Last Comment Bug 719850 - Web Console should be checked according to the selected tab
: Web Console should be checked according to the selected tab
Status: RESOLVED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Rogério Gonçalves
:
:
Mentors:
: 721227 (view as bug list)
Depends on:
Blocks: 583218
  Show dependency treegraph
 
Reported: 2012-01-20 08:44 PST by Scoobidiver (away)
Modified: 2012-01-26 05:56 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to this bug. (3.07 KB, patch)
2012-01-23 19:39 PST, Rogério Gonçalves
dao+bmo: review-
Details | Diff | Splinter Review
The second version to this bug reviewed by dao. (3.05 KB, patch)
2012-01-24 03:56 PST, Rogério Gonçalves
dao+bmo: review+
Details | Diff | Splinter Review

Description Scoobidiver (away) 2012-01-20 08:44:15 PST
When you open a Web Console in a tab, the Web Console menu is checked and stays checked as long as you haven't closed it.
When you switch to a tab without an open Web console, it should be unchecked.
Comment 1 Rogério Gonçalves 2012-01-23 19:39:37 PST
Created attachment 590980 [details] [diff] [review]
Patch to this bug.

We verified the existence of a web console opened in current tab.
Comment 2 Dão Gottwald [:dao] 2012-01-24 03:14:35 PST
Comment on attachment 590980 [details] [diff] [review]
Patch to this bug.

>+function onShowWebDeveloperMenu() {

please rename this to onWebDeveloperMenuShowing

>+  gBrowser.selectedTab.linkedBrowser.ownerDocument.getElementById("Tools:WebConsole").setAttribute("checked", HUDConsoleUI.getOpenHUD() != null);

'gBrowser.selectedTab.linkedBrowser.ownerDocument' is the same as 'document'

General approach looks good!
Comment 3 Rogério Gonçalves 2012-01-24 03:56:46 PST
Created attachment 591057 [details] [diff] [review]
The second version to this bug reviewed by dao.

We made the suggested changes.
Comment 4 Dão Gottwald [:dao] 2012-01-24 04:06:08 PST
Comment on attachment 591057 [details] [diff] [review]
The second version to this bug reviewed by dao.

thanks!
Comment 6 Dão Gottwald [:dao] 2012-01-25 05:58:33 PST
landed a second time with the right author name:
http://hg.mozilla.org/integration/mozilla-inbound/rev/aa5578d6b29f
Comment 7 Ed Morley [:emorley] 2012-01-25 18:08:44 PST
https://hg.mozilla.org/mozilla-central/rev/aa5578d6b29f
Comment 8 Panos Astithas [:past] 2012-01-26 05:56:50 PST
*** Bug 721227 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.