Last Comment Bug 719860 - Nothing happens when opening a .swf flash file directly
: Nothing happens when opening a .swf flash file directly
Status: RESOLVED FIXED
: testcase
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: ARM Android
: P2 normal (vote)
: mozilla12
Assigned To: :Margaret Leibovic
:
Mentors:
http://people.mozilla.org/~mwargers/t...
: 718983 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-20 09:07 PST by Martijn Wargers [:mwargers] (not working for Mozilla)
Modified: 2012-01-26 12:30 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
11+


Attachments
patch (1.26 KB, patch)
2012-01-24 17:36 PST, :Margaret Leibovic
jst: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Martijn Wargers [:mwargers] (not working for Mozilla) 2012-01-20 09:07:08 PST
You need to have the preference of Plugins set to "Tap to Play" to see this bug.

See url, nothing happens when loading that url.
I guess that since Flash is supported, the plugin placeholder should be shown, which you can then tap to play the Flash file.

Tested on the LG Optimus Black, Android 2.2.2.
Comment 1 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-01-20 09:18:31 PST
Actually, this is probably the same issue as bug 718983.
Comment 2 :Margaret Leibovic 2012-01-24 11:07:56 PST
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #1)
> Actually, this is probably the same issue as bug 718983.

I agree. We follow a different code path for full-page plugins like this. Snorp, I can take this, since it's a click to play issue (and I'm already looking into bug 718983).
Comment 3 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-01-24 11:11:44 PST
(In reply to Margaret Leibovic [:margaret] from comment #2)
> (In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #1)
> > Actually, this is probably the same issue as bug 718983.
> 
> I agree. We follow a different code path for full-page plugins like this.
> Snorp, I can take this, since it's a click to play issue (and I'm already
> looking into bug 718983).

Thanks!
Comment 4 :Margaret Leibovic 2012-01-24 17:19:56 PST
*** Bug 718983 has been marked as a duplicate of this bug. ***
Comment 5 :Margaret Leibovic 2012-01-24 17:36:02 PST
Created attachment 591336 [details] [diff] [review]
patch

Disclaimer: This patch fixes the bug, but I'm not really sure why.

In bug 707886, my first patch busted full page plugin tests because we weren't automatically playing those plugins, and as a fix we decided to read the plugins.click_to_play pref in nsPluginHost::IsPluginEnabledForType to decide whether or not to automatically play those plugins. However, I'm not sure this was the right way to solve the bustage, since this patch implies that this call to IsPluginEnabledForType in nsContentDLF doesn't care if a plugin is click to play or not. I think that actually must be handled later, because with this patch applied and plugins.click_to_play set to true, you get the expected "Tap to play plugin" overlay UI.
Comment 6 Johnny Stenback (:jst, jst@mozilla.com) 2012-01-25 02:32:12 PST
Comment on attachment 591336 [details] [diff] [review]
patch

Yeah, this looks right given the setup around this code.
Comment 7 :Margaret Leibovic 2012-01-25 08:21:09 PST
Landed on inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d543ed92dcbd

Switching components, since this is a core issue that would affect desktop as well.
Comment 8 Ed Morley [:emorley] 2012-01-25 18:07:49 PST
https://hg.mozilla.org/mozilla-central/rev/d543ed92dcbd
Comment 9 :Margaret Leibovic 2012-01-25 18:21:57 PST
Comment on attachment 591336 [details] [diff] [review]
patch

[Approval Request Comment]
With click to play plugins enabled, full page plugins don't work without this patch. Although this is core code, plugins.click_to_play is disabled on desktop, so this will not have any impact on desktop Firefox.
Comment 10 Alex Keybl [:akeybl] 2012-01-25 18:34:52 PST
Comment on attachment 591336 [details] [diff] [review]
patch

[Triage Comment]
Near-zero risk to desktop. Approved for Aurora.

Note You need to log in before you can comment on or make changes to this bug.