Closed Bug 719990 Opened 11 years ago Closed 10 years ago

Failure in testSearch/testReorderSearchEngines.js | could not find element ID: dn

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: u279076, Assigned: AlexLakatos)

References

()

Details

(Keywords: regression, Whiteboard: [mozmill-test-failure])

Attachments

(1 file)

This failure occurs on Nightly only across all platforms.

([object Object],(void 0),(void 0),[object Object],(void 0))
@resource://mozmill/modules/controller.js:447 
([object Object])@resource://mozmill/modules/controller.js:495
Assignee: nobody → alex.lakatos
Status: NEW → ASSIGNED
The down button changed id from "dn" to "down".
Attachment #590675 - Flags: review?(anthony.s.hughes)
Would be good to know which fixed regressed this test so we can add it to the dependency field.
Blocks: 709589
Blocks: 719974
Attachment #590675 - Flags: review?(anthony.s.hughes) → review+
Comment on attachment 590675 [details] [diff] [review]
patch v1.0 (default) [checked-in]

Landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/1b403bffb3bd (default)
Attachment #590675 - Attachment description: patch v1.0 → patch v1.0 (default) [checked-in]
Alex, please verify this is fixed in tomorrow's testruns.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
(In reply to Alex Lakatos from comment #1)
> Created attachment 590675 [details] [diff] [review]
> patch v1.0 (default) [checked-in]
> 
> The down button changed id from "dn" to "down".

Bah, sorry I didn't catch this.

(In reply to Henrik Skupin (:whimboo) from comment #2)
> Would be good to know which fixed regressed this test so we can add it to
> the dependency field.

All my fault. :(
Sorry.
Robert, no worries. We know that this can happen also because our tests aren't on mozilla-central.
Ah, right. Wasn't sure where those tests are. After all, try and tbpl looked fine. ;-)
Verified fixed as no failures in today's testrun.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 747639
Robert, your fixes on bug 709589 shouldn't be part of Firefox 12, or? Some of our tests fail due to the 'dn' button is not available anymore.

http://mozmill-ondemand.blargon7.com/#/functional/report/deba2d9c92070b21ecef8d77262e1059

Alex, would you mind checking the RC of Firefox 12.0 and when a possible backport has happened?

I would propose we do not close bugs for now until we have real tracking flags for branches which I will request soon.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(In reply to Henrik Skupin (:whimboo) from comment #10)
> Robert, your fixes on bug 709589 shouldn't be part of Firefox 12, or? Some
> of our tests fail due to the 'dn' button is not available anymore.

Parts of this bug landed for 12, one patch only for 13.

Attachment 580769 [details] [diff] which changed the button has landed for 12, from what I can see.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #11)
> Parts of this bug landed for 12, one patch only for 13.
> 
> Attachment 580769 [details] [diff] which changed the button has landed for
> 12, from what I can see.

Was that an accident? This attachment never got approval to land on the beta or now release branch.
(In reply to Henrik Skupin (:whimboo) from comment #12)
> Was that an accident? This attachment never got approval to land on the beta
> or now release branch.

No accident. Just some patches landed on trunk before 12 went to aurora and one after that.
Ok, so everything is fine. The reason why our tests failed is that Anthony run those before he merged the branches. So those results are invalid.

Anthony, for the future please make sure that we do the merge together with the source merge. Only that way we can also run our CI tests for candidate builds in the future.
Status: REOPENED → RESOLVED
Closed: 11 years ago10 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.