With smooth scrolling after scrolling stopped, hitting CTRL zooms page

RESOLVED DUPLICATE of bug 649770

Status

()

RESOLVED DUPLICATE of bug 649770
7 years ago
3 years ago

People

(Reporter: h4writer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Since enabling of smooth scrolling (bug #710372) I notice my pages sometimes unintentionally zoom.

1. Scroll to the start/end of a page
2. Wait till scrolling stopped
3. Hit CTRL (for exemple to hit CTRL+T, new tab)

Expected result:
nothing

Actual result:
page starts zooming

Best viewable when you are already at the top. Then you scroll to top (nothing should happen). And then hit CTRL. The duration between end of scrolling and buggy CTRL depends on the amount you scrolled. Therefor I think the following happens:

You scroll let's say 100px up.
You are already on top, so you see no scrolling. 
(I.e. you think there is no scrolling going)
But in fact in the background the smooth scrolling is scrolling by (e.g.) 10px per 100ms.
So that means that there is a window of 1s that can trigger this.

The fix would be to stop (smooth) scrolling when the pages hits to bottom or the top of the page. (So when the scrolling isn't visible anymore)
(Reporter)

Updated

7 years ago
Blocks: 710372
I tried and failed to reproduce this. Maybe I'm not understanding what you are describing.

This isn't meant to be condescending but I want to rule this out: you are aware that ctrl+mousewheel zooms the page? So if there was any mousewheel motion when you hit ctrl that would zoom the page.
(Reporter)

Comment 2

7 years ago
I know ctrl + scrolling is zooming

The issue is that  after scrolling. When scrolling is visible done. So no moving page anymore. And then pressing ctrl will trigger the. Zoom (as if you were pressing ctrl and zoom multiple times.).

In my case scrolling was done on laptop (so not a. Mouse scroll). But a sweep on the touchpad area.
I can't reproduce this either.

Hannes: Can you provide information on the type of trackpad that you are using and the drivers that are installed for it?
Ah, ok. I can reproduce using the touchpad, but it has nothing to do with smooth scrolling for me: happens both with and without it.
No longer blocks: 710372
(Reporter)

Comment 5

7 years ago
Really strange. The problem indeed also occurs without smooth scrolling.
The strange thing is that it never happened to me. 
But since smooth scrolling got enabled. It's happening all the time.

Could it be, that smooth scrolling triggers it faster.
I'm gonna set the preference off for the next days and see what happens.

@Jared: thinkpad lenovo w520, ubuntu 11.10 standard drivers (psmouse?)
I was testing on Ubuntu as well.
Testing on a long page without smooth scrolling you can tell that the touchpad driver is sending events at us long after I lift my finger from the touchpad. It has no idea that we are scrolled to the top and can't scroll anymore, so it will keep sending them in that case.
This looks a lot like bug 669979 and bug 574663 but those were on Mac instead of Linux....  Are the patches there at all useful to look at for the Linux code?
Component: Layout: View Rendering → Widget: Gtk
QA Contact: layout.view-rendering → gtk

Comment 9

7 years ago
I guess this is made worse because Ubuntu has kinetic scrolling on by default, which explains Timothy's observation in comment 7.

You can try disabling this with:

xinput set-prop <id> "Synaptics Coasting Speed" 0 0

(where "<id>" is the ID of your touchpad, which can be found with "xinput list").

There is a Launchpad bug somewhere for this already
(Reporter)

Comment 10

7 years ago
(In reply to Hannes Verschore from comment #5)
> Could it be, that smooth scrolling triggers it faster.
> I'm gonna set the preference off for the next days and see what happens.

I've run it now for some time with and without smooth scrolling. And the accidentally zooming stopped happening. So I see no connection between smooth scrolling and the increased rate of unintentionally zooming anymore.
Looks like this is the same as bug 649770.

Comment 12

7 years ago
(In reply to Timothy Nikkel (:tn) from comment #11)
> Looks like this is the same as bug 649770.

Looks that way; marking as a duplicate.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 649770
You need to log in before you can comment on or make changes to this bug.