Implement DOM4 DOMException types and codes

RESOLVED FIXED in mozilla13

Status

()

Core
DOM: Core & HTML
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: emk, Assigned: emk)

Tracking

({dev-doc-complete})

unspecified
mozilla13
dev-doc-complete
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

6 years ago
Created attachment 590555 [details] [diff] [review]
patch
Attachment #590555 - Flags: review?(bugs)

Comment 1

6 years ago
Comment on attachment 590555 [details] [diff] [review]
patch

I'll review this soon, but Ms2ger as a DOM4 editor could review this too.
Attachment #590555 - Flags: review?(Ms2ger)
Comment on attachment 590555 [details] [diff] [review]
patch

Looks good to me.

>--- a/dom/base/domerr.msg
>+++ b/dom/base/domerr.msg
>+DOM_MSG_DEF_(INDEX_SIZE_ERR, "IndexSizeError", "Index or size is negative or greater than the allowed amount")
>+DOM_MSG_DEF_(DOMSTRING_SIZE_ERR, "DOMSTRING_SIZE_ERR", "The specified range of text does not fit in a DOM string")

I think it's weird to have "DOMSTRING_SIZE_ERR" here, even if that's not detectable from script. Could you make them title case for consistency?
Attachment #590555 - Flags: review?(Ms2ger) → review+
(Assignee)

Comment 3

6 years ago
Created attachment 591761 [details] [diff] [review]
patch for check in; r=ms2ger, smaug

Thanks! Fixed casing.
Assignee: nobody → VYV03354
Attachment #590555 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #590555 - Flags: review?(bugs)
Attachment #591761 - Flags: review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
Comment on attachment 591761 [details] [diff] [review]
patch for check in; r=ms2ger, smaug

Er, I do want smaug to review it as well
Attachment #591761 - Flags: review?(bugs)

Updated

6 years ago
Keywords: checkin-needed
(Assignee)

Comment 5

6 years ago
(In reply to Ms2ger from comment #2)
> I think it's weird to have "DOMSTRING_SIZE_ERR" here, even if that's not
> detectable from script.
I found DOMSTRING_SIZE_ERR was still used:
https://mxr.mozilla.org/mozilla-central/source/content/base/src/nsGenericDOMDataNode.cpp#275
What should be done here?
Oh, right. That should probably just be NS_ERROR_OUT_OF_MEMORY

Updated

6 years ago
Attachment #591761 - Flags: review?(bugs) → review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
(Assignee)

Updated

6 years ago
Attachment #591761 - Attachment description: patch for check in; r=ms2ger → patch for check in; r=ms2ger, smaug
https://hg.mozilla.org/integration/mozilla-inbound/rev/0e6b1dfaa99c
Flags: in-testsuite+
Keywords: checkin-needed
Target Milestone: --- → mozilla13

Comment 8

6 years ago
Sorry had to back out for M1 orange:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=240237fb07cb

https://hg.mozilla.org/integration/mozilla-inbound/rev/738e02c121ae
Target Milestone: mozilla13 → ---
(Assignee)

Comment 9

6 years ago
Created attachment 593801 [details] [diff] [review]
patch

Grrr, bug 682299 added yet another crossorigin test which caused the test failure.
Attachment #591761 - Attachment is obsolete: true
Attachment #593801 - Flags: review?(bugs)
(Assignee)

Updated

6 years ago
Blocks: 721569
Keywords: dev-doc-needed
Comment on attachment 593801 [details] [diff] [review]
patch

r=me on the additional test change
Attachment #593801 - Flags: review?(bugs) → review+
(Assignee)

Comment 11

6 years ago
Do I need smaug's review either?
I think that's fine.
(Assignee)

Comment 13

6 years ago
Comment on attachment 593801 [details] [diff] [review]
patch

Setting the review flag again.
Attachment #593801 - Flags: review?(bugs)
What is the difference to the previous patch ?
(Assignee)

Comment 15

6 years ago
Only 1 line change.
https://bugzilla.mozilla.org/attachment.cgi?oldid=591761&action=interdiff&newid=593801&headers=1

Updated

6 years ago
Attachment #593801 - Flags: review?(bugs) → review+
(Assignee)

Updated

6 years ago
Whiteboard: [autoland-try]

Updated

6 years ago
Whiteboard: [autoland-try] → [autoland-in-queue]

Comment 16

6 years ago
Autoland Patchset:
	Patches: 593801
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=9df4a628af5e
Try run started, revision 9df4a628af5e. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=9df4a628af5e

Comment 17

6 years ago
Try run for 9df4a628af5e is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=9df4a628af5e
Results (out of 216 total builds):
    exception: 1
    success: 173
    warnings: 25
    failure: 17
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-9df4a628af5e

Updated

6 years ago
Whiteboard: [autoland-in-queue]
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
http://hg.mozilla.org/integration/mozilla-inbound/rev/dce72d0fd6aa
Keywords: checkin-needed
Target Milestone: --- → mozilla13
https://hg.mozilla.org/mozilla-central/rev/dce72d0fd6aa
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Depends on: 745498
Mentioned on
https://developer.mozilla.org/en/Firefox_13_for_developers#DOM
Updated
https://developer.mozilla.org/en/DOM/DOMException
Keywords: dev-doc-needed → dev-doc-complete

Updated

5 years ago
Duplicate of this bug: 625812
You need to log in before you can comment on or make changes to this bug.