Cursor disappears when viewing page, does not return until browser is restarted.

UNCONFIRMED
Unassigned

Status

()

Core
Widget: Cocoa
P2
normal
UNCONFIRMED
7 years ago
8 months ago

People

(Reporter: Jon Herron, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0a2) Gecko/20120122 Firefox/11.0a2
Build ID: 20120122042010

Steps to reproduce:

Viewed page @ http://www.alessioatzeni.com/mac-osx-lion-css3/

On Mac OS X 10.6.8. Autora 11.0a2 (2012-01-22)


Actual results:

Cursor disappears. Right clicking will show the context menu, but cursor does not re-appear unless right click outside of firefox (in which case cursor appears until mouse is moved back over the browser window). Had to restart the browser for the cursor to resume. Leaving the page was not enough to fix it.


Expected results:

Cursor should not have disappeared.

Comment 1

7 years ago
The cursor does indeed disappear, but it also reappears again. 
Tested in nightly on windows.

Any aurora mac folks out there?
(Reporter)

Comment 2

7 years ago
Tested again, it appears that if you click outside of the browser the cursor will reappear. Hovering back over Firefox keeps the cursor, until you click on the browser to give it focus again. Still have to restart the browser to restore it back to the correct state.
This happens because the page sets cursor: none. I don't know why it does that.
http://www.alessioatzeni.com/mac-osx-lion-css3/res/css/style.css
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

7 years ago
There are also several:

cursor:url(../img/cursor.png),auto;

Regardless, I don't see how you can mark this bug as invalid when the second 1/2 of the problem report states that the cursor does not act properly until you restart the browser. I just tried it again and even now I have no cursor. I have to click outside of firefox to see the cursor again, then as soon as firefox gets focus the cursor is gone. I don't have to be on the reported page, for instance now I am on bugzilla.mozilla.org with no cursor. After I visit the reported link, I no longer have a cursor that works properly until I restart the browser.

Even if this was just CSS hiding the cursor for one site, it should not cause the behavior of the cursor to be altered on other sites.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

7 years ago
Can't replicate that behavior at all.
I'll probe some mac testers
(In reply to Jon Herron from comment #4)
> Regardless, I don't see how you can mark this bug as invalid when the second
> 1/2 of the problem report states that the cursor does not act properly until
> you restart the browser.

Oh, sorry, I missed that part!

Comment 7

7 years ago
(In reply to Jon Herron from comment #4)
> There are also several:
> 
> cursor:url(../img/cursor.png),auto;
> 
> Regardless, I don't see how you can mark this bug as invalid when the second
> 1/2 of the problem report states that the cursor does not act properly until
> you restart the browser. I just tried it again and even now I have no
> cursor. I have to click outside of firefox to see the cursor again, then as
> soon as firefox gets focus the cursor is gone. I don't have to be on the
> reported page, for instance now I am on bugzilla.mozilla.org with no cursor.
> After I visit the reported link, I no longer have a cursor that works
> properly until I restart the browser.
> 
> Even if this was just CSS hiding the cursor for one site, it should not
> cause the behavior of the cursor to be altered on other sites.

I'm using Firefox 10 on Mac OS X 10.7.3 and it happens to me too.
Many times while I'm browsing (flash videos sites seems to have some fault!), the cursor disappears totally, although if I move the mouse, for example over bookmarks bar I can see you can select one bookmark, but you don't see the cursor.

Although, if I open a new tab the cursor reappears, how's that?
(Reporter)

Comment 8

7 years ago
I feel like I tried opening a new tab and it did not help, but I can't swear by that.

Sadly (depending on your view) it seems as if the author of the site that I used in the report has changed their css. There are no longer any cursor: declarations at all. As such, the issue does not happen on the reported site any longer. If anyone cares to investigate that particular case further perhaps the site author has the file in revision control.

Diogo - can provide a link to one of the flash video sites where you have seen the issue? If so I'll confirm the behavior is the same as what I saw.

Comment 9

7 years ago
(In reply to Jon Herron from comment #8)
> I feel like I tried opening a new tab and it did not help, but I can't swear
> by that.
> 
> Sadly (depending on your view) it seems as if the author of the site that I
> used in the report has changed their css. There are no longer any cursor:
> declarations at all. As such, the issue does not happen on the reported site
> any longer. If anyone cares to investigate that particular case further
> perhaps the site author has the file in revision control.
> 
> Diogo - can provide a link to one of the flash video sites where you have
> seen the issue? If so I'll confirm the behavior is the same as what I saw.

It seems the tab thing that I mentioned was purely luck. Maybe some CSS bug in a specific site.

What happens now is the mouse disappears on a flash video page and the only way to get it to appear is to move the hidden pointer to the dock and bring back to firefox window. But it should disappear again if you move.

Joe, I use this site to view football games and it happens on most of the links (i suppose):
http://www.vipbox.tv/sports/football.html
(Reporter)

Comment 10

7 years ago
Was not able to confirm the issue on that site, but i didn't stay around long with the pop-ups.

Comment 11

6 years ago
I've tested this on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0a2) Gecko/20120301 Firefox/12.0a2

and the cursor isn't disappearing. The same thing is happening on MacOX X 10.7.3 on latest Aurora, so WFM.

Comment 12

6 years ago
I am testing on an early 2011 MacBook Pro with 8GB of RAM and a SSD, otherwise stock, and OS X 10.7.4 (Lion) with all Apple updates and Firefox 12.0.

I am able to reliably reproduce this bug, but only after Firefox has been running for some time; about 24 hours of which perhaps 4-6 hours were active browsing. 

All I have to do is pull up a Google search page  - Google is my default search engine - and click in the search text box on the right top of the screen. The cursor disappears. I can then right click and sometimes that causes it to reappear, but usually not. Moving the cursor outside of the Firefox window does not bring it back. I was not able to find a reliable way to bring the cursor back other than moving it randomly. Most of the time if I hover over an item in the dock, the cursor comes back. But just jiggling it around also brings it back eventually. Clicking again in the text box causes it to disappear again.

I also noted that closing out Firefox - killing the program, not just closing the window - and then restarting it causes it to behave normally for a while. Then it starts again.

It appears that no other program causes this behavior, it seems limited to Firefox 12.0.

In my opinion this is a critical bug for Mac users, as the the computer is essentially unusable with the program in its current state. I have switched back to Safari for the time being and I will check back occasionally to see if any progress has been made. You just can't use a computer without a cursor :)

Comment 13

6 years ago
Am on an early  2009 Mac Pro with 32 GB of RAM, otherwise stock, and OS X  Lion 10.7.4 (11E53) and I suffer intermittently from the disappearing cursor with Firefox 12.0.   I cannot reproduce the problem reliably,  but it happens, e.g., when browsing photographs on flickr.com.   When it happens the only cure I have found is to restart Firefox.

Comment 14

6 years ago
Using late 2009 iMac i7, 16 GB RAM, Firefox 13.0.1. After prolonged use, generally with multiple tabs open, the cursor disappears when Firefox has the focus. It reappears when giving focus to another process and disappears again when returning focus to Firefox. Quitting and restarting Firefox gives normal function again, but the process repeats with prolonged use.

Comment 15

6 years ago
See also bug 717340, and bugs mentioned in bug 717340 comment 6.
As this bug seems limited to Firefox 12 it may be best to close this. Mark, are you still seeing the problem? I've been unable to replicate it. Thanks!
Flags: needinfo?(mlewus)

Comment 17

5 years ago
My later experiences with this problem suggest that it occurs only after Flash has been used for some time. At least I cannot recall it happening without Flash being used in one or more browser tabs. The disappearing cursor is a problem in other browsers, too, so it appears that the origin is in Flash or Flash in combination with the OS.

Comment 18

5 years ago
(In reply to Liz Henry :lizzard from comment #16)
> As this bug seems limited to Firefox 12 it may be best to close this. Mark,
> are you still seeing the problem? I've been unable to replicate it. Thanks!

No, I have not seen it for some time. OK to close, thanks.

Updated

5 years ago
Flags: needinfo?(mlewus)

Comment 19

5 years ago
Firefox 19.0.2 on Mac OS 10.8 here. Cursor disappeared after watching a bunch of flash videos.

Comment 20

5 years ago
Also, this hasn't happened to me in Chrome, with same OS, same websites.
Mina, can you give some sample sites where this happens? I have not been able to replicate it. Thanks! Also, can you let us know what version of Flash you are running?
Component: Untriaged → Plug-ins
Flags: needinfo?(malmasry)
Product: Firefox → Core
Version: 11 Branch → unspecified

Comment 22

5 years ago
It consistently happens at least here: http://pokemonepisode.org/ after watching a couple of episodes but would also probably happen on the website Diogo Lemos linked to if someone looked.

Running flash 11.9.900.117 I believe it's the latest.
Flags: needinfo?(malmasry)
(In reply to Mina Almasry [:mina] from comment #20)
> Also, this hasn't happened to me in Chrome, with same OS, same websites.

Opera and Chromium would be better comparisons as Chrome uses a custom Flash version.

Comment 24

3 years ago
I just had this happen running FF 37.0.2 and OSX Yosemite 10.10.3. I was on Facebook at the time.  

I found this article that hints that maybe it is not something restricted to FF. I've had it happen several times though in the last year or two, and only in FF.

They say pressing Command + Tab might make the cursor come back:
http://osxdaily.com/2013/07/19/disappearing-mouse-cursor-mac-os-x/

Comment 25

3 years ago
I am new to Mac. Have a 2013 iMac i5, 16GB DDR3, running OSX 10.8.3 and Firefox 37.0.2. Am experiencing this problem, when I view ABC iView (catch-up TV. Uses Flash). Have no such problem on PC, so if it's Flash, it has something to do with the combination of Apple/OSX.
It'd help if someone could post a testcase (a URL plus steps-to-reproduce) that doesn't require an account.
Note that this "new" bug may not be the one that was originally reported.

Comment 28

2 years ago
I am new to Mac. Have a 2013 iMac i5, 16GB DDR3, running OSX 10.8.3 and Firefox 37.0.2. Am experiencing this problem, when I view ABC iView (catch-up TV. Uses Flash).  http://www.icct20worldcup2016live.com/

Comment 29

2 years ago
I've got this also, Firefox 37.0.2. I also have this problem, when clicking on a canvas with cursor : none after having the cursor previously set to: cursor: url("../img/cursor.png") 4 2, cell !important;

Comment 30

2 years ago
This should happen to you if you visit overload.blacktowerentertainment.com/, create a character, enter the armory and view the "vault". Click on the canvas and your cursor should disappear and only reappear if you select the file, edit, view history menu at the top of the screen.
(In reply to alex from comment #30)
> This should happen to you if you visit
> overload.blacktowerentertainment.com/, create a character, enter the armory
> and view the "vault". Click on the canvas and your cursor should disappear
> and only reappear if you select the file, edit, view history menu at the top
> of the screen.

This reproduces it for me! Thanks!

Comment 32

2 years ago
Markus that is a production build of the game and we are going to actually "fix" the issue temporarily by assigning the cursor:crosshair; instead of cursor:none. You can still reproduce this by setting the element property to none manually.

Comment 33

2 years ago
This has been happening to me for at least a decade on Firefox on OS X. I've never had it occur in any other application - including Thunderbird.

It also seems to be inconsistent in behaviour. Often recreating the actions that led to the cursor disappearing will not result in a problem the second time around.

Creating a private window and closing it fixes the issue for me.

Comment 34

2 years ago
This is happening to me with Open365 when I try to use any of the LibreOffice Online applications from Firefox 47.0.1 on OSX 10.11.3 (El Capitan).

The sites seems to work OK in Chrome.

Comment 35

2 years ago
here's how i reproduce it reliably:

1. go to ted.com and play any video.
2. click on the fullscreen button in the lower right.
3. wait for the cursor to disappear.
4. it doesn't appear in any firefox windows anymore, neither when trying to move over the fullscreen video, nor after have exited fullscreen mode.

the private window trick from Comment 33 doesn't work if i open it with the keyboard shortcut, while the cursor is gone. i need to first click on another application's window, so that the cursor appears, and then, click directly on the firefox menubar -> file -> new tab/window/private window. private is not required, any windows or tab is ok.

this is on firefox 48.0.1.

Comment 37

a year ago
For what it's worth, I haven't noticed this issue in a long time (~FF48).

It's difficult to pinpoint a cause, but I think it's worth mentioning that the problem stopped around the same time I uninstalled Flash Player.

Has anyone else noticed this in recent releases?

Comment 38

a year ago
Yes, this happens when I watch HBO shows with the most recent release.  I go full screen on hbonow, wait for the cursor to disappear, exit full screen, open a new tab, and the cursor will disappears on the new tab.

I have to open up a new window to see the cursor. 

FF 52.0.2 (64-bit)
OS X 10.12.4

Comment 39

a year ago
This has been happening to me for the last month.  I switched from Chrome because I can't get flash player to work.  Flash works fine on Firefox but as soon as I am watching flash content (usually fullscreen) the cursor disappears (not consistently though) which is a bug that really bugs me!  

URL where it usually happens is http://iview.abc.net.au/ which automatically plays content fullscreen. 

Browser FF 52.0.2 (64-bit)
OSX Yosemite 10.10.5 (14F27)

I recently updated from Elcapitan hoping that would fix bugs in both browsers.  Might be that hardware (MacBook Pro (13-inch, Early 2011)) doesn't support latest flash player?  Who am I kidding.. I know nothing about computers!!

Help?  No way do I want to go to Safari.

Comment 40

a year ago
This thread describes exactly what I've been experiencing: my cursor sporadically and unpredictably disappears while I'm watching videos. I'm on Mac 10.12.5, Firefox 54.0. (This has been happening for a few years, using previous versions of OS and Firefox.) 

What I'd like to add is that I'm able to get the cursor back by clicking anywhere in the Finder menu bar and then returning to the browser window. If I click on the Finder desktop, however, or command-tab to any other open application, the cursor disappears again when I return to the browser. It's only restored after clicking specifically in the menu bar. 

I hope this tidbit is helpful.

Comment 41

9 months ago
This is happening on firefox(FF) @MacOS only. I have been using chrome, and I noticed this when I decided to use FF instead.

Comment 42

9 months ago
For investigation. long standing osx bug, might be flash related, unknown. sounds likeit might be our cursor handling related to video playback.
Component: Plug-ins → Widget: Cocoa
Flags: needinfo?(spohl.mozilla.bugs)
Priority: -- → P2
Yes, this is believed to be Flash related. If anyone can reproduce with Flash disabled, please let us know.
Flags: needinfo?(spohl.mozilla.bugs)
You need to log in before you can comment on or make changes to this bug.