[adbe 3558357] disappearing cursor when YouTube or Vimeo video playing

RESOLVED INCOMPLETE

Status

External Software Affecting Firefox
Flash (Adobe)
--
major
RESOLVED INCOMPLETE
7 years ago
2 years ago

People

(Reporter: Derek Williams, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120104111456

Steps to reproduce:

had multiple sites open on tabs
played a video on YouTube or Vimeo
after playing for a while, moved the mouse to select something elsewhere


Actual results:

the cursor vanished, but reappeared as soon as clicked outwith Firefox to switch to Finder or another app.

hard to reproduce, but will add extra steps when I can


Expected results:

The arrow cursor should always be visible.

Comment 1

7 years ago
This bug can be reliably reproduced with multiple video sites that use flash video.
Just set the flash video to fullscreen mode and the cursor disappears for all Firefox windows. Switch to any other app or finder and the cursor reappears. Select any Firefox window and the cursor disappears again.

1) goto http://watchseries.eu/serie/ben_10:_ultimate_alien

2) follow links to view any episode

3) choose novamov.com

4) when video starts playing select fullscreen

5) cursor disappears in a few seconds

Comment 2

7 years ago
I'm using Firefox 10 on Mac OS X 10.7.3 and it happens to me too. Many times while I'm browsing with flash video sites, the cursor disappears totally, although if I move the mouse, for example over bookmarks bar I can see you can select one bookmark, but you don't see the cursor.

But if I open a new tab the cursor reappears, how's that?

Comment 3

7 years ago
the same thing happens when you load a java applet, the cursor just disappears just by loading any applet. I am not sure if it's the same issue, i opened another ticket.
other users reporting the same issue
https://bugzilla.mozilla.org/show_bug.cgi?id=717340
(Reporter)

Updated

7 years ago
Version: 10 Branch → 11 Branch
(Reporter)

Updated

6 years ago
Version: 11 Branch → 12 Branch

Comment 4

6 years ago
This bug is even stranger than you think...

This bug can be reproduced by playing a flash video fullscrean in safari on one monitor and the cursor dissapears in all Firefox windows on other monitors.

The cursor only dissapears when the cursor is over a Firefox window. 

If the flash video is not playing fullscrean, then the cursor is displayed properly.

This bug also requires multiple monitors.
(Reporter)

Updated

6 years ago
Severity: normal → major

Comment 5

6 years ago
confirming same bug different specifics.. One monitor mac running osx 10.7.4 and FF 12.0:
can't seem to make it reoccur at will however, although, it does seem to involve multiple tabs playing flash video, maybe related to also playing flash in safari(will try to confirm), however once it began, if I closed all tabs containing flash video, it stopped, and upon opening multiple new tabs with flash, it does not seem to reoccur... weird...

also worth noting, it would occur upon FF losing focus then regaining it(after sleep and logging back in). Mouse would be restored upon again losing and regaining focus(either hovering over dock/switching screens/clicking desktop then clicking back in FF)

also, tabs, menubar buttons,etc would respond(highlight) if hovered over with my *invisible* cursor

VERY ANOYING while it is active!!!!

Comment 6

6 years ago
The bug eli filed as mentioned in comment #3 seems to be bug 724381, which was marked duplicate of bug 718939, which is about the text cursor.

Older reports of mouse pointer disappearing with Flash plug-in, but on Windows: bug 243718, bug 582622, bug 639237.
Component: Untriaged → Plug-ins
Product: Firefox → Core

Comment 7

5 years ago
(In reply to Aleksej [:Aleksej] from comment #6)
> The bug eli filed as mentioned in comment #3 seems to be bug 724381, which
> was marked duplicate of bug 718939, which is about the text cursor.

but that was already fixed when this bug was filed, no?

Derek do you still see this?
Flags: needinfo?(derek)
Whiteboard: [closeme 2013-05-20]

Comment 8

5 years ago
This bug is still reproducable 100% of the time as of Firefox 20.0.
(Reporter)

Updated

5 years ago
Version: 12 Branch → 20 Branch
Easy to reproduce for me by:
* open 1 browser window (A) on primary display
* open 1 browser window (B) on secondary display
* open youtube video in B, go fullscreen
* click on A
... no mouse cursor visible.
The previous comments suggest that no multi-display setup is required for this.

Note that i'm seeing the same behaviour in Safari.
Status: UNCONFIRMED → NEW
Component: Plug-ins → Flash (Adobe)
Ever confirmed: true
Flags: needinfo?(derek)
Product: Core → Plugins
Whiteboard: [closeme 2013-05-20]
Version: 20 Branch → 11.x

Comment 10

5 years ago
WFM, FF 21b, Mac 10.8
Tried loading full screen video on one monitor with Safari, Chrome, or FF itself. FF window on other screen retained mouse cursor.

Comment 11

5 years ago
I just re-confirmed that this bug occurs with when playing a full screen flash video in Safari.

OS X 10.6.8 with all fixes applied
Firefox 20.0
Safari 5.1.8
3 monitors
Multiple Firefox windows open on right 2 monitors with front-most window 
<https://bugzilla.mozilla.org/show_bug.cgi> showing this bug
Safari open on left monitor playing flash video
<http://www.youtube.com/watch?v=Qlj5TWX_Wzs> 
Switch flash video to fullscreen and click on Firefox window and cursor dissapears.

Comment 12

5 years ago
Thanks for the report.

I opened an internal Adobe bug 3558357 to get this looked at.  The issue seems to be specific to the NPAPI Flash Player, and I haven't chased it back through previous versions, but it's probably been around for a long time.  

For what it's worth, the PPAPI version of Flash Player embedded in Chrome does not have this problem; however, when we disable it and revert to the NPAPI plug-in, we see this problem there as well. 

Since it spans all browsers that consume the Plug-In, it's probably either a straightforward fix, or we're hitting some brutal limitation in what we can infer about focus via the NPAPI.  I'll update this bug when we know more.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(In reply to Jeromie Clark from comment #12)
> Since it spans all browsers that consume the Plug-In, it's probably either a
> straightforward fix, or we're hitting some brutal limitation in what we can
> infer about focus via the NPAPI.

Unless there are some weird corner cases, NPCocoaEventFocusChanged & NPCocoaEventWindowFocusChanged should be sufficient to cover this.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: disappearing cursor when YouTube or Vimeo video playing → [adbe 3558357] disappearing cursor when YouTube or Vimeo video playing

Comment 14

5 years ago
Still WFM on MBP with latest OSX (was 10.8, now 10.9). Mouse cursor remains functional on both screens. It disappears if I leave it hovered over the video, then reappears when I move it.

Possibly a bug in OSX 10.7 and below?

Comment 15

5 years ago
Reproduced this on OSX 10.8.5, personal build from:

$ git log -n 1
commit 2426e60da7c4ac320d67e5c3234e366e503c0cf5
Merge: a6fe1ae 1e976cb
Author: Ryan VanderMeulen <ryanvm@gmail.com>
Date:   Wed Dec 11 22:02:30 2013 -0500


Reproduced the symptom with:

 http://www.boohbah.com/zone.html

See https://bugzilla.mozilla.org/show_bug.cgi?id=243718#c2

Open a new tab and one does not see the cursor. One sees the effect of the cursor, as the "recent sites" images get activated by the invisible cursor moving over them....

Updated

4 years ago
Duplicate of this bug: 719864

Comment 17

2 years ago
I'm closing a lot of bugs which are filed as Adobe Flash bugs which are either irrelevant, not actionable, or not serious enough to track in the Mozilla bug tracker. For the most part, Flash bugs should be filed in Adobe bugbase, and we'll only track a few highly-critical issues in the Mozilla tracker.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago2 years ago
Resolution: --- → INCOMPLETE

Comment 18

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 11.x → unspecified
You need to log in before you can comment on or make changes to this bug.