Closed Bug 720373 Opened 8 years ago Closed 7 years ago

Use SO_VERSION from environment on OpenBSD to set DLL_SUFFIX

Categories

(Directory :: LDAP C SDK, defect)

x86
OpenBSD
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gaston, Assigned: gaston)

References

Details

Attachments

(2 files)

As was already done in mozilla-central, (see http://mxr.mozilla.org/mozilla-central/source/configure.in#2728 , and bug #648721), we use this patch in OpenBSD's portstree/packages to control the library versionning (see http://www.openbsd.org/cgi-bin/cvsweb/ports/mail/mozilla-thunderbird/patches/patch-ldap_sdks_c-sdk_configure_in?rev=1.1). So let's use the same snippet from mozilla-central, ie use SO_VERSION from the environment if present, and default to 1.0 otherwise.
Blocks: openbsdmeta
Assignee: nobody → landry
Attachment #590715 - Flags: review?(richm)
Attachment #590715 - Flags: review?(richm) → review+
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/projects/ldap-sdks/rev/e104d6403813

Bug 720328 will be incorporating this into comm-central.
Blocks: 720328
Status: NEW → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Doh i feel so dumb.. now that the patch ended up in Tb 12, i realized it was doing the wrong thing as "adding an extra ."... i ended up with libprldap60..so.1.0, which is not what was intended. So this patch should finally fix it.
Attachment #619032 - Flags: review?(richm)
And reopening...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
review ping ?
Attachment #619032 - Flags: review?(richm) → review+
Blocks: 834214
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.