Completely silence RIL worker by default

RESOLVED FIXED in mozilla13

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: philikon, Assigned: philikon)

Tracking

unspecified
mozilla13
All
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][lang=js][mentor=philikon])

Attachments

(1 attachment)

Lots of debug() calls in ril_worker.js still not guarded by the DEBUG const. We might also want to flip the DEBUG flag to false in RadioInterfaceLayer.js.
(Assignee)

Updated

5 years ago
Whiteboard: [good first bug][lang=js][mentor=philikon]
Created attachment 592262 [details] [diff] [review]
v1
Assignee: nobody → philipp
Attachment #592262 - Flags: review?(kyle)
Comment on attachment 592262 [details] [diff] [review]
v1

Review of attachment 592262 [details] [diff] [review]:
-----------------------------------------------------------------

Why not wrap the debug call in something higher up (i.e. radioDebug() that has the DEBUG check integrated)? Just seems like it might be a bit cleaner. 

Also, instead of wrapping debug, is there any way we could change the logcat message to prefix with RIL? These messages are completely viable over in the radio logs, as that's what stock android does. The problem is, that's usually a #define in the compilation unit, which we don't exactly have now.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 722341
Comment on attachment 592262 [details] [diff] [review]
v1

Review of attachment 592262 [details] [diff] [review]:
-----------------------------------------------------------------

r=me after discussing next steps with philikon. This will work for right now.
Attachment #592262 - Flags: review?(kyle) → review+
Summarizing IRL discussion:

* Explicit DEBUG checks prevent us from potentially having to construct expensive log strings.
* We should have more powerful logging in chrome-privileged environments, but it shouldn't block this from landing. Filed bug 723354.
https://hg.mozilla.org/mozilla-central/rev/aec5edf48e93
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
(Assignee)

Updated

5 years ago
Depends on: 724994
You need to log in before you can comment on or make changes to this bug.