Closed Bug 720832 Opened 8 years ago Closed 6 years ago

Add the ability to watch component starting with a string

Categories

(bugzilla.mozilla.org :: Extensions, enhancement)

Production
enhancement
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: benjamin, Assigned: glob)

References

Details

Attachments

(1 file)

One of the longstanding tensions in bugzilla (and BMO in particular) is having many or few bugzilla products/components. One of the features we've been talking about for a long time is "solving" this tension by having deep hierarchies of components. Copied below is what I posted to dev.planning about this a while back:


A. make components hierarchical. That is, all bugs in Firefox:DOM:Tables are also in Firefox:DOM and Firefox.

A.1: The benefits of this are that we wouldn't need "General" components: instead bugs would be filed in "Firefox" and triage would have the goal of moving the bug to the most specific available component.

A.2: people could watch entire groups or just specific components depending on their level of time/interest.

A.3: component owners and managers could much more easily query and prioritize entire groups

A.4: querying by component would not be completely broken for newcomers

A.5: we could move all the Firefox bugs back into a single "Firefox" product in bugzilla, with subgroups for frontend/mobile/gecko if we think that is necessary. This would remove the most significant source of confusion for newcomers.

I don't know how this would actually map to bugzilla database structures, but I imagine that we could have colon-separated components such as "Firefox:DOM:Tables" and have the UI do the hierarchical organization.

I realize that this is a pretty huge request, and I'm happy to talk about it if there are halfway measures which would provide most of the same benefits.
Severity: normal → enhancement
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #0)
> A. make components hierarchical. That is, all bugs in Firefox:DOM:Tables are
> also in Firefox:DOM and Firefox.

on principal i like this idea, however i hold grave concerns over the work required to achieve this.  this part of this request is bug 43940.

really you're talking about hierarchical products, which is more complicated as each product has their own set of versions, milestones, custom fields, and security.  due to various entry-points to bugzilla (web, webservices, email) i don't think making this a ui-only modification would work :|


> A.1: The benefits of this are that we wouldn't need "General" components:
> instead bugs would be filed in "Firefox" and triage would have the goal of
> moving the bug to the most specific available component.

we're moving away from bugs landing in general anyway (for our major products).  as per bug 713165 firefox bugs land in "untraiged" now, and we're moving towards an "untriaged product" to make it easier for triage to manage their work.

> A.2: people could watch entire groups or just specific components depending
> on their level of time/interest.

you can do that right now with component watching.

> A.3: component owners and managers could much more easily query and
> prioritize entire groups
> 
> A.4: querying by component would not be completely broken for newcomers
>
> A.5: we could move all the Firefox bugs back into a single "Firefox" product
> in bugzilla, with subgroups for frontend/mobile/gecko if we think that is
> necessary. This would remove the most significant source of confusion for
> newcomers.

if the confusion is with regards to finding bugs cross-product/cross-component then we can absolutely work further on related product searching (this already exists in the possible-duplicates part of the guided bug entry, as well as in instant-search).

we should be able to flesh out modifications to our various search forms to make this experience better.  i'm not against turning instant-search into a new-to-bugzilla geared search.
Component: Administration → General
QA Contact: administation → general
At least in the particular case of Firefox, I'd be fine with Firefox moving back into a single product if we had hierarchies, since it does share the same basic TM/security setup across Core/Toolkit/Firefox.

Component watching is currently pretty fragile if we keep subdividing components: every time we do any subdivision everyone has to add the new subdivision to their list of watchers... I have discovered 4 or 5 new components that I would be watching if I knew about them fairly recently.

But yeah, I understand that this is a big request, and apparently basically a duplicate of bug 43940 so if you just want to dup it that's fine with me.
rather than dupe this to bug 43940, i've focused on:

(In reply to Benjamin Smedberg  [:bsmedberg] from comment #2)
> Component watching is currently pretty fragile if we keep subdividing
> components: every time we do any subdivision everyone has to add the new
> subdivision to their list of watchers... I have discovered 4 or 5 new
> components that I would be watching if I knew about them fairly recently.

i'm going to morph this bug into updating component watching to support watching based on "component name start with X", which should address that particular issue, and is a lot more viable short-term.

in terms of implementation, one way to do this would be to hook into component admin actions, and update a the component_watch table automatically as components are added/removed/renamed.
Component: General → Extensions: Component Watching
QA Contact: general → comp-watch
Summary: Develop "hierarchical components" for bugzilla or bugzilla.mozilla.org → Add the ability to watch component starting with a string
Assignee: nobody → glob
Status: NEW → ASSIGNED
Attached patch 720832_1.patchSplinter Review
it was very hard to resist the temptation to refactor large parts of this old code.

this patch:
- adds the ability to specify prefixes on the component watch screen
- uses this prefix when calculating bugmail recipients
- and an 'id' field to component_watch table which simplifies the admin ui
Attachment #8422217 - Flags: review?(dkl)
Comment on attachment 8422217 [details] [diff] [review]
720832_1.patch

Review of attachment 8422217 [details] [diff] [review]:
-----------------------------------------------------------------

very nice. r=dkl
Attachment #8422217 - Flags: review?(dkl) → review+
schema only:

To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   e33a04d..f0cab24  master -> master
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   d9b38fd..d7f26d1  master -> master
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Component: Extensions: ComponentWatching → Extensions
You need to log in before you can comment on or make changes to this bug.