handle webapp manifests with a UTF8 BOM in the validator

RESOLVED FIXED in 6.4.0

Status

addons.mozilla.org Graveyard
Add-on Validation
P1
normal
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: kumar, Assigned: basta)

Tracking

unspecified
6.4.0
x86
Mac OS X

Details

Attachments

(1 attachment)

Created attachment 591523 [details]
webapp manifest with a BOM

Attached is a manifest encoded with a BOM (as is typical for Windows files). The BOM needs to be stripped out of the manifest before parsing. This is how the AMO does it: https://github.com/mozilla/zamboni/commit/d476408b6eb11a1888952a5a4c75822eb8ef0fba

See also bug 711538
Assignee: nobody → mattbasta
Priority: -- → P1
Target Milestone: --- → 6.4.0
Summary: handle webapp manifests with a UTF8 BOM → handle webapp manifests with a UTF8 BOM in the validator
Duplicate of this bug: 721051
Merged https://github.com/mozilla/amo-validator/commit/7fb5281aae973de9a2f065375a139e33ec7032c2
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.