Last Comment Bug 721551 - Need split builds for Fennec that serve XUL Fennec for tablets and native Fennec for phones
: Need split builds for Fennec that serve XUL Fennec for tablets and native Fen...
Status: RESOLVED DUPLICATE of bug 719560
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: P1 normal (vote)
: ---
Assigned To: Matt Brubeck (:mbrubeck)
:
Mentors:
https://market.android.com/search?q=p...
Depends on: 760740
Blocks: 719560
  Show dependency treegraph
 
Reported: 2012-01-26 15:19 PST by Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( )
Modified: 2013-12-10 10:00 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
beta+


Attachments

Description Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-01-26 15:19:15 PST
Catlee published a Fennec split build called  "SplitReleaseTest" from blassey on the Android Market.
The purpose of this split build was that it would serve XUL Fennec for tablets and native Fennec for phones.

While testing this, it gave a native Fennec build on my EEETransformer TF101. Mbrubeck also tested it on his Motorola Xoom and it also gave a native Fennec build. About:firefox gave 12.0a1 (2012-01-19).
Comment 1 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-01-27 10:28:37 PST
So afaik, we need a Fennec 11 split build that serves XUL Fennec for tablets and Native Fennec for phones, right?
Is there a new build planned that I would need to test on various devices (for which I would use DeviceAnywhere)?
Comment 2 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-01-27 10:33:34 PST
I guess it also might depend on which os is on the device.
Comment 3 Matt Brubeck (:mbrubeck) 2012-01-27 12:21:30 PST
I built native Fennec with the latest patch from 719560 and with a local patch to set MOZ_MOBILE_COMPAT=Phones in branding/unofficial/configure.sh.  When I upload it to the Market, the APK details say Supported screens: small-xlarge.  (It should be "small-large".)

So it looks like the manifest setting isn't working correctly, or isn't being read by the Market.  The AndroidManifest.xml file in my objdir does include <supports-screens android:xlargeScreens="false"/>, so at least my build seems to be working as expected...
Comment 4 Matt Brubeck (:mbrubeck) 2012-01-27 12:30:10 PST
I tried adding android:resizeable="false" to the manifest but it made no difference.
Comment 5 Matt Brubeck (:mbrubeck) 2012-01-27 13:45:05 PST
As far as I can tell, the Android Market can treat an APK as tablet-only, but not as phone-only.  Any app that supports small screens will also install on large-screen devices, and will just use zooming or letterboxing.
Comment 6 Matt Brubeck (:mbrubeck) 2012-01-27 13:46:56 PST
http://developer.android.com/guide/appendix/market-filters.html#manifest-filters

"As a general rule, Market assumes that the platform on the device can adapt smaller layouts to larger screens, but cannot adapt larger layouts to smaller screens. Thus, if an application declares support for "normal" screen size only, Market makes the application available to both normal- and large-screen devices, but filters the application so that it is not available to small-screen devices."
Comment 7 Matt Brubeck (:mbrubeck) 2012-01-27 13:57:26 PST
As a workaround, it looks like it might work if we make sure the XUL (tablet) build has a higher version code than the native (phone) build.  Testing this now.
Comment 8 Matt Brubeck (:mbrubeck) 2012-01-27 14:07:32 PST
(In reply to Matt Brubeck (:mbrubeck) from comment #7)
> As a workaround, it looks like it might work if we make sure the XUL
> (tablet) build has a higher version code than the native (phone) build. 
> Testing this now.

This seems to work.  You can test this at:
https://market.android.com/details?id=org.mozilla.fennec_mbrubeck
Comment 9 Tony Chung [:tchung] 2012-01-27 14:16:00 PST
(In reply to Matt Brubeck (:mbrubeck) from comment #8)
> (In reply to Matt Brubeck (:mbrubeck) from comment #7)
> > As a workaround, it looks like it might work if we make sure the XUL
> > (tablet) build has a higher version code than the native (phone) build. 
> > Testing this now.
> 
> This seems to work.  You can test this at:
> https://market.android.com/details?id=org.mozilla.fennec_mbrubeck

In a meeting, but i'll give this a spin on my tablet and devices in the next hour.  Matt, How long will you be leaving this up?
Comment 10 Matt Brubeck (:mbrubeck) 2012-01-27 14:23:39 PST
Here are new builds that RelEng can use for Market testing:
https://people.mozilla.com/~mbrubeck/split/

The "xul.all.apk" build has a lower version code than the other two builds, and is marked compatible with all devices.  This can be used as a starting state for upgrade testing.

I'll leave my own market listing up for testing until RelEng is ready to create their own.  (Then I'll need to take mine down, if they want to use the same builds.)

I've tested this myself on HTC T-Mobile G2 (Android 2.3) and Motorola Xoom (Android 4).
Comment 11 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-01-27 15:20:05 PST
I tested this on my EEETransformer TF101, there I get the XUL build and on my LG Optimus Black phone, it returns the native Fennec build. This is all correct.
On a 7 inch tablet, it should return the native Fennec build.
Naoki, I heard you have a HTC Flyer. Could you perhaps test the build with the link from comment 8?
Comment 12 Matt Brubeck (:mbrubeck) 2012-01-27 15:59:38 PST
I tried this on my 7" Galaxy Tab (Android 2.3) and got the correct (native) build.
Comment 13 Tony Chung [:tchung] 2012-01-27 16:58:31 PST
QA has also tested this on a few more devices, and so far, phones are serving up Native Fennec, and 10" tablets are serving up Fennec XUL.

I'd like to run one more test on a 7" HTC Flyer tonite before giving matt's build a blessing.   

As i understand this, 7" tablets should show the Fennec Native build.  

Naoki has this device, and will get to it this evening.

Matt, can you keep your build in the market a few more hours?   We'll let you know by email when to pull it down.
Comment 14 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-01-28 20:51:12 PST
FYI, I commented in a different bug.  The Flyer will end up getting the native build.
Comment 15 Tony Chung [:tchung] 2012-01-29 22:33:03 PST
(In reply to Tony Chung [:tchung] from comment #9)
> (In reply to Matt Brubeck (:mbrubeck) from comment #8)
> > (In reply to Matt Brubeck (:mbrubeck) from comment #7)
> > > As a workaround, it looks like it might work if we make sure the XUL
> > > (tablet) build has a higher version code than the native (phone) build. 
> > > Testing this now.
> > 
> > This seems to work.  You can test this at:
> > https://market.android.com/details?id=org.mozilla.fennec_mbrubeck
> 
> In a meeting, but i'll give this a spin on my tablet and devices in the next
> hour.  Matt, How long will you be leaving this up?

Matt, Feel free to pull it anytime we're ready.  We're done testing for now.
Comment 16 Alex Keybl [:akeybl] 2012-02-02 12:42:53 PST
Is there anything that needs to land on Beta 11 here? Or does bug 719560 cover all remaining work?
Comment 17 Matt Brubeck (:mbrubeck) 2012-02-06 14:11:59 PST
Nothing needed to land here.
Comment 18 Brad Lassey [:blassey] (use needinfo?) 2012-02-06 14:58:40 PST

*** This bug has been marked as a duplicate of bug 719560 ***

Note You need to log in before you can comment on or make changes to this bug.