Closed Bug 721644 Opened 12 years ago Closed 12 years ago

java.lang.RuntimeException: Unable to start activity ComponentInfo{org.mozilla.fennec/org.mozilla.fennec.App}: java.lang.ClassCastException: android.graphics.drawable.GradientDrawable when trying to start ES single locale build

Categories

(Firefox for Android Graveyard :: General, defect)

12 Branch
ARM
Android
defect
Not set
critical

Tracking

(firefox11 wontfix, firefox12 wontfix, blocking-fennec1.0 beta+)

RESOLVED DUPLICATE of bug 720121
Tracking Status
firefox11 --- wontfix
firefox12 --- wontfix
blocking-fennec1.0 --- beta+

People

(Reporter: nhirata, Unassigned)

References

Details

(Keywords: crash, reproducible, Whiteboard: [native-crash])

Attachments

(1 file)

Attached file logcat
1. install http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-l10n/fennec-12.0a1.es-ES.android-arm.apk
2. launch

Expected: Fennec will launch
Actual: single locale build crashes; multi locale build does not.

01-26 23:30:55.392: W/dalvikvm(6024): threadid=1: thread exiting with uncaught exception (group=0x4001d7d0)
01-26 23:30:55.400: E/AndroidRuntime(6024): FATAL EXCEPTION: main
01-26 23:30:55.400: E/AndroidRuntime(6024): java.lang.RuntimeException: Unable to start activity ComponentInfo{org.mozilla.fennec/org.mozilla.fennec.App}: java.lang.ClassCastException: android.graphics.drawable.GradientDrawable
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2663)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2679)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.app.ActivityThread.access$2300(ActivityThread.java:125)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2033)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.os.Handler.dispatchMessage(Handler.java:99)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.os.Looper.loop(Looper.java:123)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.app.ActivityThread.main(ActivityThread.java:4627)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at java.lang.reflect.Method.invokeNative(Native Method)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at java.lang.reflect.Method.invoke(Method.java:521)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:871)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:629)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at dalvik.system.NativeStart.main(Native Method)
01-26 23:30:55.400: E/AndroidRuntime(6024): Caused by: java.lang.ClassCastException: android.graphics.drawable.GradientDrawable
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at org.mozilla.gecko.BrowserToolbar.onFinishInflate(BrowserToolbar.java:162)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.view.LayoutInflater.rInflate(LayoutInflater.java:626)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.view.LayoutInflater.parseInclude(LayoutInflater.java:702)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.view.LayoutInflater.rInflate(LayoutInflater.java:614)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.view.LayoutInflater.inflate(LayoutInflater.java:407)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.view.LayoutInflater.inflate(LayoutInflater.java:320)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.view.LayoutInflater.inflate(LayoutInflater.java:276)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at com.android.internal.policy.impl.PhoneWindow.setContentView(PhoneWindow.java:200)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.app.Activity.setContentView(Activity.java:1647)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at org.mozilla.gecko.GeckoApp.onCreate(GeckoApp.java:1501)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1047)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2627)
01-26 23:30:55.400: E/AndroidRuntime(6024): 	... 11 more
01-26 23:30:55.400: W/ActivityManager(2640):   Force finishing activity org.mozilla.fennec/.App
I do not seem to find any previous l10n repacks to find the regression range.
Keywords: reproducible
Tried Japanese build.  Same issue.  Galaxy S Captivate, 2.2, 2012-01-26 build

Tried Nexus S 2.3, same build.  Same issue.  Crash on start.

Tried Galaxy S II, 2.3 same build.  same issue.  Crash on start.

Tried on Toshiba Thrive 3.0 same build same issue. Crash on start
The only single locale build that I can find so far that works is the english version, located here : http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android/en-US/
Wild guess, could the single-locale crashes be related to the multi-locale non-localized randomness?
Looks like it occurred on the Captivate on the English native version as well, but only when quitting. (note : from bug 721634); not sure if the single-locale crashes related to multi-locale non-localized randomness.  Looks like there's no need to log another crash bug since this one covers it.
Update:

2/2/2012 English single nightly locale seems to not crash
I do not see a nonEnglish single nightly locale to test

2/2/2012 nonEnglish Aurora locale seems not to crash.
reason for nonEnglish single nightly locales missing:
Bug 717522 nor, P1, Firefox 12, l10n, REOP, Android single locale fixes

Also to note: nightly single locales are not archived/stored on ftp server.
Made a mistake.  Bug 717522 refers to XUL.  There should be another bug for the L10n missing.  Seems like this might be a dup of bug 720121.  IRC'ed Aki.  The L10n Single locale builds are up as since 3 hrs ago.  retesting on those builds.
Made a mistake.  Bug 717522 refers to XUL.  Seems like this might be a dup of bug 720121. 

IRC'ed Aki.  The L10n Single locale builds are up as since 3 hrs ago.  retesting on those builds.
Tested nl, jp, and es with a quick smoke test.  Did not crash.  

- JP for some reason doesn't have the Japanese; also noticed issue with typing in landscape.

Marking this as a dup of bug 720121
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
blocking-fennec1.0: --- → beta+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.