Last Comment Bug 721762 - After having dragged the bookmark tool bar button that a menu had been opened , Drag drop functions are completely messed.
: After having dragged the bookmark tool bar button that a menu had been opened...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Widget: Gtk (show other bugs)
: Trunk
: x86 Linux
: -- major (vote)
: mozilla13
Assigned To: Karl Tomlinson (:karlt)
:
:
Mentors:
: 730774 (view as bug list)
Depends on:
Blocks: 495184
  Show dependency treegraph
 
Reported: 2012-01-27 08:34 PST by Alice0775 White
Modified: 2012-08-06 08:12 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
don't startDragSession when invokeDragSession will fail (1.46 KB, patch)
2012-01-31 21:04 PST, Karl Tomlinson (:karlt)
enndeakin: review+
Details | Diff | Splinter Review

Description Alice0775 White 2012-01-27 08:34:02 PST
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/c07595bee6cf
Mozilla/5.0 (X11; Linux i686; rv:12.0a1) Gecko/20120127 Firefox/12.0a1 ID:20120127031148

After having dragged the bookmark tool bar button that a menu had been opened,
Drag drop functions are completely messed.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox with clean profile
2. Enable Bookmarks toolbar
3  Create a Folder and put into Bookmarks toolbar
4. Create some bookmarks into the Folder

5. Mousedown on the Folder and hold till menupopup is open. and don't release a button
6. Drag and drop --- This fails due to Bug 500081

7. Try to drag/drop a link in content area to LocationBar
8. Try to drag/drop a selected text to SearchBar
9. Try to drag/drop a bookmark

Actual Results:
  Step 7, Step8 and Step 9 fail.
  Drag drop functions are completely messed.
  
Expected Results:
  Step 7, Step8 and Step 9 should be performed successfully.
  Drag drop functions should not be messed.
Comment 1 Alice0775 White 2012-01-27 19:11:31 PST
Regression window(m-c)
Works:
http://hg.mozilla.org/mozilla-central/rev/d0c10e8bae37
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090614 Namoroka/3.6a1pre ID:20090614030932
Fails:
http://hg.mozilla.org/mozilla-central/rev/eac99a38d8d9
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090615 Namoroka/3.6a1pre ID:20090615031143
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d0c10e8bae37&tochange=eac99a38d8d9

Suspected:
cbfafc498ae8	Karl Tomlinson — b=495184 current drag operation (dropEffect) is not updated while dragging outside the application. r=enndeakin sr=roc
Comment 2 Karl Tomlinson (:karlt) 2012-01-31 21:04:55 PST
Created attachment 593310 [details] [diff] [review]
don't startDragSession when invokeDragSession will fail

If gtk_drag_begin fails, we never get the necessary signals for endDragSession.
Comment 4 Ed Morley [:emorley] 2012-02-07 12:02:10 PST
https://hg.mozilla.org/mozilla-central/rev/e4ea03a30a09
Comment 5 Wayne Mery (:wsmwk, NI for questions) 2012-08-06 08:12:12 PDT
*** Bug 730774 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.