Closed Bug 722165 Opened 8 years ago Closed 3 years ago

Firefox 10.0 Crash in nsAbsoluteContainingBlock::Reflow with AMD Radeon HD 6xxx series

Categories

(Core :: Layout, defect, critical)

10 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: marcia, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

Seen while looking at crash stats. This crash is new to B6 and currently ranks #59 in browser crashes. Users are Windows 7 only so far.

http://tinyurl.com/6wcsugg shows the reports so far.  There are no addon or module correlations showing up in the report directory: https://crash-analysis.mozilla.com/crash_analysis/20120129/

I looked through some of the individual reports for common extensions but so far I haven't seen anything that appears across reports. 

https://crash-stats.mozilla.com/report/index/a3461525-ce69-485a-9eec-febd32120129

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	xul.dll@0xc584d 	
1 	xul.dll 	nsAbsoluteContainingBlock::Reflow 	
2 	xul.dll 	nsBlockFrame::Reflow 	layout/generic/nsBlockFrame.cpp:1189
3 	xul.dll 	nsRefPtr<nsPresContext>::~nsRefPtr<nsPresContext> 	obj-firefox/dist/include/nsAutoPtr.h:907
4 	xul.dll 	nsDisplayList::ComputeVisibilityForSublist 	layout/base/nsDisplayList.cpp:512
Since I filed this bug earlier today, the crash has now moved up to #47 in Beta 6 data.
There are also crashes in 10.0b1.

It's probably related to bug 700288, bug 722024, bug 722025 and bug 722030.
Blocks: 605780
Crash Signature: [@ xul.dll@0xc584d | nsAbsoluteContainingBlock::Reflow(nsContainerFrame*, nsPresContext*, nsHTMLReflowState const&, unsigned int&, int, int, bool, bool, bool, nsOverflowAreas*) ] → [@ xul.dll@0xba28d | nsAbsoluteContainingBlock::Reflow(nsContainerFrame*, nsPresContext*, nsHTMLReflowState const&, unsigned int&, int, int, bool, bool, bool, nsOverflowAreas*)] [@ xul.dll@0xc584d | nsAbsoluteContainingBlock::Reflow(nsContainerFrame* nsP…
Summary: Firefox 10.0 Crash [@ xul.dll@0xc584d | nsAbsoluteContainingBlock::Reflow(nsContainerFrame* → Firefox 10.0 Crash in nsAbsoluteContainingBlock::Reflow with AMD Radeon HD 6xxx series
Depends on: 722538
Crash Signature: nsPresContext*, nsHTMLReflowState const&, unsigned int&, int, int, bool, bool, bool, nsOverflowAreas*)] → nsPresContext*, nsHTMLReflowState const&, unsigned int&, int, int, bool, bool, bool, nsOverflowAreas*)] [@ xul.dll@0x12a50d | nsAbsoluteContainingBlock::Reflow(nsContainerFrame*, nsPresContext*, nsHTMLReflowState const&, unsigned int&, int, int, bool boo…
$ gunzip --stdout /data/security_group/crash_urls/20120307-crashdata.csv.gz | awk -W compat -F\t '$1 ~ /nsAbsoluteContainingBlock::Reflow/ {print $2}' | sort | uniq -c | sort -nr
      5 http://www.tumblr.com/dashboard
      2 about:sessionrestore
      2 about:blank
      1 \N
      1 http://www.yazino.com/table/find/SLOTS/Slots_Low/Default_Slots
      1 http://www.tumblr.com/dashboard/4/18889137878
      1 http://www.tumblr.com/dashboard/17/18886591544
      1 http://www.tumblr.com/dashboard/12/18870948800
      1 http://www.tumblr.com/blog/letmebyourfantasy
      1 http://www.trulia.com/for_rent/Palm_Bay,FL/#for_rent/Palm_Bay,FL/3p_beds/2p_baths/SINGLE-FAMILY_HOME_type/0-1000_price/10_r
      1 http://www.tagesschau.de/
      1 http://www.secretfriends.com/feeds/MemberRooms/ChatRoom/index.aspx?RoomName=...&chatop=...
      1 http://www.pandora.com/#
      1 http://www.onet.pl/
      1 http://www.nettikone.com/maatalouskoneet/traktorien-lisavarusteet?page=4&sortCol=price&ord=ASC&status=F
      1 http://www.miumeet.com/#!
      1 http://www.lynda.com/home/Player.aspx?lpk4=80393&playChapter=False
      1 http://www.hqms.hgihost.com/OnCore/Login.aspx
      1 http://www.google.co.id/search?q=gambar+mickey+and+minnie+mouse&...
      1 http://www.google.co.id/firefox?client=firefox-a&rls=org.mozilla:en-US:official
      1 http://www.facebook.com/sheonline222
      1 http://www.facebook.com/profile.php?id=1010037303
      1 http://www.facebook.com/plugins/like.php?action=like&...
      1 http://www.facebook.com/photo.php?...
      1 http://www.facebook.com/messages/?action=read&...
      1 http://www.facebook.com/media/set/?...
      1 http://www.facebook.com/ajax/pagelet/generic.php/MoreStoriesPagelet?...
      1 http://www.facebook.com/ajax/pagelet/generic.php/MoreStoriesPagelet?...
      1 http://www.facebook.com/ajax/emu/end.php?...
      1 http://www.facebook.com/
      1 http://www.da-ads.com/static_adframe.html?...
      1 http://www.burton.co.uk/webapp/wcs/stores/servlet/CatalogNavigationSearchResultCmd?catalogId=33052&storeId=12551&langId=-1&viewAllFlag=false&sort_field=Relevance&categoryId=209037&parent_categoryId=208974&beginIndex=1&pageSize=20
      1 http://vk.com/al_feed.php?__query=feed&al=-1&al_id=17508705&_rndVer=30423
      1 http://vgn-xpromo.vostu.com/xpromo/bar.do?...
      1 http://usnews.msnbc.msn.com/_news/2012/03/06/10593382-fbi-offers-1-million-reward-for-agent-missing-in-iran
      1 https://www.facebook.com/index.php?stype=lo&lh=...
      1 http://sn145w.snt145.mail.live.com/mail/logout.aspx?redirect=true&mkt=es-US&rad=True&lc=21514
      1 https://mail.google.com/mail/?shva=1#inbox
      1 http://search.babylon.com/?...
      1 https://apps.facebook.com/tltexas/index.php
      1 http://member.friendscout24.de/profilewin.html?...
      1 http://mail.verizon.com/webmail/driver?nimlet=showmessages&view=emails#abs_All_Contacts
      1 http://grooveshark.com/
      1 http://en.wikipedia.org/wiki/Plotter
      1 http://bellingham.craigslist.org/m4w/2884386162.html
      1 http://allegro.pl/dla-dzieci
      1
Keywords: needURLs
Adding qawanted now that we have URLs.
Keywords: qawanted
Loaded up most all of the sites in Comment 3 and played around with them, so far no crash yet. Using  Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0 since that is what showed the most amount of crashes. Will do some additional testing. 

I am running on a machine that has AMD Radeon HD 6310 Graphics.
Depends on: 755974
Any update on this since we landed the AMD blocklisting a while back?
Keywords: qawanted
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #6)
> Any update on this since we landed the AMD blocklisting a while back?
The AMD D2D/D3D9 blocklisting hasn't changed anything. See bug 700288 comment 39.
Bug 700288 comment 41 seems to indicate the blocklist did change something:
> This no longer appears to be a top crasher.

It might be useful to know how the crash-stats have been trending since 13.0b5 until 14.0b8.
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #8)
> Bug 700288 comment 41 seems to indicate the blocklist did change something:
> > This no longer appears to be a top crasher.
The fact that it's no longer a top crasher is not caused by the blocklist but by the bug itself that appears randomly depending on the build (see bug 700288 comment 32). It can show up again at any time with its brother crashes as long as the underlying problem is not fixed.
Agreed -- that said, is there anything QA can do here to help debug this issue?
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #10)
> Agreed -- that said, is there anything QA can do here to help debug this
> issue?
Bug 700288 was a top crasher in a Beta build in 10.0, 11.0 and 13.0. Let's wait it's back in 15.0 or it's fixed by a side effect of another patch
Crash Signature: , bool, bool, nsOverflowAreas*)] → , bool, bool, nsOverflowAreas*)] [@ xul.dll@0xba28d | nsAbsoluteContainingBlock::Reflow] [@ xul.dll@0xc584d | nsAbsoluteContainingBlock::Reflow] [@ xul.dll@0x12a50d | nsAbsoluteContainingBlock::Reflow]
I'm marking this bug as WORKSFORME as bug crashlog signature didn't appear from a long time (over half year) in Firefox (except some obsolete Fx <11).
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.