The default bug view has changed. See this FAQ.

drag-and-drop of URLs from the location bar to the download manager fail when the protocol has been trimmed

VERIFIED FIXED in mozilla34

Status

()

Toolkit
Downloads API
VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: Loic, Assigned: Gijs)

Tracking

Trunk
mozilla34
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120130 Firefox/12.0a1
Build ID: 20120130031142

Steps to reproduce:

Firefox 12 allows pasting URL directly in the download manager window to download it (see recent Bug 712421).
In addition, drag-and-drop of element of a webpage (images, links etc) to the download manager window is allowed too.

But drag-and-drop of URL from the location bar to the download manager window is still not allowed. So allow this action to be consistent with the other possibilities of downloading.
(Reporter)

Updated

5 years ago
Component: Untriaged → Download Manager
OS: Windows 7 → All
Product: Firefox → Toolkit
Hardware: x86_64 → All
Version: 12 Branch → Trunk
This works for me. How are you dragging the URL?
(Reporter)

Comment 2

5 years ago
My steps:
- I select the URL in the location bar (double click or Ctrl+A).
- I do a long left click on the highlighted URL to drag it
- I drop it into the download manager window

BUT I found my error, I have been abused by another bug.
In fact, if "http://" URL prefix is hidden (browser.urlbar.trimURLs = true, default value), drag & drop the URL from the location bar to the download manager doesn't work.
If browser.urlbar.trimURLs = false, it works like you.

But I fail to find the bug number, I'm pretty sure it's already filled.
Ah indeed, protocol stripping breaks this.
Depends on: 670587
Summary: Allow drag-and-drop of URL from the location bar to the download manager window to download it → drag-and-drop of URLs from the location bar to the download manager fail when the protocol has been trimmed
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
QA Contact: untriaged → download.manager
(Assignee)

Comment 4

3 years ago
I believe this is fixed by bug 670587 on today's (Aug. 27th) nightly.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
(Reporter)

Comment 5

3 years ago
Yes, it's fixed. Now, HTTP files/webpages are downloaded when the user drops the URL in the Download Panel or the Download Library.
Marking as verified based on Loic's comment 5.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.