Closed Bug 722759 Opened 8 years ago Closed 8 years ago

Change buildbot configs to upload symbols to symbols1.dmz.phx1.mozilla.com

Categories

(Release Engineering :: General, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ted, Assigned: nthomas)

References

Details

(Whiteboard: [symbols][upload])

Attachments

(3 files)

bug 688186 is going to replace dm-symbolpush01 with symbols1.dmz.phx1.mozilla.com. There will be a transition period where we run them both in parallel, but we'll eventually kill dm-symbolpush01. We'll need to change the buildbot configs to point to the new machine. (We'll probably also need to pre-accept the SSH host key from the new machine so that uploads don't hang.)

There will probably be a NetOps bug blocking this one to get the networking details worked out.
Blocks: 722767
Component: Release Engineering → Release Engineering: Automation
Priority: -- → P3
QA Contact: release → catlee
Whiteboard: [symbols][upload]
ted, what's the status of the dependent bugs here? when can we go ahead with this?
The machine is up and running in PHX, I'm not 100% sure if we have everything set up properly there. As part of bug 722756 we should shake out most of those issues.
Assignee: nobody → nrthomas
Priority: P3 → P2
Depends on: 742045
per irc w/cshields just now:

The symbolpush VM is being powered off and *staying* off on 4/13. We'll need to switch to new symbolpush VM before then to avoid a symbol outage. Reading bug#688186, and from irc, its unclear if the new VM is ready for use as replacement in production at this time.
Attachment #613855 - Flags: review?(catlee) → review+
Attachment #613980 - Flags: review?(philipp) → review+
Comment on attachment 613981 [details] [diff] [review]
thunderbird symbols upload patch

r+ for the copy & paste. Do you really upload try symbols to the main symbol server ?
Attachment #613981 - Flags: review?(nrthomas) → review+
This is ready to go. 

I've verified the non-try compile machines can reach symbols1.dmz.phx1.mozilla.com and /mnt/netapp/breakpad/symbols_ffx and symbols_mob is writable by ffxbld. There's a slight issue with xulrunner symbols (bug 688186 comment #54) but they are low priority and we can fix that up after the fact.
Duplicate of this bug: 722766
Comment #8 refers to the Firefox.
Comment on attachment 613980 [details] [diff] [review]
calendar symbols upload patch

Review of attachment 613980 [details] [diff] [review]:
-----------------------------------------------------------------

Landed in https://hg.mozilla.org/build/buildbot-configs/rev/ce39dfdf6a7b
Attachment #613980 - Flags: checked-in+
Comment on attachment 613981 [details] [diff] [review]
thunderbird symbols upload patch

Review of attachment 613981 [details] [diff] [review]:
-----------------------------------------------------------------

Landed in https://hg.mozilla.org/build/buildbot-configs/rev/e9c624138ec2
Attachment #613981 - Flags: checked-in+
Comment on attachment 613855 [details] [diff] [review]
[buildbot-configs] non-try symbols upload to symbols1.dmz.phx1.mozilla.com

http://hg.mozilla.org/build/buildbot-configs/rev/50645448389d
Attachment #613855 - Flags: checked-in+
Deployed and a set of Firefox & Mobile nightlies on mozilla-aurora had no problems uploading symbols.

jhopkins, if the thunderbird and lightning changes are deployed please close this bug.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.