Last Comment Bug 722808 - XUL Fennec nightly build fails with "L10NBASEDIR not defined by configure" in embedding/android/locales
: XUL Fennec nightly build fails with "L10NBASEDIR not defined by configure" in...
Status: RESOLVED FIXED
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Firefox 12
: ARM Android
: -- major (vote)
: Firefox 13
Assigned To: Matt Brubeck (:mbrubeck)
:
Mentors:
Depends on:
Blocks: 717522
  Show dependency treegraph
 
Reported: 2012-01-31 12:00 PST by Matt Brubeck (:mbrubeck)
Modified: 2013-12-10 10:00 PST (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
back out bug 717522 on Aurora (1.33 KB, patch)
2012-02-01 11:19 PST, Matt Brubeck (:mbrubeck)
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Matt Brubeck (:mbrubeck) 2012-01-31 12:00:53 PST
Last night's XUL Nightly build failed twice in a row with this error:

https://tbpl.mozilla.org/php/getParsedLog.php?id=8974969&tree=Firefox
Android XUL mozilla-central nightly on 2012-01-31 05:54:53 PST for push 3f26b7bee352

06:45:59     INFO -  make[5]: Entering directory `/builds/slave/m-cen-andrd-xul-ntly/build/obj-firefox/embedding/android/locales'
06:45:59    ERROR -  Makefile:66: *** L10NBASEDIR not defined by configure.  Stop.
06:45:59     INFO -  make[5]: Leaving directory `/builds/slave/m-cen-andrd-xul-ntly/build/obj-firefox/embedding/android/locales'
06:45:59    ERROR -  make[4]: *** [chrome] Error 2
06:45:59     INFO -  make[4]: Leaving directory `/builds/slave/m-cen-andrd-xul-ntly/build/obj-firefox/embedding/android/locales'
06:45:59    ERROR -  make[3]: *** [chrome] Error 2
06:45:59     INFO -  make[3]: Leaving directory `/builds/slave/m-cen-andrd-xul-ntly/build/obj-firefox/embedding/android'
06:45:59    ERROR -  make[2]: *** [make-package] Error 2
06:45:59     INFO -  make[2]: Leaving directory `/builds/slave/m-cen-andrd-xul-ntly/build/obj-firefox/mobile/xul/installer'
06:45:59    ERROR -  make[1]: *** [default] Error 2
06:45:59     INFO -  make[1]: Leaving directory `/builds/slave/m-cen-andrd-xul-ntly/build/obj-firefox/mobile/xul/installer'
06:45:59     INFO -  make: *** [package] Error 2
06:45:59    ERROR - Return code: 2
06:45:59    FATAL - Halting on failure while running make package AB_CD=multi
06:45:59    FATAL - Exiting 2
program finished with exit code 2
elapsedTime=409.181453
======== Finished 'python mozharness/scripts/multil10n.py ...' failed (results: 2, elapsed: 6 mins, 49 secs) ========
Comment 1 Axel Hecht [pto-Aug-30][:Pike] 2012-01-31 14:05:52 PST
Hrm, Aki?
Comment 2 Aki Sasaki [:aki] 2012-01-31 14:17:30 PST
I'm wondering if this is more l10n fallout from bug 719697.
This looks like specifying L10NBASEDIR in |make package| is now a requirement.
Comment 3 Aki Sasaki [:aki] 2012-01-31 14:31:18 PST
http://hg.mozilla.org/mozilla-central/rev/c0ae127e29cd needs backing out.
This will re-break Android xul single locale (which is also broken by bug 719697) but should hopefully fix Android xul multilocale nightlies.
Comment 4 Matt Brubeck (:mbrubeck) 2012-01-31 14:49:28 PST
Backed out c0ae127e29cd: https://hg.mozilla.org/mozilla-central/rev/1410782d557d

I'll request Aurora approval after nightly builds succeed on mozilla-central.
Comment 5 Aki Sasaki [:aki] 2012-01-31 18:22:34 PST
If this merges into mozilla-beta, this may break the 11.0b1 android-xul multilocale release build.
Comment 6 Matt Brubeck (:mbrubeck) 2012-02-01 11:19:10 PST
Created attachment 593533 [details] [diff] [review]
back out bug 717522 on Aurora

[Approval Request Comment]
Regression caused by (bug #): bug 717522

User impact if declined: XUL nightly fails to build

Testing completed (on m-c, etc.): Landed on m-c 1/31.

Risk to taking this patch (and alternatives if risky): Low-risk: this is a backout of a one-line build system change that affects only XUL fennec.

String changes made by this patch: None.
Comment 7 Alex Keybl [:akeybl] 2012-02-02 07:17:54 PST
Comment on attachment 593533 [details] [diff] [review]
back out bug 717522 on Aurora

[Triage Comment]
Fixes build failure - approved for Aurora 12.
Comment 8 Matt Brubeck (:mbrubeck) 2012-02-02 10:26:45 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/72dd0b3694fc
Comment 9 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2012-02-02 19:08:33 PST
Comment on attachment 593533 [details] [diff] [review]
back out bug 717522 on Aurora

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:

(In reply to Matt Brubeck (:mbrubeck) from comment #8)
> https://hg.mozilla.org/releases/mozilla-aurora/rev/72dd0b3694fc

afaict, this backout landed after the migration from aurora to beta. Therefore we need to backout on beta also, in order to avoid android-xul bustage in 11.0betas.
Comment 10 Matt Brubeck (:mbrubeck) 2012-02-02 19:18:45 PST
Comment on attachment 593533 [details] [diff] [review]
back out bug 717522 on Aurora

Firefox 11 (beta) is not affected by this bug, because the patch which this backs never landed in Firefox 11 and is not in mozilla-beta:

https://hg.mozilla.org/releases/mozilla-beta/file/default/embedding/android/Makefile.in#l189
Comment 11 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2012-02-07 03:01:33 PST
(In reply to John O'Duinn [:joduinn] from comment #9)
> (In reply to Matt Brubeck (:mbrubeck) from comment #8)
> > https://hg.mozilla.org/releases/mozilla-aurora/rev/72dd0b3694fc
> 
> afaict, this backout landed after the migration from aurora to beta.
> Therefore we need to backout on beta also, in order to avoid android-xul
> bustage in 11.0betas.

(In reply to Matt Brubeck (:mbrubeck) from comment #10)
> Comment on attachment 593533 [details] [diff] [review]
> back out bug 717522 on Aurora
> 
> Firefox 11 (beta) is not affected by this bug, because the patch which this
> backs never landed in Firefox 11 and is not in mozilla-beta:
> 
> https://hg.mozilla.org/releases/mozilla-beta/file/default/embedding/android/
> Makefile.in#l189

ok, thanks :mbrubeck.

Note You need to log in before you can comment on or make changes to this bug.