Bug 722880 (mtable-width)

Support for attribute "width" on mtable

RESOLVED FIXED in mozilla13

Status

()

Core
MathML
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: fredw, Assigned: François Wang)

Tracking

(Blocks: 3 bugs, {dev-doc-complete, helpwanted})

Trunk
mozilla13
dev-doc-complete, helpwanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good second bug], URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Here is a test case from the MathML testsuite:

http://www.w3.org/Math/testsuite/build/main/Presentation/TablesAndMatrices/mtable/mtableAwidth1-full.xhtml

Note that to workaround this bug, MathJax attaches the corresponding style="width: ..." on the mtable element. Hence an easy way to fix this bug would be to do this attribute mapping in src/content/mathml/content/src/nsMathMLElement.cpp. Note the special value "auto" and the case when length is unitless (it should be interpreted in the same way as a % per chapter 2).

Good new, we don't have to care about mstyle:
"MathML specifies that when the attributes height, depth or width are specified on an mstyle element, they apply only to mspace elements, and not to the corresponding attributes of mglyph, mpadded, or mtable."

Here is a reftest I wrote for the MathJax project:

http://devel.mathjax.org/testing/testsuite/MathMLToDisplay/Presentation/TablesAndMatrices/mtable/width-1.html?&outputJax=NativeMML

http://devel.mathjax.org/testing/testsuite/MathMLToDisplay/Presentation/TablesAndMatrices/mtable/width-1-ref.html?&outputJax=NativeMML

(one can also compare the effect of the attribute width with the one of the corresponding style="width: ..." rule)
(Reporter)

Updated

6 years ago
Assignee: nobody → francoiswang
(Assignee)

Comment 1

6 years ago
Created attachment 599666 [details] [diff] [review]
Patch V1
Attachment #599666 - Flags: review?(karlt)
(Reporter)

Comment 2

6 years ago
> Here is a reftest I wrote for the MathJax project:
> 
> http://devel.mathjax.org/testing/testsuite/MathMLToDisplay/Presentation/
> TablesAndMatrices/mtable/width-1.html?&outputJax=NativeMML
> 
> http://devel.mathjax.org/testing/testsuite/MathMLToDisplay/Presentation/
> TablesAndMatrices/mtable/width-1-ref.html?&outputJax=NativeMML
> 
> (one can also compare the effect of the attribute width with the one of the
> corresponding style="width: ..." rule)

The reference in this reftest does not work very well for us, because of bug 459363. So maybe we should just compare

<mtable width="...">...

against

<mtable style="width: ...;">...

We can also verify that "auto" is the same as the default value:

<mtable width="auto">...

and

<mtable>...

(I think in attachment 599666 [details] [diff] [review], ParseNumericValue will just ignore "auto" and thus provide the expected behavior here).
Attachment #599666 - Flags: review?(karlt) → review+
(Reporter)

Comment 3

6 years ago
https://tbpl.mozilla.org/?tree=Try&rev=4d4d2e22ce1a
(Assignee)

Comment 4

6 years ago
Created attachment 600810 [details] [diff] [review]
Patch reftests V1
Attachment #600810 - Flags: review?(karlt)
Attachment #600810 - Flags: review?(karlt) → review+
(Reporter)

Updated

6 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/c90e1b198f93
https://hg.mozilla.org/integration/mozilla-inbound/rev/96b6614529b6

Sorry about the name mangling...
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c90e1b198f93
https://hg.mozilla.org/mozilla-central/rev/96b6614529b6
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
https://developer.mozilla.org/en/MathML/Element/mtable
https://developer.mozilla.org/en/Firefox_13_for_developers
https://developer.mozilla.org/en/Mozilla_MathML_Project/Status

Updated by Frédéric: https://developer.mozilla.org/en/Mozilla_MathML_Project/MathML3Testsuite/Topics/TablesTokens
Keywords: dev-doc-needed → dev-doc-complete
(Reporter)

Updated

6 years ago
Alias: mtable-width
You need to log in before you can comment on or make changes to this bug.