Make AMO more discoverable in the browser

RESOLVED FIXED in Firefox 25

Status

()

P2
normal
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: madhava, Assigned: Margaret)

Tracking

unspecified
Firefox 25
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(fennec25+)

Details

Attachments

(5 attachments)

(Reporter)

Description

7 years ago
I'm a little concerned that the orange market icon in the upper right-hand-corner of the Add-ons Manager isn't quite noticeable enough or communicative enough of it's purpose.

We probably have a broader challenge in the browser of telling people about add-ons, what they can do, and why they might want them. This might involve more space dedicated on the start page, or on first run, etc.

This particular bug, though, is just about making the path to AMO, as the mechanism for getting more add-ons, more discoverable.
Created attachment 593442 [details]
An additional row item would be added which links to the add-ons store.
Created attachment 593443 [details]
for further differentiation the row can be hinted with a faint orange
The current proposal would be to add another row into your add-ons list, have it always be the last item so new users who don't have any add-ons with see it, while it will get out of the way for more advanced users, as their add-ons list should be more populated. The user would still be able to click the upper right corner (add-ons icon) to get quick access to the add-ons market place.
(Reporter)

Comment 4

7 years ago
If we did a version without the second line of text, we could in theory do this without any new strings, given that the header is the same as the link on about:home.

Comment 5

7 years ago
over to madhava for a final design/approval.  Is this something you were thinking about for beta / final?
Assignee: nobody → madhava
Priority: -- → P4

Updated

6 years ago
Blocks: 823558
Assignee: madhava → mark.finkle
tracking-fennec: --- → 20+
Priority: P4 → P2
Created attachment 697951 [details]
mockup

Here are a few changes to the Add-ons page. 

1. Since we can't use the Marketplace icon, we should go back to the green puzzle symbol in the top right corner, and at the left of the bottom row. 
2. Add a chevron to the top right corner next to the add-ons icon to make it look more tappable
3. Bottom row: use "Browse all Firefox Add-ons" only and center the text vertically, to visually distinguish this row. 
4. Add a chevron to the right of the bottom row. With the addition of the chevron, I don't think we need any kind of colour tint on the bottom row to distinguish it from other items. 

Will post assets for the puzzle piece and chevron shortly.
tracking-fennec: 20+ → +

Updated

6 years ago
Duplicate of this bug: 857212

Updated

5 years ago
tracking-fennec: + → ?
tracking-fennec: ? → 25+
Assignee: mark.finkle → margaret.leibovic
(Assignee)

Comment 8

5 years ago
Given the work going on in bug 891115, I think we should WONTFIX this. Ian, do you agree?
Flags: needinfo?(ibarlow)
Depending on how much work it is, it would still be a nice thing to have, even if it's just for a release or two. 

If it's easy, let's do it if there's time. If it isn't, we can wontfix.
Flags: needinfo?(ibarlow)
(Assignee)

Comment 10

5 years ago
Finally getting around to this... Ian, do you have a puzzle piece image I can use? Right now the marketplace icon we have is 50x50. I'll also need that chevron icon.
Flags: needinfo?(ibarlow)
Here you go Margaret! http://cl.ly/1p2f331N0O1N
Flags: needinfo?(ibarlow)
(Assignee)

Comment 12

5 years ago
Created attachment 784075 [details] [diff] [review]
patch

I feel rusty with CSS, so this might not be the best way to be doing this. However, it seems to get the job done, and about:addons should be retired soon, so I don't think we need to be perfectionists here.
Attachment #784075 - Flags: review?(mark.finkle)
(Assignee)

Comment 13

5 years ago
Created attachment 784077 [details]
screenshot

This doesn't *perfectly* match the mock-up, but I got kinda sick of futzing around with CSS :)
Comment on attachment 784075 [details] [diff] [review]
patch


>diff --git a/mobile/android/locales/en-US/chrome/aboutAddons.properties b/mobile/android/locales/en-US/chrome/aboutAddons.properties

>+addons.browseAll=Browse all Firefox Add-ons

I think this is OK without resorting to using branding. It is 'Firefox' on AMO and we use 'Firefox' in other places too.
Attachment #784075 - Flags: review?(mark.finkle) → review+
Looks good Margaret, thanks :)
https://hg.mozilla.org/mozilla-central/rev/c1b7e3837fad
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
You need to log in before you can comment on or make changes to this bug.