Last Comment Bug 722962 - intermittent failure in /tests/content/base/test/test_XHR.html | hello pass
: intermittent failure in /tests/content/base/test/test_XHR.html | hello pass
Status: RESOLVED FIXED
[qa-]
: intermittent-failure, regression
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: Masatoshi Kimura [:emk]
:
:
Mentors:
Depends on:
Blocks: 438871 656253 696586
  Show dependency treegraph
 
Reported: 2012-01-31 19:23 PST by Phil Ringnalda (:philor)
Modified: 2012-11-25 19:31 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
-
fixed


Attachments
patch (1.50 KB, patch)
2012-02-01 03:15 PST, Masatoshi Kimura [:emk]
no flags Details | Diff | Splinter Review
patch v2 (1.39 KB, patch)
2012-02-01 15:19 PST, Masatoshi Kimura [:emk]
jonas: review+
Details | Diff | Splinter Review
patch for check in; r=jonas (7.08 KB, patch)
2012-02-02 05:22 PST, Masatoshi Kimura [:emk]
VYV03354: review+
Details | Diff | Splinter Review
patch for check in; r=jonas (9.82 KB, patch)
2012-02-02 05:31 PST, Masatoshi Kimura [:emk]
VYV03354: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Phil Ringnalda (:philor) 2012-01-31 19:23:45 PST
+++ This bug was initially created as a clone of Bug #656253 +++

https://tbpl.mozilla.org/php/getParsedLog.php?id=8972541&tree=Firefox
Rev3 WINNT 5.1 mozilla-central opt test mochitests-1/5 on 2012-01-31 05:03:58

6764 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_XHR.html | hello pass

https://tbpl.mozilla.org/php/getParsedLog.php?id=8991612&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound opt test mochitests-1/5 on 2012-01-31 17:06:47

6764 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_XHR.html | hello pass
Comment 1 Masatoshi Kimura [:emk] 2012-02-01 03:15:51 PST
Created attachment 593371 [details] [diff] [review]
patch

|var fr| can race after bug 696586 because it is executed twice now.
Wrapped the code in an anonymous function to avoid the race.
Also added |"use strict";| directive.
Comment 2 Jonas Sicking (:sicking) No longer reading bugmail consistently 2012-02-01 11:34:28 PST
Can you explain what's happening here?

I don't see how runTests is run twice, and even if it was, 'fr' is a local variable so it will go out of scope after the first run, no?

Nit: please put the "use strict" on a separate line.
Comment 3 Masatoshi Kimura [:emk] 2012-02-01 15:18:17 PST
(In reply to Jonas Sicking (:sicking) from comment #2)
|var fr = new FileReader();| at line 237 will be executed twice because a for-loop has been added by bug 696586 (from line 218 to line 302).
'fr' will be overwritten even if it is a local variable because the for-loop will not create a independent scope. I added a anonymous function to create a new scope for every execute.
Comment 4 Masatoshi Kimura [:emk] 2012-02-01 15:19:07 PST
Created attachment 593626 [details] [diff] [review]
patch v2
Comment 5 Jonas Sicking (:sicking) No longer reading bugmail consistently 2012-02-01 17:58:28 PST
Comment on attachment 593626 [details] [diff] [review]
patch v2

Review of attachment 593626 [details] [diff] [review]:
-----------------------------------------------------------------

r=me if you also fix the indentation in this file. Both the fact that this whole thing is wrapped in a function, and the for-loop is all too easy to miss.
Comment 6 Treeherder Robot 2012-02-01 20:21:51 PST
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=9023094&tree=Mozilla-Aurora
Rev3 WINNT 6.1 mozilla-aurora pgo test mochitests-1/5 on 2012-02-01 19:42:45

6765 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_XHR.html | hello pass
Comment 7 Treeherder Robot 2012-02-01 20:23:15 PST
rnewman
https://tbpl.mozilla.org/php/getParsedLog.php?id=9023094&tree=Mozilla-Aurora
Rev3 WINNT 6.1 mozilla-aurora pgo test mochitests-1/5 on 2012-02-01 19:42:45

6765 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_XHR.html | hello pass
Comment 8 Treeherder Robot 2012-02-01 22:14:08 PST
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=9015773&tree=Fx-Team
Rev3 WINNT 6.1 fx-team opt test mochitests-1/5 on 2012-02-01 14:44:12

6764 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_XHR.html | hello pass
Comment 9 Masatoshi Kimura [:emk] 2012-02-02 05:22:01 PST
Created attachment 593794 [details] [diff] [review]
patch for check in; r=jonas
Comment 10 Masatoshi Kimura [:emk] 2012-02-02 05:31:25 PST
Created attachment 593798 [details] [diff] [review]
patch for check in; r=jonas

Sorry, the previous patch didn't pass the test
Comment 11 Treeherder Robot 2012-02-02 15:54:42 PST
mbrubeck
https://tbpl.mozilla.org/php/getParsedLog.php?id=9044960&tree=Mozilla-Aurora
Rev3 WINNT 5.1 mozilla-aurora pgo test mochitests-1/5 on 2012-02-02 14:08:02

6764 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_XHR.html | hello pass
Comment 12 Treeherder Robot 2012-02-02 17:17:28 PST
sgautherie
https://tbpl.mozilla.org/php/getParsedLog.php?id=9046451&tree=Firefox
Rev3 WINNT 6.1 mozilla-central pgo test mochitests-1/5 on 2012-02-02 15:17:34

6764 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_XHR.html | hello pass
Comment 13 Treeherder Robot 2012-02-03 13:44:13 PST
jfkthame%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=9071604&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound pgo test mochitests-1/5 on 2012-02-03 12:28:20

6764 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_XHR.html | hello pass
Comment 14 Mozilla RelEng Bot 2012-02-03 15:12:26 PST
Autoland Patchset:
	Patches: 593798
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/rev/f1b3301da9a5
Try run started, revision f1b3301da9a5. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=f1b3301da9a5
Comment 15 Mozilla RelEng Bot 2012-02-03 21:30:24 PST
Try run for f1b3301da9a5 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=f1b3301da9a5
Results (out of 206 total builds):
    success: 185
    warnings: 21
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-f1b3301da9a5
 Timed out after 06 hours without completing.
Comment 17 Ed Morley [:emorley] 2012-02-05 04:11:36 PST
https://hg.mozilla.org/mozilla-central/rev/1d89a17aacbe
Comment 18 Alex Keybl [:akeybl] 2012-02-10 12:54:01 PST
We don't typically track a test-only change for release, but we'll gladly accept a nomination to fix this orange on Aurora 12.
Comment 19 Masatoshi Kimura [:emk] 2012-02-10 16:17:50 PST
Comment on attachment 593798 [details] [diff] [review]
patch for check in; r=jonas

[Approval Request Comment]
Regression caused by (bug #): bug 696586
User impact if declined: None (test only)
Testing completed (on m-c, etc.): No test orange on m-c for 5 days
Risk to taking this patch (and alternatives if risky): None (test only)
String changes made by this patch: None
Comment 20 Alex Keybl [:akeybl] 2012-02-14 11:28:28 PST
Comment on attachment 593798 [details] [diff] [review]
patch for check in; r=jonas

[Triage Comment]
Approved for Aurora 12.

Note You need to log in before you can comment on or make changes to this bug.