Closed Bug 723046 Opened 8 years ago Closed 8 years ago

[OOPP]Cannot focus any input/textarea/XUL textbox after clicking Flash video under condition of dom.ipc.plugins.enabled=false and Java plugin(dom.ipc.plugins.java.enabled=false by default)

Categories

(Core :: DOM: Core & HTML, defect, major)

10 Branch
x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 718939

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/3f26b7bee352
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120131 Firefox/12.0a1 ID:20120131031150

Cannot focus any input/textarea/XUL textbox after clicking Youtube Flash video under condition of dom.ipc.plugins.enabled=false

Reproducible: Always

Steps to Reproduce:
1. Start Firefox with clean profile
2. Set dom.ipc.plugins.enabled=false
3. Restart browser

4. Open Youtube Video( http://www.youtube.com/watch?v=55s3T7VRQSc ) in a foreground new tab
5. Wait to play the video
6. Click Flash video to pause

7. Switch to previous selected tab
8. Click Location bar

Actual Results:
  Cannot focus.
  
Expected Results:
  The textbox should be focused. 

Regression window(m-c)
Works:
http://hg.mozilla.org/mozilla-central/rev/81dedcc49ac0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111108 Firefox/10.0a1 ID:20111108031146
Fails:
http://hg.mozilla.org/mozilla-central/rev/c170948e646e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111108 Firefox/10.0a1 ID:20111108000404
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=81dedcc49ac0&tochange=c170948e646e


Regression window(m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/f70682372656
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111107 Firefox/10.0a1 ID:20111107143440
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/be3714af7869
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111107 Firefox/10.0a1 ID:20111107173846
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f70682372656&tochange=be3714af7869

Suspected: Bug 699885
Java applet  also problem, because dom.ipc.plugins.java.enabled=false by default

Reproducible: Always

Steps to Reproduce:
1. Start Firefox with clean profile + Java Plugin
2. Open Java applet( http://java.sun.com/applets/jdk/1.4/demo/applets/ArcTest/example1.html ) in a foreground new tab
3. Wait page lading complete.
4. Click Java applet

5. Switch to previous selected tab
6. Click Location bar

Actual Results:
  Cannot focus.
  
Expected Results:
  The textbox should be focused.
Severity: normal → major
Summary: Cannot focus any input/textarea/XUL textbox after clicking Youtube Flash video under condition of dom.ipc.plugins.enabled=false → [OOPP]Cannot focus any input/textarea/XUL textbox after clicking Flash video under condition of dom.ipc.plugins.enabled=false and Java plugin(dom.ipc.plugins.java.enabled=false by default)
Regressed by:
bea7ecf9084e	Chris Pearce — Bug 699885 part 1 - Ensure we dispatch 'deactivate' event to chrome window when we lose focus while changing to full-screen mode. r=roc
This link in comment#2 has a broken link. Please use the following link instead.

Java applet http://nis-lab.is.s.u-tokyo.ac.jp/~nis/javaexampl/javtool/colmodel.html
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 718939
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.