Last Comment Bug 718939 - Java applet causes text entry fields to become semi-unresponsive
: Java applet causes text entry fields to become semi-unresponsive
Status: VERIFIED FIXED
: regression, relnote, verified-aurora, verified-beta
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: 10 Branch
: All Windows 7
: -- major with 12 votes (vote)
: mozilla13
Assigned To: Chris Pearce (:cpearce)
:
Mentors:
: 713607 723046 723675 723682 723891 724381 724382 725896 (view as bug list)
Depends on:
Blocks: 699885 727692
  Show dependency treegraph
 
Reported: 2012-01-18 00:30 PST by Eric Tam [krazywrath]
Modified: 2013-05-02 08:11 PDT (History)
36 users (show)
anthony.s.hughes: in‑litmus?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
+
verified
+
verified
verified
10+
verified


Attachments
Patch: backout bea7ecf9084e from m-r (1.14 KB, patch)
2012-02-07 14:03 PST, Chris Pearce (:cpearce)
cpearce: review+
akeybl: approval‑mozilla‑release+
Details | Diff | Review
Patch: backout bea7ecf9084e from m-c (1.10 KB, patch)
2012-02-07 14:05 PST, Chris Pearce (:cpearce)
cpearce: review+
Details | Diff | Review
Patch: backout bea7ecf9084e from m-b (1.16 KB, patch)
2012-02-07 14:17 PST, Chris Pearce (:cpearce)
cpearce: review+
akeybl: approval‑mozilla‑beta+
Details | Diff | Review
Patch: backout bea7ecf9084e from m-a (1.15 KB, patch)
2012-02-07 15:01 PST, Chris Pearce (:cpearce)
cpearce: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review
Patch: backout bea7ecf9084e from esr10 (1.13 KB, patch)
2012-02-07 17:22 PST, Chris Pearce (:cpearce)
cpearce: review+
Details | Diff | Review

Description Eric Tam [krazywrath] 2012-01-18 00:30:39 PST
Overview: Interacting with an embedded Java applet (e.g. clicking inside a Java game) causes all text entry fields to become virtually unusable until one 'un-focuses' the Firefox window (i.e. by minimizing or resizing it). This affects the location and search bars as well.

Build ID: Bug found in the following builds, but not the stable version
Nightly - Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120117 Firefox/12.0a1 ID:20120117031056
Aurora - Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a2) Gecko/20120117 Firefox/11.0a2 ID:20120117042008
Beta - Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0 ID:20120111092507

Steps to Reproduce:
1) Find a webpage with an embedded Java applet such as [[http://chir.ag/stuff/sand/]]
2) Click into the Java applet

Actual Results: User becomes unable to type or select text in the Location Bar, Search Bar, or any text entry field

Expected Results: User should be able to type or select text in any text entry field
Comment 1 Matthias Versen [:Matti] 2012-01-20 00:26:55 PST
confirming with  Mozilla/5.0 (Windows NT 6.1; rv:12.0a1) Gecko/20120117 Firefox/12.0a1 SeaMonkey/2.9a1 and JRE 6.0.300.12

requesting tracking because this is a serious regression.

Last good nightly: 2011-11-08
First bad nightly: 2011-11-09

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2011-11-08&enddate=2
011-11-09
Comment 2 Alex Keybl [:akeybl] 2012-01-22 18:45:28 PST
(In reply to Matthias Versen (Matti) from comment #1)
> confirming with  Mozilla/5.0 (Windows NT 6.1; rv:12.0a1) Gecko/20120117
> Firefox/12.0a1 SeaMonkey/2.9a1 and JRE 6.0.300.12
> 
> requesting tracking because this is a serious regression.
> 
> Last good nightly: 2011-11-08
> First bad nightly: 2011-11-09

Tracking for FF11/12, but it's unclear from merge calendar [1] (and my attempt to reproduce) that FF10 is affected.

[1] https://wiki.mozilla.org/RapidRelease/Calendar
Comment 3 Alex Keybl [:akeybl] 2012-01-22 18:45:46 PST
Please re-nominate for FF10 if it ends up being affected.
Comment 4 Eric Tam [krazywrath] 2012-01-22 21:35:27 PST
(In reply to Alex Keybl [:akeybl] from comment #3)
> Please re-nominate for FF10 if it ends up being affected.

Are you using Windows 7, and Java 6.0.300.12 as well?

I've tried this on a new profile and safe mode as well, both ending with this problem.
Comment 5 Alex Keybl [:akeybl] 2012-01-23 11:33:37 PST
(In reply to Eric [krazywrath] from comment #4)
> (In reply to Alex Keybl [:akeybl] from comment #3)
> > Please re-nominate for FF10 if it ends up being affected.
> 
> Are you using Windows 7, and Java 6.0.300.12 as well?

Thanks, it wasn't clear that this was Windows only. We'll track for 10 in case we end up getting a number of dupes, but I don't think we can expect to have a low-risk fix ready for FF10 at this point.
Comment 6 Matthias Versen [:Matti] 2012-02-02 13:35:25 PST
*** Bug 723675 has been marked as a duplicate of this bug. ***
Comment 7 Matthias Versen [:Matti] 2012-02-02 13:35:33 PST
*** Bug 723682 has been marked as a duplicate of this bug. ***
Comment 8 Alice0775 White 2012-02-02 13:41:31 PST
*** Bug 723046 has been marked as a duplicate of this bug. ***
Comment 9 Alice0775 White 2012-02-02 13:44:53 PST
Regression window(m-c)
Works:
http://hg.mozilla.org/mozilla-central/rev/81dedcc49ac0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111108 Firefox/10.0a1 ID:20111108031146
Fails:
http://hg.mozilla.org/mozilla-central/rev/c170948e646e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111108 Firefox/10.0a1 ID:20111108000404
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=81dedcc49ac0&tochange=c170948e646e


Regression window(m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/f70682372656
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111107 Firefox/10.0a1 ID:20111107143440
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/be3714af7869
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111107 Firefox/10.0a1 ID:20111107173846
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f70682372656&tochange=be3714af7869

Regressed by:
bea7ecf9084e	Chris Pearce — Bug 699885 part 1 - Ensure we dispatch 'deactivate' event to chrome window when we lose focus while changing to full-screen mode. r=roc
Comment 10 Trevor Andreas 2012-02-02 20:00:20 PST
I am also experiencing this bug in an internal enterprise web application using Firefox 10.  When the java applet loads, you cannot see the text cursor/selection in input boxes either on the web page or in the Firefox application (location bar and history does not show up).  Minimizing the window fixes the problem.
Comment 11 Matthias Versen [:Matti] 2012-02-03 15:41:43 PST
*** Bug 723891 has been marked as a duplicate of this bug. ***
Comment 12 Fubuki Hoshino 2012-02-05 06:42:14 PST
merge with 713607
Comment 13 Matthias Versen [:Matti] 2012-02-05 10:10:06 PST
*** Bug 713607 has been marked as a duplicate of this bug. ***
Comment 14 Matthias Versen [:Matti] 2012-02-05 10:14:41 PST
*** Bug 724382 has been marked as a duplicate of this bug. ***
Comment 15 Matthias Versen [:Matti] 2012-02-05 10:15:11 PST
*** Bug 724381 has been marked as a duplicate of this bug. ***
Comment 16 Loic 2012-02-05 14:44:38 PST
Possible workaround: http://forums.mozillazine.org/viewtopic.php?p=11703665#p11703665

Set about:config > dom.ipc.plugins.java.enabled = true
Add new boolean about:config > dom.ipc.plugins.enabled.npjp2.dll = true
Restart Firefox.
Comment 17 eli 2012-02-05 17:52:59 PST
I tried it. Doesn't work.
Comment 18 Fubuki Hoshino 2012-02-05 20:13:44 PST
no matter it is oopp or not, it won't work
Comment 19 Kohei Yoshino [:kohei] 2012-02-06 03:53:50 PST
akeybl: could you add this bug to the known issue list on the Firefox 10+ Release Notes?
Comment 20 MS 2012-02-06 09:19:44 PST
Hello,
We have the same bug in our web application. This is a serious issue for us as our application is used by our customers.

Please, could you assigned somebody to work on this issue ?
Best regards
Comment 21 Alex Keybl [:akeybl] 2012-02-07 08:35:31 PST
(In reply to MS from comment #20)
> Hello,
> We have the same bug in our web application. This is a serious issue for us
> as our application is used by our customers.

MS, please provide as much information as possible about the affected web application, the user effect, etc. Thanks!
Comment 22 Trevor Andreas 2012-02-07 09:58:39 PST
(In reply to Alex Keybl [:akeybl] from comment #21)
> 
> MS, please provide as much information as possible about the affected web
> application, the user effect, etc. Thanks!

The internal application I am using that this effects uses Java applets to display charts.  As soon as the Java applet runs:

* Text selection works, but the visual indication no longer appears to the user, making text selection and editing very difficult
* The location bar in the Firefox Application becomes non-functional - it will display no history when typing, and hitting enter no longer works
* These issues are true of every tab, not just the one running the Java applet

A typical user will generate many charts in a short time with this tool, and these issues will be encountered after each request.  Minimizing the window and restoring it fixes the problem, but users will not realize this.  Most colleagues I have talked with end up restarting the web browser completely.  

I would classify the user impact as severe since it actually "breaks" the Firefox application.
Comment 23 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-02-07 10:29:40 PST
I can easily reproduce this on Firefox 10 on Windows 7 64-bit with Java SE 6.0.290.11.

1) Download and install Firefox 10, start with a new profile
2) Open http://chir.ag/stuff/sand/ -> prompted to install Java
3) Install Java -> page reloads
4) Try some text fields (ex. location bar, search box, google on the home page, etc)

Result:
No text boxes work until I restart Firefox
Comment 24 MS 2012-02-07 10:43:32 PST
(In reply to Alex Keybl [:akeybl] from comment #21)
> (In reply to MS from comment #20)
> > Hello,
> > We have the same bug in our web application. This is a serious issue for us
> > as our application is used by our customers.
> 
> MS, please provide as much information as possible about the affected web
> application, the user effect, etc. Thanks!

Hello Alex,
Our web application is used by airlines in critical environment. That's why it's a serious regression for us.

Sorry but I can't give you a scenario to reproduce it on our application, but I can give you those following details :
WINDOWS XP
FIREFOX 10.0
JAVA 1.6
Comment 25 Alice0775 White 2012-02-07 10:43:57 PST
1. go http://java.sun.com/applets/jdk/1.4/index.html
2. Click Demo and click applet to focus it
3. Click text fields (ex. location bar, search box, google on the home page, etc)
Comment 26 MS 2012-02-07 10:58:21 PST
(following my last comment #24)
Impacts in our application:
When the applet is loaded, the focus cursor is missing in all textfields in Firefox (location bar, search field and in all tabs opened). Even the :focus css rules is not applied to any input field in our page. But we are still able to enter text.

Workaround :
The workaround given by Loic in comment #16 doesn't work. But we found that if firefox loses the focus and then gets the focus, the issue disapears and everything comes back to the normal.

Alice0775 : We have the same behaviour the scenario given in your comment #25.
Comment 27 Chris Pearce (:cpearce) 2012-02-07 12:45:41 PST
Well fix this by backing out bea7ecf9084e.
Comment 28 Chris Pearce (:cpearce) 2012-02-07 14:03:32 PST
Created attachment 595168 [details] [diff] [review]
Patch: backout bea7ecf9084e from m-r

Try push: https://tbpl.mozilla.org/?tree=Try&rev=4db261dee3f3

Will wait for QA+ on Try builds and for test to go green before requesting approval for landing.
Comment 29 Chris Pearce (:cpearce) 2012-02-07 14:05:14 PST
Created attachment 595169 [details] [diff] [review]
Patch: backout bea7ecf9084e from m-c

Backout bea7ecf9084e from m-c.

Try push: https://tbpl.mozilla.org/?tree=Try&rev=451c593d557b
Comment 30 Chris Pearce (:cpearce) 2012-02-07 14:17:08 PST
Created attachment 595175 [details] [diff] [review]
Patch: backout bea7ecf9084e from m-b

Backout from beta.
Try: https://tbpl.mozilla.org/?tree=Try&rev=a0aaa91b06ef
Comment 31 Chris Pearce (:cpearce) 2012-02-07 15:01:43 PST
Created attachment 595206 [details] [diff] [review]
Patch: backout bea7ecf9084e from m-a

Backout bea7ecf9084e from m-a
https://tbpl.mozilla.org/?tree=Try&rev=1a6a08aa1078
Comment 32 Chris Pearce (:cpearce) 2012-02-07 17:22:20 PST
Created attachment 595258 [details] [diff] [review]
Patch: backout bea7ecf9084e from esr10
Comment 33 Marcia Knous [:marcia - use ni] 2012-02-07 18:47:24 PST
Juan and I spent some time testing the fix on the tryserver build. You can see the results of our Windows testing here: https://etherpad.mozilla.org/Bug-718939.

We believe based on this it is good to land so you have our QA+.

(In reply to Chris Pearce (:cpearce) (on paternity leave, don't expect quick response!) from comment #28)
> Created attachment 595168 [details] [diff] [review]
> Patch: backout bea7ecf9084e from m-r
> 
> Try push: https://tbpl.mozilla.org/?tree=Try&rev=4db261dee3f3
> 
> Will wait for QA+ on Try builds and for test to go green before requesting
> approval for landing.
Comment 34 Alex Keybl [:akeybl] 2012-02-07 19:25:54 PST
Based upon QA's testing, let's land on m-c.

Also, a=akeybl for m-a, m-b, m-r, and ESR.
Comment 35 Chris Pearce (:cpearce) 2012-02-07 19:39:36 PST
https://hg.mozilla.org/releases/mozilla-release/rev/18ce5e304e97
Comment 36 Chris Pearce (:cpearce) 2012-02-07 19:48:22 PST
https://hg.mozilla.org/releases/mozilla-esr10/rev/7d38a883abb8
Comment 37 Chris Pearce (:cpearce) 2012-02-07 19:55:49 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/c0feb8e404a0
Comment 38 Chris Pearce (:cpearce) 2012-02-07 20:01:56 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/87c39b5f821c
Comment 40 MS 2012-02-08 01:41:53 PST
Hello,
Our application works fine with your patched version : ftp://ftp.mozilla.org/pub/firefox/try-builds/cpearce@mozilla.com-4db261dee3f3/try-win32/firefox-10.0.en-US.win32.installer.exe

Well done !
Do you know when this patch will be loaded on the offical release version ?

Thanks
Comment 41 Paul Synnott 2012-02-08 02:34:41 PST
I have also been having this problem in the current v10 release.
I can confirm that the patched version linked in comment 40 works.  Great stuff!
Comment 42 Fubuki Hoshino 2012-02-08 03:14:44 PST
confirm patch in comment 40 works!
Comment 43 Eric Bordeau 2012-02-08 07:10:51 PST
I also confirm the patch works. Thanks!
Comment 44 Ed Morley [:emorley] 2012-02-08 08:48:18 PST
(In reply to Chris Pearce (:cpearce) (on paternity leave, don't expect quick response!) from comment #39)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/f468e195c899

https://hg.mozilla.org/mozilla-central/rev/f468e195c899
Comment 45 Marcia Knous [:marcia - use ni] 2012-02-08 14:45:03 PST
I see a spike in Linux signatures in Firefox 10 - reports such as https://crash-stats.mozilla.com/report/index/71888852-6e7e-4000-ac45-630eb2120207 mention java applets in the comments.
Comment 46 Chris Pearce (:cpearce) 2012-02-08 15:18:52 PST
This was in code which only runs on Windows only, you must be seeing something different.
Comment 47 Matthias Versen [:Matti] 2012-02-08 15:27:04 PST
Marcia : That is probably bug 704249
Comment 48 juan becerra [:juanb] 2012-02-08 22:36:17 PST
Verified on 10.0.1 (build1), 10.0.1-ESR (build1), 11.0b2 (build1), 12.0a2 (latest), on Windows XP (with Java SE 6 Update 30) and Windows 7 (with Java SE 6 Update 29).

Today's nightly doesn't have the fix, so I'll wait until tomorrow to verify on that.
Comment 49 juan becerra [:juanb] 2012-02-09 16:23:53 PST
Verified on latest nightly as well.
Comment 50 Daniel B. 2012-02-09 17:38:00 PST
*** Bug 725896 has been marked as a duplicate of this bug. ***
Comment 51 dothesamba 2012-02-20 01:36:28 PST
Problem still exists in 10.0.2 with site www.marktplaats.nl with java applet function quick adding of pictures. Location bar is responsive but other fields are not till I click the location bar.
Comment 52 Alex Keybl [:akeybl] 2012-02-21 09:31:46 PST
(In reply to dothesamba from comment #51)
> Problem still exists in 10.0.2 with site www.marktplaats.nl with java applet
> function quick adding of pictures. Location bar is responsive but other
> fields are not till I click the location bar.

Please file a new bug with steps to reproduce, and add the qawanted keyword so that we can verify the problem. Thanks!

Note You need to log in before you can comment on or make changes to this bug.