Last Comment Bug 723048 - CSS Class names for scopes shouldn't have spaces
: CSS Class names for scopes shouldn't have spaces
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: All All
: P3 trivial (vote)
: Firefox 13
Assigned To: Victor Porof [:vporof][:vp]
:
Mentors:
Depends on:
Blocks: minotaur
  Show dependency treegraph
 
Reported: 2012-02-01 03:07 PST by Panos Astithas [:past]
Modified: 2012-02-27 01:13 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (1.53 KB, patch)
2012-02-22 06:51 PST, Victor Porof [:vporof][:vp]
past: review+
Details | Diff | Review

Description Panos Astithas [:past] 2012-02-01 03:07:24 PST
In debugger-view.js we currently use the scope name as its class name, leading to classes like "Local-scope" and "With block-scope". It would be nice to use more regular class names for scopes.
Comment 1 Victor Porof [:vporof][:vp] 2012-02-18 12:13:04 PST
I'll take this.
Comment 2 Victor Porof [:vporof][:vp] 2012-02-22 06:51:17 PST
Created attachment 599593 [details] [diff] [review]
v1

Also fixed typos in DVP__addProperty documentation.
Comment 3 Panos Astithas [:past] 2012-02-23 03:48:34 PST
Comment on attachment 599593 [details] [diff] [review]
v1

Review of attachment 599593 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.
Comment 4 Panos Astithas [:past] 2012-02-23 04:29:43 PST
Although I have to admit it bothers me that we are still using a localizable string as a class name, I hope that this won't create more problems in the future.
Comment 5 Victor Porof [:vporof][:vp] 2012-02-23 04:56:12 PST
(In reply to Panos Astithas [:past] from comment #4)
> Although I have to admit it bothers me that we are still using a localizable
> string as a class name, I hope that this won't create more problems in the
> future.

I can easily change this. However, we're not using it as a class name (it's just "scope"). We're using it as an id, and I don't think we're (or will be) querying it anywhere (because every scope is cached in DebuggerView.Properties).
Comment 6 Panos Astithas [:past] 2012-02-23 05:38:02 PST
(In reply to Victor Porof from comment #5)
> (In reply to Panos Astithas [:past] from comment #4)
> > Although I have to admit it bothers me that we are still using a localizable
> > string as a class name, I hope that this won't create more problems in the
> > future.
> 
> I can easily change this. However, we're not using it as a class name (it's
> just "scope"). We're using it as an id, and I don't think we're (or will be)
> querying it anywhere (because every scope is cached in
> DebuggerView.Properties).

I was mainly concerned with producing CSS errors in the console, but after reading the spec, I think it's fine:

http://www.w3.org/TR/CSS21/syndata.html#value-def-identifier
Comment 7 Rob Campbell [:rc] (:robcee) 2012-02-24 06:50:56 PST
https://hg.mozilla.org/integration/fx-team/rev/e1098816a74f
Comment 8 Tim Taubert [:ttaubert] 2012-02-27 01:13:49 PST
https://hg.mozilla.org/mozilla-central/rev/e1098816a74f

Note You need to log in before you can comment on or make changes to this bug.