Last Comment Bug 723122 - fix clang build
: fix clang build
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla13
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
:
:
Mentors:
: 723187 723284 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-01 08:00 PST by Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
Modified: 2012-03-28 15:00 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix build (480 bytes, patch)
2012-02-01 08:00 PST, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
jmuizelaar: review+
Details | Diff | Splinter Review

Description Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-01 08:00:53 PST
Created attachment 593453 [details] [diff] [review]
fix build

See also bug 723114.

This patch is just a quick fix. Clang warns on GetImageFromSourceSurface via -Wreturn-type and we build with -Werror=return-type.
Comment 1 Joe Drew (not getting mail) 2012-02-01 12:16:32 PST
*** Bug 723187 has been marked as a duplicate of this bug. ***
Comment 2 Joe Drew (not getting mail) 2012-02-01 14:16:24 PST
*** Bug 723284 has been marked as a duplicate of this bug. ***
Comment 3 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-02 01:02:56 PST
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=5a80e90839fd
Comment 4 Rob Campbell [:rc] (:robcee) 2012-02-02 09:13:08 PST
merge! merge!
Comment 5 Gregor Wagner [:gwagner] 2012-02-02 14:21:39 PST
And the next one :(
In file included from ../../../dist/include/nsCoreAnimationSupport.h:49:
../../../dist/include/nsIOSurface.h:48:7: error: redefinition of 'NSOpenGLContext' as different kind of symbol
Comment 6 Joe Drew (not getting mail) 2012-02-02 14:25:34 PST
That's bug 723618.
Comment 7 Ed Morley [:emorley] 2012-02-03 11:50:21 PST
(Please can you set assignee when attaching patches, or if using bzexport, file a bug against it :-))

https://hg.mozilla.org/mozilla-central/rev/5a80e90839fd
Comment 8 Nomis101 2012-03-28 12:46:42 PDT
Is it possible to get this into mozilla-beta? Today I've tried several times to build Thunderbird 12 with Clang, but it failed constantly with the error from Bug 723187. It takes me a hour or so to find out what the problem is and to find this Bug. Thanks.
Comment 9 Victor Porof [:vporof][:vp] 2012-03-28 12:55:48 PDT
(In reply to Nomis101 from comment #8)
> Is it possible to get this into mozilla-beta? Today I've tried several times
> to build Thunderbird 12 with Clang, but it failed constantly with the error
> from Bug 723187. It takes me a hour or so to find out what the problem is
> and to find this Bug. Thanks.

You could just export "-Wreturn-type" to turn the error into a warning and let the build finish.
Comment 10 Nomis101 2012-03-28 15:00:22 PDT
I've applied this patch to fix the error, maybe your workaround would also help. But I think more about all the other users who are trying to build Firefox/Thunderbird 12 with Clang and run into the same error.

Note You need to log in before you can comment on or make changes to this bug.