Language packs should work for all releases of a branch, maxVersion should use * for compatibility ranges

RESOLVED FIXED in Thunderbird 14.0

Status

MailNews Core
Build Config
--
enhancement
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: aryx, Assigned: standard8)

Tracking

Trunk
Thunderbird 14.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird12 fixed, thunderbird13 fixed, thunderbird-esr1012+ fixed)

Details

(Whiteboard: [esr], URL)

Attachments

(1 attachment, 1 obsolete attachment)

The language packs provided in the release folder on the ftp should work for all releases of a branch and not only a single release. With Enterprise Support Releases (ESR), this should provide more benefits (but also for normal users). At the moment, the language pack have the same minVersion and maxVersion, but because the strings are frozen, compatibility ranges should look like 10.0 - 10.0.* (This is being done for Thunderbird 3.1.x)
(Assignee)

Comment 1

6 years ago
Ok, I'm moving this to core build config, as I suspect it affects everyone, although I also suspect we'll need different sets of fixes across the board.
Component: Build Config → Build Config
Product: Thunderbird → Core
QA Contact: build-config → build-config
Version: unspecified → Trunk
(Assignee)

Updated

6 years ago
Whiteboard: [esr]
(Assignee)

Comment 2

6 years ago
Ok, Commandeering this back to Mailnews for the c-c part of what I'm going to be posting in bug 723135.
Assignee: nobody → mbanner
Component: Build Config → Build Config
Depends on: 723135
Product: Core → MailNews Core
QA Contact: build-config → build-config
(Assignee)

Comment 3

6 years ago
Created attachment 601022 [details] [diff] [review]
The fix

This is the c-c version of the fix from bug 723135.
Attachment #601022 - Flags: review?(bugspam.Callek)
Comment on attachment 601022 [details] [diff] [review]
The fix

I'm ok with this IFF the relevent m-c patch lands.

One caveat to note though is that chemspill releases will get a weird maxversion in the langpacks of, e.g. 11.0.1.* rather than 11.0.* with your code here
Attachment #601022 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 5

6 years ago
Comment on attachment 601022 [details] [diff] [review]
The fix

Damn, I meant to account for that. Gonna have to rethink that a little.
Attachment #601022 - Attachment is obsolete: true
(Assignee)

Comment 6

5 years ago
Created attachment 614777 [details] [diff] [review]
The fix v2

Ok, this matches the patch in bug 723135. I'm hoping to land this on Monday, so that we've got it in time for the various releases.
Attachment #614777 - Flags: review?(bugspam.Callek)
Attachment #614777 - Flags: review?(bugspam.Callek) → review+
Duplicate of this bug: 682816
(Assignee)

Comment 8

5 years ago
Checked in:

http://hg.mozilla.org/comm-central/rev/5c06bd39f172
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

5 years ago
This also required a bustage fix as bug 723135 hasn't landed yet:

http://hg.mozilla.org/comm-central/rev/74679c8cb51d
(Assignee)

Comment 10

5 years ago
Comment on attachment 614777 [details] [diff] [review]
The fix v2

[Triage Comment]
Moving forward across releases, as I want the test pilot fix for TB 12, and the langpack fixes for ESR.
Attachment #614777 - Flags: approval-comm-esr10+
Attachment #614777 - Flags: approval-comm-beta+
Attachment #614777 - Flags: approval-comm-aurora+
(Assignee)

Comment 11

5 years ago
Checked in:
http://hg.mozilla.org/releases/comm-aurora/rev/d59ce82bff2d
http://hg.mozilla.org/releases/comm-aurora/rev/985be5ac4630
status-thunderbird13: --- → fixed
(Assignee)

Comment 12

5 years ago
Checked in:
http://hg.mozilla.org/releases/comm-beta/rev/b1002bdd09b6
http://hg.mozilla.org/releases/comm-beta/rev/b0b116bdec07
http://hg.mozilla.org/releases/comm-esr10/rev/3b63dc8cfe1a
http://hg.mozilla.org/releases/comm-esr10/rev/4bb3fe25be5f
status-thunderbird12: --- → fixed
status-thunderbird-esr10: --- → fixed
To be clear, I'm a bit surprised you self-approved and used your approval for the suite/* changes here.

That said, I would have approved for suite had it been asked, so no end-result harm done.
Blocks: 746020
(Assignee)

Comment 14

5 years ago
Sorry, I'd forgotten about the suite parts.
Target Milestone: --- → Thunderbird 14.0
(Assignee)

Updated

5 years ago
tracking-thunderbird-esr10: --- → 12+
You need to log in before you can comment on or make changes to this bug.