Last Comment Bug 723154 - Some Flash objects don't work if content policies (Adblock Plus, NoScript, GreaseMonkey etc.) are present
: Some Flash objects don't work if content policies (Adblock Plus, NoScript, Gr...
Status: RESOLVED FIXED
[Please read comment 21 before commen...
: regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: unspecified
: x86_64 All
: -- critical with 27 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
http://speedtest.net/
: 723162 723412 723921 725001 (view as bug list)
Depends on:
Blocks: abp 90268
  Show dependency treegraph
 
Reported: 2012-02-01 09:26 PST by Wladimir Palant
Modified: 2014-09-02 18:41 PDT (History)
64 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
Minimal content policy extension (2.26 KB, application/x-xpinstall)
2012-02-01 09:26 PST, Wladimir Palant
no flags Details

Description Wladimir Palant 2012-02-01 09:26:15 PST
Created attachment 593487 [details]
Minimal content policy extension

The Flash object on http://speedtest.net/ fails to load in the current nightly (tested wth Windows NT 6.1; WOW64; rv:13.0a1 Gecko/20120201 Firefox/13.0a1) if Adblock Plus is installed. This issue isn't limited to Adblock Plus however, I verified that a minimal content policy implementation (restartless extension attached) triggers it as well. Judging by the discussion in the Mozillazine forums other high-profile web sites might be affected as well but I didn't verify that.

Users pinpointed bug 90268 as the likely cause. I will check whether the regression range matches.
Comment 1 Wladimir Palant 2012-02-01 09:39:52 PST
Confirmed, the same page loads correctly with Windows NT 6.1; WOW64; rv:12.0a1 Gecko/20120131 Firefox/12.0a1, the big Flash object in the middle shows up along with a green "begin test" button. So the regression range is http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3f26b7bee352&tochange=e18c7bc2c28e which includes a plugin-related change from bug 90268.
Comment 2 Justin Lebar (not reading bugmail) 2012-02-01 09:49:10 PST
*** Bug 723162 has been marked as a duplicate of this bug. ***
Comment 3 Justin Lebar (not reading bugmail) 2012-02-01 09:50:15 PST
It appears that merely having Firebug installed and active (even if it's not enabled for any site) also triggers this.
Comment 4 Wladimir Palant 2012-02-01 10:03:34 PST
(In reply to Justin Lebar [:jlebar] from comment #3)
> It appears that merely having Firebug installed and active (even if it's not
> enabled for any site) also triggers this.

This might not be the same issue - Firebug doesn't use content policies. However, my minimal content policy also causes http://www.thedailyshow.com/full-episodes/tue-january-31-2012-jonathan-macey to fail (no error message, the Flash video simply becomes transparent) so maybe Firebug triggers the same issue in a different way.
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2012-02-01 10:58:57 PST
Is it possible that we were not instantiating on wrap before (because we had no frame) but now we are?  And all content policies do is cause us to wrap very eagerly, during the loading code in the object element?
Comment 6 bogas04 2012-02-01 21:04:44 PST
Is Bug 723133 related?
Comment 7 Matthias Versen [:Matti] 2012-02-02 05:04:37 PST
*** Bug 723412 has been marked as a duplicate of this bug. ***
Comment 8 tomko222 2012-02-03 10:12:44 PST
http://speedtest.net/ is working for me in 13.0a1 (2012-02-03) ubuntu 11.10 x86-64. Firefox with adblock plus and flashblock.
To play videos in youtube.com i have to disable flashblock.
Comment 9 Philip Chee 2012-02-03 12:30:58 PST
*** Bug 723921 has been marked as a duplicate of this bug. ***
Comment 10 Eddward 2012-02-04 04:45:26 PST
Looks like here is the same issue: http://gs.statcounter.com/#
Mozilla/5.0 (Windows NT 6.1; rv:13.0a1) Gecko/20120203 Firefox/13.0a1
Adblock Plus enabled.
Comment 11 kancaras 2012-02-04 09:47:38 PST
its still not working correctly with 02/04 build
youtube.com plays all videos but menus are sometimes behaving not like they should. greamonkeys scripts also aint working.
Comment 12 Max 2012-02-04 10:31:18 PST
in 13.0a1 i can't hardly watch any videos (except youtube)... please fix this; except for this bug, nightly is the best browser for me...
Comment 13 bogas04 2012-02-04 10:39:48 PST
(In reply to Max from comment #12)
> in 13.0a1 i can't hardly watch any videos (except youtube)... please fix
> this; except for this bug, nightly is the best browser for me...

(In reply to kancaras from comment #11)
> its still not working correctly with 02/04 build
> youtube.com plays all videos but menus are sometimes behaving not like they
> should. greamonkeys scripts also aint working.


Of course they will fix it, moreover nightlies are not meant to be always crashfree and stable for everyday use , just give them some time and stop commenting again and again , it ain't helping.
Comment 14 rob64rock 2012-02-04 14:51:50 PST
I can confirm that use any userscripts that have any thing to do with embedded flash videos or objects are also not functioning when using the extension Scriptish 2012-02-04 dev build.
Comment 15 tomko222 2012-02-06 07:39:05 PST
Same problems with 13.0a1 (2012-02-06)
Comment 16 Paul [pwd] 2012-02-06 08:00:40 PST
Affected sites list also includes BBC iPlayer.
Comment 17 rob64rock 2012-02-06 16:56:34 PST
(In reply to Paul [sabret00the] from comment #16)
> Affected sites list also includes BBC iPlayer.

Also sites: Novamov.com, Gorillavid.com, and Daclips.com(AKA: Daclips.in)
Comment 18 rob64rock 2012-02-06 17:24:23 PST
(In reply to rob64rock from comment #17)
> (In reply to Paul [sabret00the] from comment #16)
> > Affected sites list also includes BBC iPlayer.
> 
> Also sites: Novamov.com, Gorillavid.com, and Daclips.com(AKA: Daclips.in)

Also site: Movpod.net(AKA: Movpod.in)
Comment 19 tomko222 2012-02-06 18:45:22 PST
I think that writing more and more sites is not needed to solve this because it's not like fixing every site separately.
Comment 20 Paul [pwd] 2012-02-07 02:49:23 PST
Seeing that this isn't a blanket issue, any information that may help diagnose the problem and facilitate its patching would probably help a lot more than attempts to police the bug.
Comment 21 Wladimir Palant 2012-02-07 03:12:06 PST
Paul, this is a very common issue - judging by the issue reports I am getting it affects half of the web. It can be reproduced perfectly well on the website I mentioned when I reported this, adding more websites doesn't add any new information, it merely increases the noise. It is also clear what happens (Flash objects get wrapped too early, see comment 5) so it is best to just let the developers figure this out.
Comment 22 Matthias Versen [:Matti] 2012-02-07 11:00:58 PST
*** Bug 725001 has been marked as a duplicate of this bug. ***
Comment 23 Kirk Elifson 2012-02-07 11:57:13 PST
Vimeo is also an affected site. Running fully-updated nightly on W7 x64, w/ Adblock Plus.

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:13.0a1) Gecko/20120207 Firefox/13.0a1
Comment 24 Emanuel Hoogeveen [:ehoogeveen] 2012-02-08 13:07:21 PST
Running the latest hourly (built off b584b4be0a00), this bug seems fixed (tested on speedtest.net and twitch.tv). Positive fallout from bug 723379?
Comment 25 kancaras 2012-02-08 13:25:59 PST
Emanuel, this bug hasnt been marked as RESOLVED FIXED and many features aint working as expected. I didnt test them all but greasmonkey scripts on youtube aint working with newest firefox version 1328722077.
Comment 26 Emanuel Hoogeveen [:ehoogeveen] 2012-02-08 13:34:41 PST
Alright, fair enough. But the example that was used in filing this bug (speedtest.net's Flash object not loading) appears to be fixed, so maybe this bug should be repurposed or a bug opened for the remaining issues?
Comment 27 kancaras 2012-02-08 13:48:32 PST
Yes, description should always be clear. BTW i thought this might be helpful: broken builds started with 15b00ab7f22d, latest "good" build is b506d48ef7aa - folder 1328045792 in hourlies.
Comment 28 annaeus 2012-02-08 17:36:26 PST
Just tried the latest hourly. Of course it's to early to say for sure, but as of now : gametrailers, youtube, vimeo, speedtest
everything is running as it should. I have adblock and scriptish installed including
some scripts for youtube and gametrailers. Even miniclip (not working on nightly) works fine.
Comment 29 Gary [:streetwolf] 2012-02-09 05:46:52 PST
It looks like changeset 86418:b584b4be0a00 http://hg.mozilla.org/mozilla-central/rev/b584b4be0a00 fixed the problem.
Comment 30 Josh Aas 2012-02-09 06:44:32 PST
Excellent, re-open if the problem re-appaears.
Comment 31 IU 2012-02-09 07:54:35 PST
If this is really fixed, I suppose Flashblock does not fit into this category, as it still must be disabled for Flash to work.
Comment 32 Bur 2012-02-09 14:15:11 PST
I'm not sure if this is the same bug or related. I have Adblock Plus installed, but this problem also occurs in safe mode.

Since two or three nightlies ago (current being 2012-02-09) the flash object on video sites like sockshare.com, gorillavid.com or videarn is not visible for me. Right-clicking the area where it is supposed to be located opens the standard context menu, nothing flash related.

Site information shows the object as being there, but the entry is in italics and greyed out. speedtest.net works though, so far I'm only aware of flash video not working.
Comment 33 Paul [pwd] 2012-02-09 14:19:14 PST
sockshare you seem to need a direct video link. gorillavid seems to be setting off my antivirus and videoarn is NSFW but seems to work normally. Are you sure you're using the latest nightly to test?
Comment 34 Mike Pesce (:By-Tor) 2012-02-09 14:22:23 PST
The videos embedded on cnn.com pages still don't work properly with ABP.  Whether this is a separate issue or not, I can't say.  But, I find it hard to say the issue has been resolved.
Comment 36 softice86 2012-02-09 14:35:27 PST
CNN videos are working for me too, and I have ABP installed too.
Gorillavid is setting off my AV too since at least 6 days, so I can say that it's completely unrelated to this bug.
Comment 37 Mike Pesce (:By-Tor) 2012-02-09 14:52:49 PST
I'm talking about videos that are embedded further down the page, such as this:
http://www.cnn.com/2012/02/09/world/europe/europe-cold-snap/index.html

The videos further down the page won't work for me.
Comment 38 softice86 2012-02-09 15:09:04 PST
Confirmed: the smaller videos in this page http://www.cnn.com/2012/02/09/world/europe/europe-cold-snap/index.html don't work for me, even in safe mode.
Comment 39 Alice0775 White 2012-02-09 15:42:12 PST
(In reply to Mike Pesce (:By-Tor) from comment #37)
> I'm talking about videos that are embedded further down the page, such as
> this:
> http://www.cnn.com/2012/02/09/world/europe/europe-cold-snap/index.html
> 
> The videos further down the page won't work for me.

Filed Bug 725855
Comment 40 Jim Jeffery not reading bug-mail 1/2/11 2012-02-09 16:27:08 PST
(In reply to Alice0775 White from comment #39)
> (In reply to Mike Pesce (:By-Tor) from comment #37)
> > I'm talking about videos that are embedded further down the page, such as
> > this:
> > http://www.cnn.com/2012/02/09/world/europe/europe-cold-snap/index.html
> > 
> > The videos further down the page won't work for me.
> 
> Filed Bug 725855


WFM, but take several seconds to start loading - and playing.

Latest m-c hourly win32 build: https://hg.mozilla.org/mozilla-central/rev/92d3c66fe897
Comment 41 rob64rock 2012-02-09 16:49:37 PST
(In reply to rob64rock from comment #17)
> (In reply to Paul [sabret00the] from comment #16)
> > Affected sites list also includes BBC iPlayer.
> 
> Also sites: Novamov.com, Gorillavid.com, Daclips.com(AKA: Daclips.in) and Movpod.net(AKA: Movpod.in)

Using the latest Win32 Nightly 20120209 build with latest dev build of ABP, sites  Gorillavid.com, Daclips.com(AKA: Daclips.in) and Movpod.net(AKA: Movpod.in) are now working. I'm still having problems with YouTube userscripts using extension Scriptish not working. I had to start using extension Scriptify: https://addons.mozilla.org/firefox/addon/scriptify/.

Note: I couldn't test Novamov.com the site is under going a server upgrade currently.
Comment 42 Bur 2012-02-10 00:23:53 PST
Gorillavid.com is working, I still have the problem with sockshare.com. Here's a link to a SFW/non-copyrighted video: http://www.sockshare.com/file/6902291F4A29FDED

I get the play-button but after clicking on it no flash object appears (noth safe-mode and standard).

Here's some version info:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120209 Firefox/13.0a1
ABP 2.0.4a.3409
NoScript 2.2.9
Comment 43 msth67 2012-02-10 02:42:29 PST

Just observed that in the current nightly UX  http://www.speedtest.net/ works only when flash is toggled off and then on again and the page is reloaded skipping the cache.
Version 13.0a1
User Agent Mozilla/5.0 (Windows NT 5.1; rv:13.0a1) Gecko/20120209 Firefox/13.0a1
Adblock Plus2.0.3
NoScript2.2.9
FlashToggle0.4
Comment 44 Steven Michaud [:smichaud] (Retired) 2012-02-10 09:15:56 PST
There's a small chance my patch at bug 723520 might help here.  Please try one of the tryserver builds at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/smichaud@pobox.com-292c77354647/.
Comment 45 kancaras 2012-02-10 09:28:31 PST
(In reply to Steven Michaud from comment #44)
> There's a small chance my patch at bug 723520 might help here.  Please try
> one of the tryserver builds at
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/smichaud@pobox.com-
> 292c77354647/.

didnt solve my problems mentioned above.
Comment 46 Bur 2012-02-10 15:18:56 PST
Could anyone confirm whether http://www.sockshare.com/file/6902291F4A29FDED works with ABP or not? It might well be that there's another reason why it's not working here (don't worry about the video it's a few mini pigs my brother filmed some time ago...).
Comment 47 Justin Lebar (not reading bugmail) 2012-02-10 21:37:49 PST
> Could anyone confirm whether http://www.sockshare.com/file/6902291F4A29FDED works with ABP or not?

Doesn't work for me.

Please, if you have additional sites which don't work, file new bugs.  Piling on here makes it very difficult for us to track these issues.
Comment 48 msth67 2012-02-11 00:58:17 PST
(In reply to Steven Michaud from comment #44)
> There's a small chance my patch at bug 723520 might help here.  Please try
> one of the tryserver builds at
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/smichaud@pobox.com-
> 292c77354647/.

It works,speedtest.net loads normally with this build.
Comment 49 rob64rock 2012-02-18 13:28:50 PST
(In reply to Justin Lebar [:jlebar] from comment #47)
> > Could anyone confirm whether http://www.sockshare.com/file/6902291F4A29FDED works with ABP or not?
> 
> Doesn't work for me.
> 
> Please, if you have additional sites which don't work, file new bugs. 
> Piling on here makes it very difficult for us to track these issues.

Bug Now Filed:
Bug 726278
Comment 50 Virgil Dicu [:virgil] [QA] 2012-05-21 05:00:46 PDT
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0

Verified in F13 beta 4 with add-on in comment 0 installed and sites which previously exhibited the issue: speedtest.net and http://gs.statcounter.com/

Flash objects now load correctly.
Comment 52 Paul [pwd] 2012-11-03 09:25:21 PDT
Apologies people. Wrong bug.
Comment 53 shape5 2014-08-31 17:04:48 PDT
looks like this bug has reappeared in a recent version of Nightly.  If i disable Adblock Plus then Speedtest.net loads again. Disabling it on the site only from the ABP drop-down menu doesn't do the trick. I have to disable the add-on in the add-ons manager.  Testing it with FF 31 Speedtest loads fine with ABP.
Comment 54 Wladimir Palant 2014-09-01 04:45:21 PDT
(In reply to shape5 from comment #53)
> looks like this bug has reappeared in a recent version of Nightly.

Speedtest.net works fine for me but this might be OS-dependent. In general, a bug that was fixed two years ago definitely won't just reappear - a *different* bug with similar symptoms might appear however. So please file a new bug report and provide some info there (operating system, Flash version, ABP version etc).
Comment 55 shape5 2014-09-02 18:41:56 PDT
ok, gotcha. I filed a new report here: https://bugzilla.mozilla.org/show_bug.cgi?id=1062035

thanks

Note You need to log in before you can comment on or make changes to this bug.