Last Comment Bug 723641 - Different compatibilty message shown in add-on page on Firefox 10 Beta and Firefox 10 Release
: Different compatibilty message shown in add-on page on Firefox 10 Beta and Fi...
Status: RESOLVED WORKSFORME
:
Product: addons.mozilla.org Graveyard
Classification: Graveyard
Component: Public Pages (show other bugs)
: unspecified
: All All
: P1 critical
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
https://addons.mozilla.org/en-US/fire...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-02 11:13 PST by Jorge Villalobos [:jorgev]
Modified: 2016-02-04 14:51 PST (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screen shot demonstrating problem. (181.71 KB, image/png)
2012-02-02 13:30 PST, John Nagle
no flags Details

Description Jorge Villalobos [:jorgev] 2012-02-02 11:13:55 PST
Steps to reproduce:

Visit this page https://addons.mozilla.org/en-US/firefox/addon/ad-limiter/ with Firefox 10 Beta and Firefox 10 Release.

Beta shows a light warning: "May be incompatible with Firefox 10.0". Clicking on the install button will initiate installation immediately.
Release shows a strong warning: "Not available for Firefox 10.0". Clicking on the install button shows another warning before allowing installation.

Because of Default to Compatible, we should be removing all compatibility roadblocks for add-ons that are compatible with at least Firefox 4. I think there's a separate bug for that, but this Beta/Release inconsistency is very odd.
Comment 1 krupa raj[:krupa] 2012-02-02 11:18:43 PST
On checking with Jorgev, looks like he has ACR installed. We show "May be incompatible.." message for users who have ACR. This is by design as far as I can tell.
Comment 2 John Nagle 2012-02-02 13:30:02 PST
Created attachment 593956 [details]
Screen shot demonstrating problem.

This screen shot was taken with the release version of Firefox 10, without any add-on version related tools installed in the browser.

Note that the add-on in question has been updated, so that the message will no longer appear for this add-on.
Comment 3 John Nagle 2012-02-02 13:32:28 PST
It's not related to ACR.  See attached screenshot above.

(Status: DEVELOPER IN DENIAL.)
Comment 4 krupa raj[:krupa] 2012-02-02 13:42:06 PST
Hey John,

We know that we need to update the user messaging in AMO regarding add-on compatibility. We are working on that right now. 

This bug was about inconsistency in user messaging between beta and release versions of Firefox which is indeed related to ACR.

Sorry about the confusion.
Comment 5 Jorge Villalobos [:jorgev] 2012-02-02 15:01:56 PST
@Nagle, the bug you can to follow is bug 723724.

Note You need to log in before you can comment on or make changes to this bug.