regression: Panning in XUL fennec does not start until finger is removed from screen.

RESOLVED FIXED in Firefox 13

Status

Fennec Graveyard
Panning/Zooming
--
major
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

({regression})

Firefox 12
Firefox 13
ARM
Android
regression
Dependency tree / graph

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Note: This is in a build of mozilla-central tip plus the patch from bug 723480.  (Without that patch, panning doesn't work at all.)

Steps to reproduce:
1) Drag to scroll any part of chrome or content in XUL Fennec.

Expected results: Scrolling happens as you move your finger.
Actual results: Nothing happens while you drag.  Scrolling happens after you lift your finger.

It looks like mouse events aren't sent until a touch is finished.  Possibly a regression from bug 721484.
(Assignee)

Comment 1

5 years ago
Created attachment 594033 [details] [diff] [review]
patch

This fixes the bug for me.  Next I'll test to make sure it doesn't regress anything in native Fennec.
Attachment #594033 - Flags: review?(wjohnston)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
status-firefox12: --- → affected
Whiteboard: [has patch]
Version: Trunk → Firefox 12
Comment on attachment 594033 [details] [diff] [review]
patch

Review of attachment 594033 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with a little change. Thanks for finding this matt!

::: widget/android/nsWindow.cpp
@@ -1586,3 @@
>      }
>      return false;
>  }

We can just remove this return and instead return preventPanning at the end.
Attachment #594033 - Flags: review?(wjohnston) → review+
(Assignee)

Comment 3

5 years ago
Pushed with review comment addressed:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9d1a7abd2991

QA note: It won't be possible to verify this fix until bug 723480 is fixed.
status-firefox13: affected → fixed
Depends on: 723480
Whiteboard: [has patch]
Target Milestone: --- → Firefox 13
(Assignee)

Comment 4

5 years ago
Comment on attachment 594033 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): bug 721484

User impact if declined: Panning is badly broken in XUL fennec.

Testing completed (on m-c, etc.): Landed on inbound 2/2.

Risk to taking this patch (and alternatives if risky): This is a low-risk Android-only trivial fix for some broken code.

String changes made by this patch: None.
Attachment #594033 - Flags: approval-mozilla-beta?
Attachment #594033 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/9d1a7abd2991
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 6

5 years ago
Comment on attachment 594033 [details] [diff] [review]
patch

[Triage Comment]
Approved for Aurora 12 and Beta 11.
Attachment #594033 - Flags: approval-mozilla-beta?
Attachment #594033 - Flags: approval-mozilla-beta+
Attachment #594033 - Flags: approval-mozilla-aurora?
Attachment #594033 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/e222d18ba92c
status-firefox11: --- → affected
status-firefox12: affected → fixed
https://hg.mozilla.org/releases/mozilla-beta/rev/4582aedd2320
status-firefox11: affected → fixed
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.