Single touch broken in Feb 1 2012 XUL Nightly

VERIFIED FIXED in Firefox 13

Status

Fennec Graveyard
General
--
critical
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Robert Kaiser, Assigned: mbrubeck)

Tracking

({regression})

Firefox 12
Firefox 13
regression
Dependency tree / graph

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
I just downloaded the XUL Nightly of Feb 1 (first with 13.0a1, but no real code changes in there yet from what I see) to my tablet and discovered that all single-touch actions (clicking links, trying to access tabs, trying to focus the awesomebar or open the menu) are broken. Two-finger pinch zoom works, though.

When I got the last 12.0a1 Nightly from Jan 31, this works fine, so the regression is within this one day of m-c. Given that practically no change landed on m-c between the Aurora uplift and the point where the Feb 1 Nightly was cut, I'd expect this problem to exist on Aurora 12 as well, but I haven't tested yet.
(Reporter)

Comment 1

6 years ago
OK, this is indeed affecting Aurora 12 XUL as well. As this might very well end up shipping on tablets, nominating for tracking.

Also, this means that bug 723200 has no influence on this, as it happens before this landed. And bug 603008 already landed way before the 12.0a1 build from Jan 31 that still works.
tracking-firefox12: --- → ?
(Reporter)

Comment 2

6 years ago
Given the two Nightly builds I tested and looking at their changesets, the regression range would be:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3f26b7bee352&tochange=e18c7bc2c28e

As I tested that this is on today's Aurora 12 as well, we can ignore whatever came after the uplift, so that reduces the regression range to this:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3f26b7bee352&tochange=AURORA_BASE_20120131

Updated

6 years ago
Duplicate of this bug: 723450
(Assignee)

Updated

6 years ago
Assignee: nobody → mbrubeck
tracking-fennec: --- → ?
status-firefox12: --- → unaffected
status-firefox13: --- → affected
tracking-firefox12: ? → ---
(Assignee)

Comment 4

6 years ago
The first bad revision is:
https://hg.mozilla.org/mozilla-central/rev/2fa163bb05d7
Wes Johnston <wjohnston@mozilla.com>
Bug 721484 - Don't disable mouse events for touch events. r=blassey
Blocks: 721484
status-firefox12: unaffected → affected
Version: Trunk → Firefox 12
(Assignee)

Comment 5

6 years ago
Created attachment 594018 [details] [diff] [review]
patch

This fixes the bug for me.
Attachment #594018 - Flags: review?(wjohnston)
Comment on attachment 594018 [details] [diff] [review]
patch

Review of attachment 594018 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not very comfortable reviewing this (I've messed this up twice now because I don't understand how these defines trickle around). Blassey?
Attachment #594018 - Flags: review?(wjohnston) → review?(blassey.bugs)
(Assignee)

Updated

6 years ago
Blocks: 723772
Attachment #594018 - Flags: review?(blassey.bugs) → review+
(In reply to Matt Brubeck (:mbrubeck) from comment #5)
> Created attachment 594018 [details] [diff] [review]

Well not exactly perfect.  I can verify that this patch fixes the issue reported here.  However, we end up back with the issue reported in bug 721484.
(In reply to Bill Gianopoulos [:WG9s] from comment #7)
> (In reply to Matt Brubeck (:mbrubeck) from comment #5)
> > Created attachment 594018 [details] [diff] [review]
> 
> Well not exactly perfect.  I can verify that this patch fixes the issue
> reported here.  However, we end up back with the issue reported in bug
> 721484.

That said, from looking at config.status it appears this patch should have worked correctly in both cases.  Perhaps something else broke the testcase in bug 721484.  I am redoing my native feeenc build with this backed out to see what happens.
(In reply to Bill Gianopoulos [:WG9s] from comment #8)
> (In reply to Bill Gianopoulos [:WG9s] from comment #7)
> > (In reply to Matt Brubeck (:mbrubeck) from comment #5)
> > > Created attachment 594018 [details] [diff] [review]
> > 
> > Well not exactly perfect.  I can verify that this patch fixes the issue
> > reported here.  However, we end up back with the issue reported in bug
> > 721484.
> 
> That said, from looking at config.status it appears this patch should have
> worked correctly in both cases.  Perhaps something else broke the testcase
> in bug 721484.  I am redoing my native feeenc build with this backed out to
> see what happens.

Never mind.  I can't get that testcase to work in today's nightly Android native build either, which does not include this patch.  Must be a different issue.  Go figure ;-)
(Assignee)

Comment 10

6 years ago
https://hg.mozilla.org/mozilla-central/rev/cadfebcc626e
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 13
(Assignee)

Comment 11

6 years ago
Comment on attachment 594018 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): bug 721484

User impact if declined: XUL Fennec completely broken (does not respond to touch input).

Testing completed (on m-c, etc.): Tested locally by myself, wesj, and WG9s; landed on m-c February 3.

Risk to taking this patch (and alternatives if risky): Low risk.  This is a trivial fix to a build system bug that caused some code to be accidentally enabled in XUL Fennec when it never should have been.  This is effectively a partial backout of an accidental change.

String changes made by this patch: None.
Attachment #594018 - Flags: approval-mozilla-beta?
Attachment #594018 - Flags: approval-mozilla-aurora?

Updated

6 years ago
status-firefox13: affected → ---
(Reporter)

Comment 12

6 years ago
As the reporter, I think marking this as verified is OK - I can confirm that today's 13.0a1 XUL Nightly works on my TF101. Thanks for the fix!
Status: RESOLVED → VERIFIED
Comment on attachment 594018 [details] [diff] [review]
patch

[Triage Comment]
Important fix - approved for Aurora 12 and Beta 11.
Attachment #594018 - Flags: approval-mozilla-beta?
Attachment #594018 - Flags: approval-mozilla-beta+
Attachment #594018 - Flags: approval-mozilla-aurora?
Attachment #594018 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-beta/rev/8082febbe120
status-firefox11: --- → fixed
https://hg.mozilla.org/releases/mozilla-aurora/rev/cd3f31d128b8
tracking-fennec: ? → 11+
status-firefox12: affected → fixed
status-firefox13: --- → fixed
You need to log in before you can comment on or make changes to this bug.