New Tab Page frequently leaks 4-700+Kb (AtomImpl + BackstagePass + DOMCSSDeclarationImpl + DOMCSSStyleRule + more) in mochitest-browser-chrome

RESOLVED DUPLICATE of bug 750424

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 750424
6 years ago
4 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure, mlk, regression})

Trunk
intermittent-failure, mlk, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox13- affected, firefox14- affected)

Details

(Whiteboard: [MemShrink:P1])

(Reporter)

Description

6 years ago
This leak exploded this morning on mozilla-inbound, and I wanted to pin it on the push after a merge from mozilla-central, because the merge was green and the next push had three instances of this leak, but I didn't have time during the day, and then bugmail about this same leak being misstarred as a crashtest leak alerted me that it was on mozilla-central before my blame-target had gotten there.

First seen on mozilla-central on https://hg.mozilla.org/mozilla-central/rev/1cdef0321abd (merge from fx-team), first seen on fx-team on https://hg.mozilla.org/integration/fx-team/rev/29c4463e6a2e (enable New Tab Page and what I presume are supporters, which are just as likely to be the real cause I suppose).

Retriggers in https://tbpl.mozilla.org/?tree=Fx-Team&rev=29c4463e6a2e show plenty more instances beside the one that was there from the initial push; retriggers on the parent in https://tbpl.mozilla.org/?tree=Fx-Team&rev=e7f7c1e948ca don't show any (gambling, because I still have a couple of retriggers running right this second, but the odds are with me).

Sorry, but, j'accuse.

http://tbpl.swatinem.de/php/getLeakAnalysis.php?id=9053424 (the working version of the "analyze the leak" links that are broken on tbpl.m.o) only mentions the lying not actually leaked domwindow from test_process_error.xul, so unfortunately there's no help about which test is triggering the leak, other than "something in browser-chrome" (and "not test_process_error.xul, which isn't even in browser-chrome").
(Reporter)

Comment 1

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9049357&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9050675&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9050853&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9045027&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9042171&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9044949&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9045241&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9040562&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9034825&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9034134&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9034857&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9047572&tree=Mozilla-Inbound
(Reporter)

Comment 2

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9059217&tree=Mozilla-Inbound
(Reporter)

Comment 3

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9066988&tree=Mozilla-Inbound

Comment 4

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9067365&tree=Firefox
(Reporter)

Comment 5

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9062661&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9067725&tree=Mozilla-Inbound
(Reporter)

Comment 6

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9056354&tree=Mozilla-Inbound
Summary: New Tab Page frequently leaks 700+Kb (AtomImpl + BackstagePass + DOMCSSDeclarationImpl + DOMCSSStyleRule + more) in mochitest-browser-chrome → New Tab Page frequently leaks 4-700+Kb (AtomImpl + BackstagePass + DOMCSSDeclarationImpl + DOMCSSStyleRule + more) in mochitest-browser-chrome

Comment 7

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9068364&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9068265&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9068623&tree=Mozilla-Inbound

Comment 8

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9073312&tree=Mozilla-Inbound

Comment 9

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9072819&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=9076148&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=9079799&tree=Mozilla-Inbound
(Reporter)

Comment 12

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9080127&tree=Mozilla-Inbound
I'm optimistic about this being fixed by bug 723102 - we accidentally hold New Tab Pages alive by the JSM (instead of properly unregistering them). Will land today.
Depends on: 723102
https://tbpl.mozilla.org/php/getParsedLog.php?id=9084739&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9081776&tree=Try
https://tbpl.mozilla.org/php/getParsedLog.php?id=9085373&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=9090856&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9090751&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9071318&tree=Try
(Reporter)

Comment 20

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9091625&tree=Mozilla-Inbound
(Reporter)

Comment 21

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9091084&tree=Mozilla-Inbound
(Reporter)

Comment 22

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9092598&tree=Mozilla-Inbound
(Reporter)

Comment 23

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9093001&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9093599&tree=Mozilla-Inbound
(Reporter)

Comment 25

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9094079&tree=Mozilla-Inbound
(Reporter)

Comment 26

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9097451&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=9097603&tree=Mozilla-Inbound
Marking as fixed by bug 723102.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 28

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9230791&tree=Mozilla-Aurora (a couple of pushes after you flipped the pref on aurora) reminds me a great deal of this, so I think you might have had another thing involved in the leak fix, that didn't hit aurora.
https://tbpl.mozilla.org/php/getParsedLog.php?id=9244606&tree=Mozilla-Aurora
(Reporter)

Comment 30

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9334357&tree=Mozilla-Aurora
(Reporter)

Comment 31

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9342758&tree=Mozilla-Aurora
(Reporter)

Comment 32

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9341168&tree=Mozilla-Aurora
(Reporter)

Comment 33

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9341093&tree=Mozilla-Aurora
(Reporter)

Comment 34

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9343563&tree=Mozilla-Aurora
(Reporter)

Comment 35

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9343721&tree=Mozilla-Aurora
(Reporter)

Comment 36

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9343794&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=9354191&tree=Mozilla-Aurora
(In reply to Phil Ringnalda (:philor) from comment #28)
> https://tbpl.mozilla.org/php/getParsedLog.php?id=9230791&tree=Mozilla-Aurora
> (a couple of pushes after you flipped the pref on aurora) reminds me a great
> deal of this, so I think you might have had another thing involved in the
> leak fix, that didn't hit aurora.

Yeah, but I don't have a clue what changeset fixed that entirely. Need to look what landed around the same time.
(Reporter)

Comment 39

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9373199&tree=Mozilla-Aurora
(Reporter)

Comment 40

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9375968&tree=Mozilla-Aurora
(Reporter)

Comment 41

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9375028&tree=Mozilla-Aurora
(Reporter)

Comment 42

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10084544&tree=Mozilla-Inbound

Sure was nice having this gone for a while, back when it was gone for a while.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 43

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10085551&tree=Firefox
(Reporter)

Comment 44

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10101370&tree=Mozilla-Inbound
(Reporter)

Comment 45

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10105253&tree=Mozilla-Inbound
(Reporter)

Comment 46

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10106611&tree=Mozilla-Inbound
(Reporter)

Comment 47

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10118503&tree=Mozilla-Inbound
(Reporter)

Comment 48

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10125140&tree=Mozilla-Inbound
(Reporter)

Comment 49

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10120637&tree=Mozilla-Aurora
(Reporter)

Updated

5 years ago
status-firefox13: --- → affected
https://tbpl.mozilla.org/php/getParsedLog.php?id=10131089&tree=Firefox&full=1
(Reporter)

Comment 51

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10137804&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10161887&tree=Mozilla-Inbound
(Reporter)

Comment 53

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10169069&tree=Firefox
(Reporter)

Comment 54

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10170156&tree=Try
(Reporter)

Comment 55

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10199603&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10218365&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10224865&tree=Mozilla-Inbound
(Reporter)

Comment 58

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10238196&tree=Mozilla-Inbound
(Reporter)

Comment 59

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10255792&tree=Mozilla-Inbound
Nominating for tracking because it is a fairly large, fairly frequent leak apparently introduced by a new feature.
status-firefox14: --- → affected
tracking-firefox13: --- → ?
tracking-firefox14: --- → ?
Whiteboard: [orange] → [orange][MemShrink]
Depends on: 738167
(Reporter)

Comment 61

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10336086&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=10336741&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10339907&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10345168&tree=Mozilla-Inbound
(Reporter)

Comment 65

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10365436&tree=Firefox
(Reporter)

Comment 66

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10377569&tree=Mozilla-Inbound
(Reporter)

Comment 67

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10378946&tree=Mozilla-Inbound
(In reply to Andrew McCreight [:mccr8] from comment #60)
> Nominating for tracking because it is a fairly large, fairly frequent leak
> apparently introduced by a new feature.

This is reasonable - also sending over to Tim since we suspect this to be related to the new tab page.
Assignee: nobody → ttaubert
tracking-firefox13: ? → +
tracking-firefox14: ? → +
(Reporter)

Comment 69

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10387002&tree=Mozilla-Aurora
(Reporter)

Comment 70

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10391485&tree=Mozilla-Inbound
(Reporter)

Comment 71

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10393907&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10402559&tree=Fx-Team
(Reporter)

Comment 73

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10403506&tree=Mozilla-Inbound
Whiteboard: [orange][MemShrink] → [orange][MemShrink:P1]
https://tbpl.mozilla.org/php/getParsedLog.php?id=10433012&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=10433443&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10437518&tree=Mozilla-Inbound
(Reporter)

Comment 77

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10444825&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=10469262&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10471032&tree=Fx-Team
(Reporter)

Comment 80

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10471003&tree=Mozilla-Inbound
(Reporter)

Comment 81

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10469839&tree=Firefox
(Reporter)

Comment 82

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10478029&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10482914&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10486917&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10488963&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=10502922&tree=Fx-Team
(Reporter)

Comment 87

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10505665&tree=Mozilla-Inbound
(Reporter)

Comment 88

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10509760&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10515921&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10518271&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10549478&tree=Mozilla-Inbound
(Reporter)

Comment 92

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10577943&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=10602050&tree=Firefox
(Reporter)

Comment 94

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10613739&tree=Mozilla-Aurora
(Reporter)

Comment 95

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10657145&tree=Mozilla-Inbound
(Reporter)

Comment 96

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10657316&tree=Mozilla-Inbound
(Reporter)

Comment 97

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10667032&tree=Mozilla-Inbound
(Reporter)

Comment 98

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10670792&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10683992&tree=Fx-Team
(Reporter)

Comment 100

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10693267&tree=Mozilla-Inbound
(Reporter)

Comment 101

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10712631&tree=Mozilla-Inbound
(Reporter)

Comment 102

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10718373&tree=Mozilla-Inbound
(Reporter)

Comment 103

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10745751&tree=Mozilla-Inbound
(Reporter)

Comment 104

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10759821&tree=Mozilla-Aurora
(Reporter)

Comment 105

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10765719&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=10765563&tree=Mozilla-Aurora
(Reporter)

Comment 106

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10768009&tree=Mozilla-Inbound
(Reporter)

Comment 107

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10785368&tree=Mozilla-Aurora
(Reporter)

Comment 108

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10794259&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10806253&tree=Mozilla-Inbound
(Reporter)

Comment 110

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10803970&tree=Mozilla-Inbound
(Reporter)

Comment 111

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10820306&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10824216&tree=Fx-Team
(Reporter)

Comment 113

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10836189&tree=Mozilla-Inbound
(Reporter)

Comment 114

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10845780&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10874891&tree=Fx-Team
(Reporter)

Comment 116

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10860015&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10893556&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=10907274&tree=Mozilla-Inbound
(Reporter)

Comment 119

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10926928&tree=Mozilla-Inbound
(Reporter)

Comment 120

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10929142&tree=Mozilla-Inbound
What's happening here?  This is a significant leak in a new feature.
(Reporter)

Comment 122

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10960793&tree=Mozilla-Aurora
(Reporter)

Comment 123

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10983923&tree=Mozilla-Inbound
(Reporter)

Comment 124

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11011817&tree=Mozilla-Inbound
(Reporter)

Comment 125

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11025520&tree=Mozilla-Inbound
(Reporter)

Comment 126

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11047547&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=11074428&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=11072024&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=11097718&tree=Mozilla-Inbound
(Reporter)

Comment 130

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11103444&tree=Mozilla-Inbound
(Reporter)

Comment 131

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11131471&tree=Mozilla-Aurora
(Reporter)

Comment 132

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11136862&tree=Mozilla-Inbound
(Reporter)

Comment 133

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11138589&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=11153240&tree=Birch
(Reporter)

Comment 135

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11170852&tree=Mozilla-Beta
(Reporter)

Comment 136

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11178420&tree=Mozilla-Aurora
(Reporter)

Comment 137

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11210299&tree=Mozilla-Aurora
(Reporter)

Comment 138

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11215798&tree=Mozilla-Inbound
(Reporter)

Comment 139

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11214542&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=11250206&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=11242795&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=11264708&tree=Mozilla-Inbound
(Reporter)

Comment 143

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11283667&tree=Mozilla-Inbound
(Reporter)

Comment 144

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11277819&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=11321139&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=11320896&tree=Mozilla-Inbound
(Reporter)

Comment 147

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11344645&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=11385697&tree=Firefox
(In reply to Tim Taubert [:ttaubert] from comment #38)
> (In reply to Phil Ringnalda (:philor) from comment #28)
> > https://tbpl.mozilla.org/php/getParsedLog.php?id=9230791&tree=Mozilla-Aurora
> > (a couple of pushes after you flipped the pref on aurora) reminds me a great
> > deal of this, so I think you might have had another thing involved in the
> > leak fix, that didn't hit aurora.
> 
> Yeah, but I don't have a clue what changeset fixed that entirely. Need to
> look what landed around the same time.

This appears to still be a problem on FF13 and up. What are the next steps for this investigation?
I'm kind of hoping that this was fixed by bug 750424. It hasn't happened on inbound since that patch landed, but with the tree closed there haven't been enough pushes to say for sure.
(Reporter)

Comment 151

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11434587&tree=Mozilla-Beta
I'm going to call this fixed.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 750424
(Reporter)

Comment 153

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11545158&tree=Mozilla-Aurora
(Reporter)

Comment 154

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11616635&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=11696918&tree=Mozilla-Beta
https://tbpl.mozilla.org/php/getParsedLog.php?id=11704666&tree=Mozilla-Beta
(In reply to Bill McCloskey (:billm) from comment #150)
> I'm kind of hoping that this was fixed by bug 750424. It hasn't happened on
> inbound since that patch landed, but with the tree closed there haven't been
> enough pushes to say for sure.

We'll track bug 750424 instead in that case. Thanks!
tracking-firefox13: + → -
tracking-firefox14: + → -

Updated

5 years ago
Blocks: 764771
(Reporter)

Updated

5 years ago
No longer blocks: 764771
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange][MemShrink:P1] → [MemShrink:P1]
Assignee: ttaubert → nobody
You need to log in before you can comment on or make changes to this bug.