Closed Bug 724042 Opened 10 years ago Closed 10 years ago

disable tile by tile rendering

Categories

(Firefox for Android Graveyard :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 724230

People

(Reporter: blassey, Unassigned)

Details

(Whiteboard: not-fennec-11)

Attachments

(1 file)

Attached patch patchSplinter Review
No description provided.
Attachment #594245 - Flags: review?(doug.turner)
Comment on attachment 594245 [details] [diff] [review]
patch

This patch unnecessarily allocates a big-ass buffer when using gralloc.
(In reply to Kartikaya Gupta (:kats) from comment #1)
> Comment on attachment 594245 [details] [diff] [review]
> patch
> 
> This patch unnecessarily allocates a big-ass buffer when using gralloc.

Oh, never mind. Misread the patch.
Comment on attachment 594245 [details] [diff] [review]
patch

Review of attachment 594245 [details] [diff] [review]:
-----------------------------------------------------------------

this is fine to get us going.  good to have chris take another look post uplifting.

::: mobile/android/base/gfx/GeckoSoftwareLayerClient.java
@@ +239,3 @@
>                  mBufferSize = new IntSize(width, height);
> +                if (mTileLayer instanceof SingleTileLayer) {
> +                    int size = mBufferSize.getArea() * 2;

why * 2?

@@ +286,4 @@
>              // Reallocate the buffer if necessary
> +            if (mTileLayer instanceof SingleTileLayer) {
> +                // * 2 because it's a 16-bit buffer (so 2 bytes per pixel).
> +                size = mBufferSize.getArea() * 2;

is it always * 2?
Attachment #594245 - Flags: review?(doug.turner) → review+
(In reply to Doug Turner (:dougt) from comment #3)
> Comment on attachment 594245 [details] [diff] [review]
> patch
> 
> Review of attachment 594245 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> this is fine to get us going.  good to have chris take another look post
> uplifting.
> 
> ::: mobile/android/base/gfx/GeckoSoftwareLayerClient.java
> @@ +239,3 @@
> >                  mBufferSize = new IntSize(width, height);
> > +                if (mTileLayer instanceof SingleTileLayer) {
> > +                    int size = mBufferSize.getArea() * 2;
> 
> why * 2?
> 
> @@ +286,4 @@
> >              // Reallocate the buffer if necessary
> > +            if (mTileLayer instanceof SingleTileLayer) {
> > +                // * 2 because it's a 16-bit buffer (so 2 bytes per pixel).
> > +                size = mBufferSize.getArea() * 2;
> 
> is it always * 2?

yes, its always 2.
Backed out in inbound:

https://hg.mozilla.org/integration/mozilla-inbound/rev/9415c0c24d53

since Chris put up a more comprehensive patch in bug 724230 that we should use instead.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: [inbound]
Duplicate of bug: 724230
Whiteboard: not-fennec-11
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.