Last Comment Bug 724230 - On-demand tile patches are risky and unnecessary without further patches/testing
: On-demand tile patches are risky and unnecessary without further patches/testing
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 12 Branch
: ARM Android
: -- normal (vote)
: Firefox 13
Assigned To: Chris Lord [:cwiiis]
:
Mentors:
: 724042 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-04 03:46 PST by Chris Lord [:cwiiis]
Modified: 2012-02-06 14:57 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
fixed
fixed


Attachments
Backout ondemand tiling (59.30 KB, patch)
2012-02-04 03:48 PST, Chris Lord [:cwiiis]
no flags Details | Diff | Review
Backout ondemand tiling (59.29 KB, patch)
2012-02-04 03:51 PST, Chris Lord [:cwiiis]
bugmail.mozilla: review+
blassey.bugs: review+
mark.finkle: approval‑mozilla‑aurora+
Details | Diff | Review

Description Chris Lord [:cwiiis] 2012-02-04 03:46:07 PST
The patch in bug #717283 was checked in to enable other optimisations, but none of these optimisations are ready yet. On its own, this patch is possibly a slight performance decrease, and introduces unnecessary risk.

We should back it out until we're ready.

Unfortunately, other work was done inside this patch and on top of it, so the back-out patch is not entirely trivial. Patch incoming.
Comment 1 Chris Lord [:cwiiis] 2012-02-04 03:48:53 PST
Created attachment 594418 [details] [diff] [review]
Backout ondemand tiling

This patch backs out on-demand tiling, but doesn't back out any of the other associated work/fixes (some initialisation memory leak fixes, checkerboard metrics)

I'm currently at FOSDEM and won't be back until Monday evening, so if this needs checking in before Tuesday morning GMT, someone else needs to do it.

I've marked both dougt and blassey as reviewers, but I only think it needs the one review, so whoever takes it, remove the other flags if you could please :)
Comment 2 Chris Lord [:cwiiis] 2012-02-04 03:51:26 PST
Created attachment 594420 [details] [diff] [review]
Backout ondemand tiling

And correct the commit message.
Comment 3 Chris Lord [:cwiiis] 2012-02-04 03:52:02 PST
Try run: http://tbpl.mozilla.org/?tree=Try&rev=7fa0d3a0e995
Comment 4 Brad Lassey [:blassey] (use needinfo?) 2012-02-04 08:58:10 PST
Comment on attachment 594420 [details] [diff] [review]
Backout ondemand tiling

Review of attachment 594420 [details] [diff] [review]:
-----------------------------------------------------------------

pretty rubbery-stampy r+
Comment 5 Kartikaya Gupta (email:kats@mozilla.com) 2012-02-04 15:43:51 PST
Comment on attachment 594420 [details] [diff] [review]
Backout ondemand tiling

Lots of stuff here but I looked over it and there doesn't appear to be anything obviously wrong with it. Try run is also green, and I built it locally and it seems to work fine.
Comment 6 Kartikaya Gupta (email:kats@mozilla.com) 2012-02-04 15:51:19 PST
*** Bug 724042 has been marked as a duplicate of this bug. ***
Comment 7 Kartikaya Gupta (email:kats@mozilla.com) 2012-02-04 15:52:09 PST
Landed on inbound:

https://hg.mozilla.org/integration/mozilla-inbound/rev/f9eb58a6dd6a
Comment 8 Ed Morley [:emorley] 2012-02-05 03:58:50 PST
https://hg.mozilla.org/mozilla-central/rev/f9eb58a6dd6a
Comment 9 Mark Finkle (:mfinkle) (use needinfo?) 2012-02-06 14:51:44 PST
Comment on attachment 594420 [details] [diff] [review]
Backout ondemand tiling

[Triage Comment]
This is needed on aurora, but not beta. The code never landed there.

This backout should make the rendering performance on aurora match that on trunk and beta.
Comment 10 Mark Finkle (:mfinkle) (use needinfo?) 2012-02-06 14:57:59 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/784efd5bfec0

Note You need to log in before you can comment on or make changes to this bug.