Type 'return' in location bar should use same site as 'search' button

VERIFIED DUPLICATE of bug 53171

Status

SeaMonkey
Search
--
minor
VERIFIED DUPLICATE of bug 53171
18 years ago
10 years ago

People

(Reporter: gekacheka, Assigned: matt)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8.1) Gecko/20010316
BuildID:    2001031604

Typing search terms in location bar is useful.
Customizing search engine is useful.
But hitting return after search terms in location bar should use customized
search engine!

Reproducible: Always
Steps to Reproduce:
1. Menu Edit | Preferences 
2. Navigate tree to Navigator > Internet Search
3. Select Default Seach Engine:  Google
4. Click OK to top level.
5. Type search terms in location bar.
6. Click 'search' button
  This should successfully perform search on Google.
7. Type search terms in location bar.
8. This time, hit the the return key.
  Bug: uses search.netscape.com (which happens to use google, but
    also adds lots of irrelevant clutter.)

Actual Results:  Searched using search.netscape.com

Expected Results:  Search using www.google.com

Hitting return key should be same as clicking 'search' button when location bar
contents is not a URL.

Workaround: click search button instead of hitting return.

Comment 1

18 years ago
dup of bug 53171

*** This bug has been marked as a duplicate of 53171 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Gilles, thanks for finding this dupe. bug 53171 looks like the oldest bug on the subject but I'm
fairly certain there is another dupe out there with a fair amount of discussion. I seem to
remember blathering on endlessly on this subject in another bug...

VERIFIED Dupe.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.