Closed Bug 724292 Opened 10 years ago Closed 10 years ago

Android Marketplace activity opening issue

Categories

(Firefox for Android Graveyard :: General, defect, P3)

11 Branch
ARM
Android
defect

Tracking

(firefox11 affected, firefox12 affected, firefox13 fixed, fennec11+)

RESOLVED FIXED
Firefox 13
Tracking Status
firefox11 --- affected
firefox12 --- affected
firefox13 --- fixed
fennec 11+ ---

People

(Reporter: rnewman, Assigned: mbrubeck)

References

Details

Attachments

(1 file)

While testing a release test split-APK package on the market today [1], I ran into an Android issue I'm fairly sure was introduced when Sync was bundled with Fennec. After installing the package from the market, an attempt to tap 'Open' directly from the market issues a notification: "The requested item couldn't be found on this device so couldn't be launched". I'm guessing this is due to multiple activities now defined in the Android Manifest, and one of them, Fennec, I assume needs to be specified as the default launching activity. 

Starting Fennec directly from market fails. This happens on Gingerbread for me but not ICS (you also see this when installing Nightly or Fennec manually and the open button is greyed out on any platform).
This is for m-c. Testing now, though I can't test uploading it to the Marketplace.

Note that the alias must come *after* the Activity. If it works for me locally, I suggest applying it to Beta and rolling up a build so it can be tested properly.
Installed build APK through Browser. Android 3.2.1. Installation dialog's "Open" button launched Fennec. Tapping the Sync icon while Fennec is running takes you to… Fennec. If I force-close Fennec, tapping the Sync icon takes me to Settings. Only the setup banner in Fennec will take me straight to Sync setup.

Humph.

*resumes testing*
Actually, that's the behavior we get *now* on m-c, so it's not a regression. Behavior is identical with and without the alias definition.

If this patch helps with the Marketplace, then…

Over to someone else to try that out.

(By the way, quote in Comment 0 is from AaronMT.)
So, yes, main concern is that users will see the toast notification "The requested item couldn't be found on this device so couldn't be launched", as I have seen today (testing the split-release test) when tapping 'Open' once downloaded Beta from market and think the package is corrupted.
>Starting Fennec directly from market fails. This happens on Gingerbread for me but >not ICS (you also see this when installing Nightly or Fennec manually and the open >button is greyed out on any platform).

FWIW: 

- Toast notification (SplitReleaseTest from Store) = can't repro on ICS
- "Open" Button being disabled when installing Nightly manually (nightly.mozilla.org)= also can't repro on ICS
Any update?
I've done all I can here.
Assignee: nobody → mark.finkle
tracking-fennec: --- → ?
This also happens on Froyo and Eclair: "The requested item couldn't be found on this device so couldn't be launched".
Attachment #594483 - Flags: review?(blassey.bugs)
tracking-fennec: ? → 11+
Attachment #594483 - Flags: review?(blassey.bugs) → review+
Could we get rid of the separate launcher icon for Firefox Sync, and just let people access the sync activity through in-browser UI and through the system settings?
(In reply to Matt Brubeck (:mbrubeck) from comment #10)
> Could we get rid of the separate launcher icon for Firefox Sync, and just
> let people access the sync activity through in-browser UI and through the
> system settings?

Up to UX, really.

If the Fennec home screen offers affordances for both setting up Sync and pairing a new device, we're confident in their discoverability, and UX doesn't see any value in the additional entry point, then I have no significant objection.

I'd still be interested to know if this manifest change works. I would be surprised if the Fennec bundled functionality will be limited to one launcher icon for the rest of time.
(In reply to Richard Newman [:rnewman] from comment #11)
> I'd still be interested to know if this manifest change works.

Rel-eng has a marketplace test account
Assignee: mark.finkle → nobody
(In reply to Richard Newman [:rnewman] from comment #11)
> (In reply to Matt Brubeck (:mbrubeck) from comment #10)
> > Could we get rid of the separate launcher icon for Firefox Sync, and just
> > let people access the sync activity through in-browser UI and through the
> > system settings?
> 
> Up to UX, really.
> 
> If the Fennec home screen offers affordances for both setting up Sync and
> pairing a new device, we're confident in their discoverability, and UX
> doesn't see any value in the additional entry point, then I have no
> significant objection.
> 
> I'd still be interested to know if this manifest change works. I would be
> surprised if the Fennec bundled functionality will be limited to one
> launcher icon for the rest of time.

I'm biased, caring mostly about Firefox users, but I think this would solve more problems than it creates. We can use a visual for sync as a feature within the browser (i.e. no point using a firefox icon _within_ Firefox), but then we could use the Firefox icon in place of the Sync icon in the sync settings area.

I think that most people who would understand that a sync account is a thing you can set up (without just doing it through firefox as a firefox feature) would know to look in Android Settings for it.
Assignee: nobody → mbrubeck
Blocks: 729681
I tested this in my own Market account, and it works:
https://market.android.com/details?id=org.mozilla.fennec_mbrubeck

I'm landing Richard's patch, because as he says above, even if we remove the Sync icon, we'll need this if we ever add any other launcher icon in the future:
https://hg.mozilla.org/integration/mozilla-inbound/rev/053482215d7f

I filed follow-up bug 729681 to remove the Firefox Sync launcher icon.
Status: NEW → ASSIGNED
Target Milestone: --- → Firefox 13
Priority: -- → P3
https://hg.mozilla.org/mozilla-central/rev/053482215d7f
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.