Last Comment Bug 724408 - [Page Thumbnails] no thumbnails with browser.cache.disk.enable set to false
: [Page Thumbnails] no thumbnails with browser.cache.disk.enable set to false
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- normal with 5 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 722160 (view as bug list)
Depends on: 744388
Blocks: 497543
  Show dependency treegraph
 
Reported: 2012-02-05 12:13 PST by A, T
Modified: 2012-05-02 06:51 PDT (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description A, T 2012-02-05 12:13:19 PST
Thumbnails in about:newtab don't show up with the disk cache disabled, a lot of people run around with it disabled and opt for browser.cache.memory.enable only for both privacy and performance.

Now, it's normal to lose these thumbnails due to the volatile nature of system memory when the application closes or when the OS is restarted, but the thumbnails aren't even saved in the session, no matter how many times the site is visited, essentially, memory cache users are left without thumbnails.  
This also applies to when the disk cache is wiped clean, the thumbnails are lost and visiting the site is required for getting them back. 

You already use storage for different parts of the browser that are exempt from the cache(history,bookmarks,cookies, etc), why not move the thumbnails to its own storage for this?
Comment 1 SpeciesX 2012-02-08 15:05:14 PST
*** Bug 722160 has been marked as a duplicate of this bug. ***
Comment 2 Ilia Penchev 2012-03-31 14:11:08 PDT
My disk cache is enabled, but I got 2-3 thumbnails at best - the other tabs show no thumbnail.
Comment 3 A, T 2012-03-31 15:16:39 PDT
(In reply to Ilia Penchev from comment #2)
> My disk cache is enabled, but I got 2-3 thumbnails at best - the other tabs
> show no thumbnail.

The thumbs sometimes don't generate after one visit to the site, I have noticed this as well, I could reproduce this on sites with a large amount of flash or java applets embedded, or sites with a large amount of hyperlinks before, not anymore though.
Comment 4 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-04-11 07:15:26 PDT
Will be fixed by bug 744388.
Comment 5 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-05-02 06:51:34 PDT
Fixed by bug 744388.

Note You need to log in before you can comment on or make changes to this bug.