Backout nsChangeHint_UpdateOverflow for all properties except transforms. (bug 719177 etc)

RESOLVED FIXED in Firefox 12

Status

()

Core
Layout
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Mats Palmgren (vacation - back in August), Assigned: Mats Palmgren (vacation - back in August))

Tracking

unspecified
mozilla13
Points:
---

Firefox Tracking Flags

(firefox12+ fixed)

Details

(Whiteboard: [qa-])

Attachments

(4 attachments)

Created attachment 594601 [details]
backout commands

Changesets to backout:

Bug 722325
https://hg.mozilla.org/mozilla-central/rev/a8b8c4489e4e

Bug 722117
https://hg.mozilla.org/mozilla-central/rev/a5569fc4c390

Bug 719177
https://hg.mozilla.org/mozilla-central/rev/2cae7e5c62ae
https://hg.mozilla.org/mozilla-central/rev/07bd73451aa4
https://hg.mozilla.org/mozilla-central/rev/13739446fc8e
https://hg.mozilla.org/mozilla-central/rev/0246973f2513
https://hg.mozilla.org/mozilla-central/rev/f222fbece983
https://hg.mozilla.org/mozilla-central/rev/8f11aaac24dc

Part 4 (outline) in bug 524925 
https://hg.mozilla.org/mozilla-central/rev/73eaf1199ff0
Created attachment 594602 [details] [diff] [review]
additional fixes

Additional fixes on top of the backout, as requested in bug 723669.
Try results pending:  https://tbpl.mozilla.org/?tree=Try&rev=fa1a77db5788
Is this something we think we can reinstate later, or is there some fundamental issue with it?
We can reinstate most of it, see bug 723669.
Comment on attachment 594602 [details] [diff] [review]
additional fixes

Review of attachment 594602 [details] [diff] [review]:
-----------------------------------------------------------------

Should we remove nsChangeHint_UpdateTransformLayer and nsChangeHint_UpdateOpacityLayer too? I think we should! It seems to me they currently have the same bug.
Please file a new bug.  This bug is only for making UpdateOverflow work for
transforms and nothing else.  The aim is to merge this to Aurora and leave it
at that state for Fx12.  Then re-land bug 719177 with some additional fixes
(as discussed in bug 723669) on trunk, except for 'text-shadow' which we can
handle in bug 723669 (if we decide to do it).
The Try run was green.  I installed the Try build on my Nexus and it seems to work
fine on sites mentioned in bug 722325, but I'm not exactly sure what to look for.

Chris, I'd appreciate if you can verify that.
https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/mpalmgren@mozilla.com-fa1a77db5788/
tracking-firefox12: --- → ?
Created attachment 594799 [details] [diff] [review]
The full diff for the suggested changes

Feel free to review this patch, or the backout commands + additional fixes
patch, whichever you think is easier to review.
Attachment #594799 - Flags: review?(roc)
(In reply to Mats Palmgren [:mats] from comment #6)
> Please file a new bug.

Sure, filed bug 724502. I'll try to fix it.
Attachment #594602 - Flags: review+
r+ on the patch and backout
https://hg.mozilla.org/mozilla-central/rev/8d25faacb769
https://hg.mozilla.org/mozilla-central/rev/f7ca5d73bbdd
https://hg.mozilla.org/mozilla-central/rev/cffa39f708c0
https://hg.mozilla.org/mozilla-central/rev/66458f5036df
https://hg.mozilla.org/mozilla-central/rev/43251fa50e35
https://hg.mozilla.org/mozilla-central/rev/9237d0cacba5
https://hg.mozilla.org/mozilla-central/rev/14e550268f98
https://hg.mozilla.org/mozilla-central/rev/4eda0eecbb95
https://hg.mozilla.org/mozilla-central/rev/8f1b1574e4b0
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
Attachment #594799 - Flags: review?(roc)
This caused bug 722325 to regress again, so I re-instated that wallpaper and
filed bug 725664 to fix it for real.  The question is - what do we want to do
for Aurora?  Ship with the wallpaper or revert UpdateOverflow also for transforms?
Wallpaper.

Updated

6 years ago
tracking-firefox12: ? → +
Created attachment 596226 [details]
backout for Aurora

Ok, here's the backout commands for Aurora.  Specifically, I'm NOT backing out
the wallpaper for bug 722325, which landed independently for Aurora in
https://hg.mozilla.org/releases/mozilla-aurora/rev/73f3d8eeb937

On top of that, the same "additional fixes" patch.
These changes will make the affected code the same as currently on trunk.
Comment on attachment 596226 [details]
backout for Aurora

[Approval Request Comment]
Regression caused by (bug #): 722117, 719177, 524925 (part 4)
User impact if declined: content rendering errors
Testing completed (on m-c, etc.): baked on trunk for a few days,
pass reftests in local Aurora build on Linux, Try results pending:
https://tbpl.mozilla.org/?tree=Try&rev=40d3b4e37a0e
Risk to taking this patch (and alternatives if risky): low since it mostly
reverts changes from the mentioned bugs
String changes made by this patch: none
Attachment #596226 - Flags: approval-mozilla-aurora?

Updated

6 years ago
Depends on: 726912
Comment on attachment 596226 [details]
backout for Aurora

[Triage Comment]
Approving these backouts for Aurora 12 given the content rendering regressions.
Attachment #596226 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
No longer depends on: 726912
https://hg.mozilla.org/releases/mozilla-aurora/rev/95b5009ae49f
https://hg.mozilla.org/releases/mozilla-aurora/rev/76e53f59457f
https://hg.mozilla.org/releases/mozilla-aurora/rev/00c7793f0770
https://hg.mozilla.org/releases/mozilla-aurora/rev/1444f8427e81
https://hg.mozilla.org/releases/mozilla-aurora/rev/58710da82f8f
https://hg.mozilla.org/releases/mozilla-aurora/rev/c5fce77e6f19
https://hg.mozilla.org/releases/mozilla-aurora/rev/19788bc83248
status-firefox12: --- → fixed
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.