Last Comment Bug 724468 - HTML5 Extension for Windows Media Player Plug-in 1.0 Causing Memory Leak
: HTML5 Extension for Windows Media Player Plug-in 1.0 Causing Memory Leak
Status: RESOLVED FIXED
[MemShrink:P2][3rd-party-bustage]
:
Product: Tech Evangelism
Classification: Other
Component: Add-ons (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Brian King [:kinger]
:
Mentors:
: 620334 (view as bug list)
Depends on:
Blocks: LeakyAddons
  Show dependency treegraph
 
Reported: 2012-02-05 23:02 PST by randall
Modified: 2012-05-04 16:38 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description randall 2012-02-05 23:02:33 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

Apparently the HTML5 extension updated itself to compatibility and re-enabled itself. I took no direct action regarding installing or enabling this plugin.


Actual results:

Memory leaked all over the place. Rolled up to 1.4G RAM usage. GC/CC/Minimize Memory Usage has no effect on it. Disabling the plugin immediately cut RAM usage back down to normal levels (about 600-700MB freed up instantly)


Expected results:

No memory leak.
Comment 1 Kevin Brosnan [:kbrosnan] 2012-02-05 23:12:22 PST
Please provide a link to the extension that caused this.
Comment 2 randall 2012-02-05 23:16:43 PST
Add-on page is reading last updated 27 Jan. 2012

Here are the links I could find:

http://www.interoperabilitybridges.com/html5-extension-for-wmp-plugin
http://kb.mozillazine.org/Windows_Media_Player


Other users reporting issue on Neowin over here:
http://www.neowin.net/forum/topic/971988-memory-leak-in-html5-extension-for-windows-media-player-firefox-add-on/
Comment 3 Nicholas Nethercote [:njn] 2012-03-27 14:13:58 PDT
Kev, do you know anyone at Microsoft who works on this?
Comment 4 Jorge Villalobos [:jorgev] 2012-04-04 15:10:20 PDT
I tried their contact form and another add-on developer at MS (probably unrelated to this extension). If there is no response in the next week or so, we need to poke Kev again about this.
Comment 5 Brian King [:kinger] 2012-04-05 15:00:11 PDT
I'll take this!

I suspect *some* of the leakage is the fact that an old version of the SDK is being used.
Comment 6 Jorge Villalobos [:jorgev] 2012-04-06 08:52:40 PDT
Oh, right, I forgot you had worked on this. Thanks, Brian!

And yes, version 1.6 of the SDK is the only one with no known leaks. Judging by the severity of the report, though, I suspect there's more to it.

I also received a very encouraging response from the Microsoft dev (Claudio Caldato).
Comment 7 Brian King [:kinger] 2012-04-10 09:45:51 PDT
Reporter (or anyone else),

Please check this version and let me know how it behaves WRT memory:

http://dl.dropbox.com/u/5940796/ms/wmpff-1.1b1.xpi

I have not run it through any tools yet, but in my casual testing there was no noticeable different with it installed or not.

This is using version 1.6 of the SDK.
Comment 8 Jorge Villalobos [:jorgev] 2012-04-10 11:27:14 PDT
Randall, Andrew: can you give this new version a try?
Comment 9 Andrew Williamson [:eviljeff] 2012-04-13 02:43:32 PDT
I don't see any increase in memory usage with this new version of the addon installed.  Though I couldn't actually get the add-on to demonstrably work on a test page if that makes a difference.
Comment 10 Brian King [:kinger] 2012-04-16 06:51:47 PDT
(In reply to Andrew Williamson [:eviljeff] from comment #9)
> I don't see any increase in memory usage with this new version of the addon
> installed.  Though I couldn't actually get the add-on to demonstrably work
> on a test page if that makes a difference.

What page(s) did you test with?
Comment 11 Andrew Williamson [:eviljeff] 2012-04-16 07:25:05 PDT
(In reply to Brian King (Briks) [:kinger] from comment #10)
> (In reply to Andrew Williamson [:eviljeff] from comment #9)
> > I don't see any increase in memory usage with this new version of the addon
> > installed.  Though I couldn't actually get the add-on to demonstrably work
> > on a test page if that makes a difference.
> 
> What page(s) did you test with?

http://www.vdat.com/techsupport/PRNwindowstest.asp - it appeared to load but pressing the play button in the toolbar didn't play anything iirc.
Comment 12 Jorge Villalobos [:jorgev] 2012-04-18 14:45:40 PDT
Brian: what's the status of this new version? Has it been released? Do we have confirmation that is works correctly?
Comment 13 Brian King [:kinger] 2012-04-20 06:59:57 PDT
(In reply to Andrew Williamson [:eviljeff] from comment #11)
> http://www.vdat.com/techsupport/PRNwindowstest.asp - it appeared to load but
> pressing the play button in the toolbar didn't play anything iirc.

What version of Windows? WFM on Win7.
Comment 14 Brian King [:kinger] 2012-04-20 07:02:09 PDT
(In reply to Jorge Villalobos [:jorgev] from comment #12)
> Brian: what's the status of this new version? Has it been released? Do we
> have confirmation that is works correctly?

This was released yesterday and is being updated via the update channel. The version is 1.1. It was built with version 1.6.1 of the SDK.

Direct link:
http://www.interoperabilitybridges.com/wmpff/wmpff.xpi

The install page needs updating to point to the correct XPI, but that should be fixed today.
Comment 15 Andrew Williamson [:eviljeff] 2012-04-20 07:15:22 PDT
(In reply to Brian King (Briks) [:kinger] from comment #13)
> (In reply to Andrew Williamson [:eviljeff] from comment #11)
> > http://www.vdat.com/techsupport/PRNwindowstest.asp - it appeared to load but
> > pressing the play button in the toolbar didn't play anything iirc.
> 
> What version of Windows? WFM on Win7.

Win7. Anything involving WMP and codecs could be broken on my computer due to any number of reasons though.
Comment 16 Brian King [:kinger] 2012-04-20 10:09:08 PDT
I see it now on one profile on Win Vista. But this is a plugin issue, separate to what the extension does, and unrelated to this bug. I'll make sure the MS folks are aware of it.
Comment 17 Danial Horton 2012-05-04 14:38:53 PDT
*** Bug 620334 has been marked as a duplicate of this bug. ***
Comment 18 Danial Horton 2012-05-04 14:49:37 PDT
i'll give it a run through one of my sessions, trouble with this plugin was that it grew considerably while idle and not so noticeably while actually browsing.
Comment 19 Danial Horton 2012-05-04 14:56:35 PDT
Also, http://www.vdat.com/techsupport/PRNwindowstest.asp is not a test that is affected by the h264 video plugin, the np-mswmp.dll is used whether the h264 wrapper is installed or not.
Comment 20 Danial Horton 2012-05-04 15:10:08 PDT
I cannot find any test pages which use this extension at all

the tests at quirksmode.org don't seem to work with it :3
Comment 21 Danial Horton 2012-05-04 16:38:03 PDT
ok, now works on quirksmode.org, previous broken-ness was probably a result of bug 751641

requires the msmpeg2adec and msmpeg2vdec files that come as part of Windows 7 DMO unfortunately, which i disable in favour of other codecs

Note You need to log in before you can comment on or make changes to this bug.