Closed Bug 724571 Opened 8 years ago Closed 8 years ago

Graphic issues and flickering screen on Adreno GPU devices

Categories

(Firefox for Android :: General, defect, P1)

ARM
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 733596
Tracking Status
firefox11 - affected
firefox12 - affected
firefox13 - affected
blocking-fennec1.0 --- +
fennec + ---

People

(Reporter: xti, Assigned: snorp)

References

Details

(Keywords: regression)

Attachments

(4 files)

Attached image screenshot
Firefox 13.0a1 (2012-02-06)
20120206031148
http://hg.mozilla.org/mozilla-central/rev/814d0b2dbaba
Device: HTC Desire Z
OS: Android 2.3.3

Steps to reproduce:
1. Open Fennec
2. Go to www.mozilla.com
3. Tap on URL Bar for Awesomebar
4. Tap on device back button

Expected result:
The switch between Awesomebar and opened page at step 2 is made smoothly. No graphic issues or flickering screen should occur after step 4.

Actual result:
After step 4, graphic issues can be noticed for 1/2-1 sec. Also display is flickering during this transition. Please see the following video: http://youtu.be/itIUvTAMKdw
Adreno 205, gralloc free device.

I also see this on the Nexus One, Adreno 200.
Summary: Graphic issues and flickering screen when going back from Awesombar to an existing opened page → Graphic issues and flickering screen on Adreno GPU devices
tracking-fennec: --- → ?
snorp, could this be more gralloc fail
Assignee: nobody → snorp
tracking-fennec: ? → +
Priority: -- → P1
The flickering screen can be noticed on other devices like LG Optimus 2X (ULP GeForce) or Samsung Galaxy S2 (Mali-400MP). 

I'm not sure if there are any graphic issues or if the page is auto scrolling up and down for a couple of times (see attached screenshot).
The above screenshot looks like you simply pulled the page down with your finger. I'm more concerned about the first screenshot which I have seen on the Nexus One as well.
I've seen the first screenshot as well, also a lot in combination with bug 721383.
Could you perhaps test the testcase in that bug and report in that bug?
(In reply to Aaron Train [:aaronmt] from comment #4)
> The above screenshot looks like you simply pulled the page down with your
> finger. I'm more concerned about the first screenshot which I have seen on
> the Nexus One as well.

Yes, it looks like that. Here is a video while I was trying to reproduce this on Galaxy S2: http://youtu.be/vA8AjfzwvZ0

If a screenshot is taken, the result can be noticed in the 2nd screenshot attached.
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #5)
> I've seen the first screenshot as well, also a lot in combination with bug
> 721383.
> Could you perhaps test the testcase in that bug and report in that bug?

I attached a new screenshot using the TC from bug 721383. I see a big yellow square and a little rectangle under it after the vkb is closed, but I cannot catch all of them in the screenshot, just small yellow areas.
Screenshot of the HTC Nexus One (Android 2.3.4) taken during page load
Duplicate of this bug: 726579
In the above range I see bug 717283 which stands out.
Already tracked for Fennec, no need to track for all branches.
(In reply to Aaron Train [:aaronmt] from comment #12)
> In the above range I see bug 717283 which stands out.

It could be some of the initialisation changes that went in with this could have caused this. Not sure if it's worth spending too much time on, as all this code will disappear soon, but if it's easily fixable I'll write a patch.
Received an Xperia Play this afternoon, (Adreno 205) and still see this; at least on Nightly. I have not tested Maple.
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → +
This GPU is rather common, we need this sorted out for release.
Tested Maple (tinderbox from 03/06), I still see this very frequently through normal operations of the browser.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 733596
You need to log in before you can comment on or make changes to this bug.