Address book corrupted with extra information at the end

RESOLVED DUPLICATE of bug 366457

Status

--
critical
RESOLVED DUPLICATE of bug 366457
7 years ago
4 years ago

People

(Reporter: VanillaMozilla, Unassigned)

Tracking

({dataloss})

x86
All
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
The address book was found to be blank.  Inspection of file dates showed that on startup, a new 'abook.mab' file was created, and the pre-existing 'abook.mab.bak' file was corrupt.

The problem may have been caused by a power outage earlier that day, although it is not certain that TB was running at the time.  There appears to be no TB crash log that would verify the event.

I noticed that the backup file seemed to be divided into records.  The last apparently intact record (i.e., with readable text) was followed by records with no readable text.  The address book was successfully restored by removing the final, unreadable records with a text editor and renaming the file.

The profile was stored on an NTFS volume and mounted with ntfs-3g under Ubuntu 11.10.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.24) Gecko/20111108 Thunderbird/3.1.16
Vanilla - did you manage to recover your data ?
(Reporter)

Comment 2

7 years ago
Yes.  Ordinarily one doesn't edit such a file with a text editor, but it worked.  Where to cut was mostly guesswork.
(Reporter)

Comment 3

7 years ago
It happened again.  I'll be happy to do some troubleshooting if anyone has a clue.
(Reporter)

Comment 4

7 years ago
Well, after thinking about it, I need to add more information, although it's likely irrelevant.  This profile runs on a hetergeneous network, not just Linux.

Although the profile is usually mounted on a Linux machine, it is also shared with a Windows 7 netbook.  Sometimes there is an attempt to open two program instances simultaneously, but usually (always?) the lock file prevents this.  As far as I can tell, there was no simultaneous access in this case.
(Reporter)

Comment 5

7 years ago
Probably a duplicate of 366457.

I'm also marking this for All OS's because the profile is shared between Linux and Windows XP, and it's not certain in which one the problem occurred.
OS: Linux → All
(Reporter)

Comment 6

7 years ago
Geez, the DUPLICATE didn't stick.  Trying again.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 366457
You need to log in before you can comment on or make changes to this bug.