Closed Bug 724795 Opened 8 years ago Closed 8 years ago

Refresh of the Add-On Manager is required in order to see uninstallation of a search engine

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 13
Tracking Status
firefox11 --- affected
firefox12 --- affected
firefox13 --- verified
fennec + ---

People

(Reporter: nhirata, Assigned: mbrubeck)

References

Details

(Whiteboard: [has patch])

Attachments

(1 file)

1. goto http://mycroft.mozdev.org/bing-search-search-plugins.html
2. click on the top link
3. go to about:addons
4. click on cooliris search
5. click uninstall

Expected: refresh to the about:addons
Actual: nothing seems to happen; refresh will cause the addons page not to show the search engine

Note:
ftp://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-aurora-android/1328550010/
android 2.3
Galaxy S 2

minor bug

http://www.youtube.com/watch?v=GiDmrNFTzPk&feature=youtube_gdata_player
Yep, can reproduce (02/07 Nightly).
tracking-fennec: --- → ?
OS: Mac OS X → Android
Hardware: x86 → ARM
Summary: Refresh required in order to see Search engine uninstalled → Refresh of the Add-On Manager is required in order to see uninstallation of a search engine
Assignee: nobody → mbrubeck
tracking-fennec: ? → +
Attached patch patchSplinter Review
Attachment #595900 - Flags: review?(mark.finkle)
Status: NEW → ASSIGNED
Whiteboard: [has patch]
Version: Firefox 12 → Trunk
Attachment #595900 - Flags: review?(mark.finkle) → review+
Comment on attachment 595900 [details] [diff] [review]
patch

[Approval Request Comment]
Low-risk mobile-only fix for some confusing UX.
Attachment #595900 - Flags: approval-mozilla-beta?
Attachment #595900 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/e6b09b85a178
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 595900 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Attachment #595900 - Flags: approval-mozilla-beta?
Attachment #595900 - Flags: approval-mozilla-beta+
Attachment #595900 - Flags: approval-mozilla-aurora?
Attachment #595900 - Flags: approval-mozilla-aurora+
Depends on: 728861
Comment on attachment 595900 [details] [diff] [review]
patch

Clearing approval for Aurora 12 and Beta 11 because we are not currently planning a Native Fennec release of these versions.  If this changes in the future, we will likely do a mass uplift of all native fennec changes.  For now, let's get these bugs off the channel triage radar.

[Filter on the string "mbrubeck-bugspam" if you want to delete all of these emails at once.]
Attachment #595900 - Flags: approval-mozilla-beta+
Attachment #595900 - Flags: approval-mozilla-aurora+
Nightly Fennec 13.0a1 (2012-02-29)
Device: HTC Desire Z
OS: Android 2.3.3

Uninstall is performed and the screen is refreshed to the about:addons
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.