Last Comment Bug 724808 - First run import wizard doesn't show up on Firefox 12 and 13
: First run import wizard doesn't show up on Firefox 12 and 13
Status: VERIFIED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: 12 Branch
: x86 All
: -- normal (vote)
: Firefox 13
Assigned To: Mano (::mano, needinfo? for any questions; not reading general bugmail)
:
Mentors:
Depends on:
Blocks: 715099 739056
  Show dependency treegraph
 
Reported: 2012-02-07 01:31 PST by Paul Silaghi, QA [:pauly]
Modified: 2012-03-25 06:02 PDT (History)
7 users (show)
djcater+bugzilla: in‑testsuite?
djcater+bugzilla: in‑litmus?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
aham (831 bytes, patch)
2012-02-12 05:39 PST, Mano (::mano, needinfo? for any questions; not reading general bugmail)
mak77: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Paul Silaghi, QA [:pauly] 2012-02-07 01:31:06 PST
Steps to reproduce:
1. Install Firefox 12 (Aurora) and Firefox 13 (Nightly)
2. Remove profiles folders:
On Windows - %appdata%\Mozilla
On Mac - Library\Application Support\Firefox
On Linux - /home/user/.mozilla
3. Start Aurora or Nighly

Expected results:
First run import wizard should show up

Actual results:
No import wizard displayed

Note:
Import wizard shows up on FF 11b1
Comment 1 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-02-07 15:11:31 PST
I confirm that the First Run migration wizard displayed on 11.0a2 so it seems that it is a recent change the made Aurora/Nightly not display it.

Paul, can you please track down a regression range?
Comment 2 Paul Silaghi, QA [:pauly] 2012-02-08 07:37:53 PST
Last good nightly: 2012-01-16
First bad nightly: 2012-01-17
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2012-01-16&enddate=2012-01-17

I suspect bug 715099, but I'm not really sure.
Comment 3 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-02-08 08:03:47 PST
Thanks Paul. Yeah, bug 715099 seems like it could be a likely culprit.
Comment 4 Marco Bonardo [::mak] 2012-02-08 08:19:29 PST
tentatively assigning to Mano, though if anyone else has a fix feel free to steal.
Comment 5 Makoto Kato [:m_kato] 2012-02-08 17:50:02 PST
maybe, let pathMatches = value.match(/^"?(.+?\.exe)"?/); is invalid.  I don't think that this can extract program filename.
Comment 6 Matthew N. [:MattN] (behind on reviews) 2012-02-08 18:00:09 PST
Paul/Anthony, were there any errors in the error console after the first-run startup?
Comment 7 Paul Silaghi, QA [:pauly] 2012-02-08 23:34:07 PST
There are no errors, only some warnings.
Comment 8 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-02-11 00:52:32 PST
Looking now.
Comment 9 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-02-12 05:39:32 PST
Created attachment 596463 [details] [diff] [review]
aham

After trying hard to reproduce it with my debug build... I figure what it's missing. I haven't tested this though (that is, I haven't built the installer).
Comment 10 Marco Bonardo [::mak] 2012-02-13 12:21:15 PST
Comment on attachment 596463 [details] [diff] [review]
aham

Review of attachment 596463 [details] [diff] [review]:
-----------------------------------------------------------------

made an installer locally without and with the patch, tried starting the browser without a mozilla userdata folder and verified it opens the dialog after the patch, not before.
Comment 11 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-02-21 01:11:06 PST
Comment on attachment 596463 [details] [diff] [review]
aham

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Comment 12 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-02-21 01:11:31 PST
Comment on attachment 596463 [details] [diff] [review]
aham

oops!
Comment 13 Marco Bonardo [::mak] 2012-02-28 03:25:33 PST
can this land please?
Comment 15 Ed Morley [:emorley] 2012-03-04 05:06:22 PST
https://hg.mozilla.org/mozilla-central/rev/f0cc27e3731c
Comment 16 Paul Silaghi, QA [:pauly] 2012-03-04 23:31:34 PST
First run import wizard is now displayed on FF 13 but without the Home Page Selection screen as in FF 11.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120304 Firefox/13.0a1
Comment 17 Marco Bonardo [::mak] 2012-03-06 11:19:29 PST
Comment on attachment 596463 [details] [diff] [review]
aham

[Approval Request Comment]
Regression caused by (bug #): bug 715099
User impact if declined: no first run migration
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low, adding a missing file to the package
String changes made by this patch: none
Comment 18 Marco Bonardo [::mak] 2012-03-06 11:21:02 PST
(In reply to Paul Silaghi [QA] from comment #16)
> First run import wizard is now displayed on FF 13 but without the Home Page
> Selection screen as in FF 11.

please file a bug in Firefox/Migration about this so we can evaluate if it's expected or not, specify platform and the source browser.
Comment 19 Alex Keybl [:akeybl] 2012-03-06 13:42:55 PST
Comment on attachment 596463 [details] [diff] [review]
aham

[Triage Comment]
Low risk - approved for Aurora 12.
Comment 21 Paul Silaghi, QA [:pauly] 2012-03-13 03:20:40 PDT
(In reply to Marco Bonardo [:mak] from comment #18)
> please file a bug in Firefox/Migration about this so we can evaluate if it's
> expected or not, specify platform and the source browser.

New bug 735183 filed. Marking this bug as verified fixed.

Note You need to log in before you can comment on or make changes to this bug.