No Home Page Selection screen on first run import wizard

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
8 months ago

People

(Reporter: pauly, Unassigned)

Tracking

12 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Steps to reproduce:
1. Install Firefox 12 (Aurora) and Firefox 13 (Nightly)
2. Remove profiles folders:
On Windows - %appdata%\Mozilla
On Mac - Library\Application Support\Firefox
On Linux - /home/user/.mozilla
3. Start Aurora or Nighly
4. Select any browser from the list and then click "Next"

Expected results:
Home page selection screen should show up

Actual results:
No home page selection screen displayed
(Reporter)

Comment 1

7 years ago
Created attachment 605327 [details]
home page selection screen on FF11
Marco, the hack you're using in your tree may be useful for everyone, apparently.  :) And now that the default homepage is a built-in page, we can move this out of the branding package.
yeah I agree we should just remove this stuff from branding.
I think we should be able to get rid of a bunch of "official branding only" logic related to the home page, right?
(Reporter)

Updated

7 years ago
Blocks: 710259
(Reporter)

Updated

7 years ago
Blocks: 354967
(Reporter)

Updated

7 years ago
Blocks: 454008
This is not a regression, and it has nothing to do with the new migrators.
No longer blocks: 354967, 454008, 710259
(Reporter)

Comment 6

4 years ago
Is this Home Page Selection screen still the case?
Flags: needinfo?(mak77)
the bug as-is may be wfm, it depends on the source browser, it may not support home page migration. Should be verified.

Regarding branding discussion both migrators and about:home are firefox related and in browser, I guess we could remove the string from branding, though I'm not sure whether other unbranded releases are using about:home, since it is not yet brand-friendly (bug 890124, bug 855461, bug 632264). So I don't think we can really remove anything from branding.
Flags: needinfo?(mak77)
(Reporter)

Comment 8

4 years ago
(In reply to Marco Bonardo [:mak] from comment #7)
> the bug as-is may be wfm, it depends on the source browser, it may not
> support home page migration. Should be verified.
I'm talking about the initial screen in the migration wizard that was available once (see the screenshot). It is still not displayed for any of the browsers import: chrome, safari & IE.
The homepage is also not ported.
Paul, that wizard page is still in place in official-branded builds. Just test with the last official release.

To be honest though, I think we should remove the homepage migration altogether. about:home has become too-rich-to-ignore.
(Reporter)

Comment 10

4 years ago
(In reply to Mano (needinfo? for any questions; not reading general bugmail) from comment #9)
> Paul, that wizard page is still in place in official-branded builds. Just
> test with the last official release.
Sorry, I missed that.

> To be honest though, I think we should remove the homepage migration
> altogether. about:home has become too-rich-to-ignore.
Agreed

Updated

3 years ago
See Also: → bug 1210401
Bug 1434167 made this invalid
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Depends on: 1434167
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.