Closed Bug 725007 Opened 13 years ago Closed 10 years ago

dismissing the Autocomplete formfill after deleting any typed letters with Swype will leave a character behind

Categories

(Firefox for Android Graveyard :: Keyboards and IME, defect, P3)

12 Branch
ARM
Android
defect

Tracking

(blocking-fennec1.0 -)

RESOLVED WORKSFORME
Tracking Status
blocking-fennec1.0 --- -

People

(Reporter: nhirata, Unassigned)

References

Details

1. switch to Swype (long tap on a field and switch the ime to swype)
2. go to http://people.mozilla.com/~nhirata/html_tp/formsninput.html
3. go to field : Username: and type some stuff to populate the form fill and hit submit
4. click in the field, type in the first letter of something you typed in step 3
5. hit the delete key to delete all characters in the field
6. hit outside of the autocomplete form fill and the keyboard to dismiss both

Expected: nothing in Username field
Actual: the first letter that was typed in step 4.

Note:
1. does not happen with Swiftkey nor default keyboard
2. Aurora, Nightly 02/07/2012, Samsung galaxy S II
Assignee: nobody → cpeterson
I can reproduce this on the Galaxy SII, using latest Nightly Native Fennec.
I don't even need step 3 to reproduce this issue.
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → -
Triage, this bug needs a priority.
blocking-fennec1.0: - → ---
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → -
Priority: -- → P3
Component: General → IME
This bug needs to be retested after autocomplete is re-enabled by bug 764193.
Depends on: 764193
Form autocomplete has been re-enabled, but I have blocklisted Swype until this and some other Swype IME bugs have been fixed.
I believe the fix for bug 780191 will also fix this Swype bug.
Depends on: 780191
I verified that this bug is fixed in my local build, but I am leaving this bug open because Swype form autocomplete is still blocklisted until Swype bug 755909 is fixed.
Depends on: 755909
Assignee: cpeterson → nobody
Jim is this still "fixed but not fixed"?
Flags: needinfo?(nchen)
I could not reproduce it with Swype on my Nexus 4.
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: needinfo?(nchen)
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.