Closed Bug 725294 Opened 8 years ago Closed 8 years ago

mozconfig comparison doesn't work for mobile

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(firefox-esr10 fixed)

RESOLVED FIXED
Tracking Status
firefox-esr10 --- fixed

People

(Reporter: bhearsum, Assigned: aki)

References

Details

(Whiteboard: [automation][releases])

Attachments

(10 files, 2 obsolete files)

7.04 KB, patch
lsblakk
: review+
Details | Diff | Splinter Review
14.45 KB, patch
catlee
: review+
Details | Diff | Splinter Review
4.72 KB, patch
catlee
: review+
Details | Diff | Splinter Review
8.39 KB, patch
catlee
: review+
Details | Diff | Splinter Review
8.26 KB, patch
catlee
: review+
Details | Diff | Splinter Review
4.67 KB, patch
rail
: review+
Details | Diff | Splinter Review
3.34 KB, patch
lsblakk
: review+
Details | Diff | Splinter Review
5.76 KB, patch
lsblakk
: review+
Details | Diff | Splinter Review
4.85 KB, patch
lsblakk
: review+
Details | Diff | Splinter Review
4.48 KB, patch
lsblakk
: review+
Details | Diff | Splinter Review
This may have broken when we switched to in-tree mozconfigs, or it may have never worked. Here's the errors that release_sanity.py throws:
2012-02-08 05:48:01,079 : INFO : Comparing fennec mozconfigs to nightly mozconfigs...
2012-02-08 05:48:08,950 : ERROR : MISSING: http://hg.mozilla.org/releases/mozilla-release/raw-file/18ce5e304e97/mobile/config/mozconfigs/macosx-desktop/release - ERROR: Not Found
2012-02-08 05:48:16,047 : INFO : Missing mozconfigs to compare for macosx-mobile
2012-02-08 05:48:23,919 : ERROR : MISSING: http://hg.mozilla.org/releases/mozilla-release/raw-file/18ce5e304e97/mobile/config/mozconfigs/win32-desktop/release - ERROR: Not Found
2012-02-08 05:48:31,169 : INFO : Missing mozconfigs to compare for win32-mobile
2012-02-08 05:48:38,205 : ERROR : MISSING: http://hg.mozilla.org/releases/mozilla-release/raw-file/18ce5e304e97/mobile/config/mozconfigs/android/release - ERROR: Not Found
2012-02-08 05:48:45,731 : INFO : Missing mozconfigs to compare for linux-android
2012-02-08 05:48:52,838 : ERROR : MISSING: http://hg.mozilla.org/releases/mozilla-release/raw-file/18ce5e304e97/mobile/config/mozconfigs/linux-desktop/release - ERROR: Not Found
2012-02-08 05:48:59,859 : INFO : Missing mozconfigs to compare for linux-mobile
It did work before we switched to in-tree mozconfigs
Assignee: nobody → lsblakk
I am thinking that the output error might now be the one in bug 729516 since we don't have Desktop mobile repacks.
Assignee: lsblakk → aki
2012-02-22 07:05:38,577 : INFO : Comparing fennec mozconfigs to nightly mozconfigs...
2012-02-22 07:05:45,713 : ERROR : MISSING: http://hg.mozilla.org/releases/mozilla-beta/raw-file/52cf2b0c8439/mobile/android/config/mozconfigs/android/release - ERROR: Not Found
2012-02-22 07:05:52,001 : INFO : Missing mozconfigs to compare for android
2012-02-22 07:05:58,219 : ERROR : MISSING: http://hg.mozilla.org/releases/mozilla-beta/raw-file/52cf2b0c8439/mobile/xul/config/mozconfigs/android/release - ERROR: Not Found
2012-02-22 07:06:04,163 : INFO : Missing mozconfigs to compare for android-xul
Duplicate of this bug: 729516
Tested against my user repo mozilla-beta and mozilla-esr10; I'm going to rely on the beta->release merge to get m-r fixed up.
Attachment #602218 - Flags: review?(lsblakk)
* deleted mobile desktop mozconfigs
* added release and l10n mozconfigs for android, android-xul

This will merge into mozilla-release.
Coming: nightly patches for mozilla-{central,aurora}; nightly+release patch for mozilla-esr10.

I'll also have to patch mozharness to point to the new l10n mozconfig locations.
Attachment #602222 - Flags: review?(catlee)
* deleted mobile desktop mozconfigs
* added release mozconfigs for linux-android
* fixed branding for bug 730918
Attachment #602223 - Flags: review?(catlee)
Noted a couple things:

* I'm not touching the debug mozconfigs. Not sure this is a big deal.
* I added l10n-{nightly,release} mozconfigs for mozilla-beta android-xul, when we're not doing android-xul single locale at all.  Not sure this is a big deal either, but I can remove em easily.
Attachment #602226 - Flags: review?(catlee)
Attachment #602227 - Flags: review?(catlee)
Attachment #602229 - Flags: review?(rail) → review+
Comment on attachment 602222 [details] [diff] [review]
mozilla-beta mobile mozconfigs

Review of attachment 602222 [details] [diff] [review]:
-----------------------------------------------------------------

looks good, assuming you want the XUL builds to use version 13 of the SDK, and native to use version 14.
Attachment #602222 - Flags: review?(catlee) → review+
Attachment #602223 - Flags: review?(catlee) → review+
Comment on attachment 602226 [details] [diff] [review]
mobile central mozconfigs

Review of attachment 602226 [details] [diff] [review]:
-----------------------------------------------------------------

deleting files makes me happy
Attachment #602226 - Flags: review?(catlee) → review+
Attachment #602227 - Flags: review?(catlee) → review+
looks like this fixes the missing l10n and release mozconfigs for mobile from bug 558180, right?
Comment on attachment 602222 [details] [diff] [review]
mozilla-beta mobile mozconfigs

[Approval Request Comment]
This is basically a cleanup of the in-tree mozconfigs and moving mozconfigs out of buildbot-configs into the tree.

Risk to taking this patch (and alternatives if risky):
None.

String changes made by this patch:
None.
Attachment #602222 - Flags: approval-mozilla-beta?
Comment on attachment 602223 [details] [diff] [review]
mobile esr10 mozconfigs

[Approval Request Comment]
This is basically a cleanup of the in-tree mozconfigs and moving mozconfigs out of buildbot-configs into the tree.

Risk to taking this patch (and alternatives if risky):
None.

String changes made by this patch:
None.
Attachment #602223 - Flags: approval-mozilla-esr10?
Comment on attachment 602227 [details] [diff] [review]
mobile aurora mozconfigs

[Approval Request Comment]
This is basically a cleanup of the in-tree mozconfigs and moving mozconfigs out of buildbot-configs into the tree.

Risk to taking this patch (and alternatives if risky):
None.

String changes made by this patch:
None.
Attachment #602227 - Flags: approval-mozilla-aurora?
(In reply to Chris AtLee [:catlee] from comment #13)
> looks like this fixes the missing l10n and release mozconfigs for mobile
> from bug 558180, right?

Yes.
Doesn't deal with m-r, but the merge will fix that.
Comment on attachment 602226 [details] [diff] [review]
mobile central mozconfigs

Pushed to inbound (as ffxbld):
http://hg.mozilla.org/integration/mozilla-inbound/rev/e29cdf5839e3
Attachment #602226 - Flags: checked-in+
Attachment #602218 - Flags: review?(lsblakk) → review+
Comment on attachment 602218 [details] [diff] [review]
mobile whitelist needed to get mozconfig errors to 0

http://hg.mozilla.org/build/tools/rev/bc68063e9bdb
Attachment #602218 - Flags: checked-in+
Comment on attachment 602223 [details] [diff] [review]
mobile esr10 mozconfigs

Go ahead and land this, I can send the go again with a new changeset
Attachment #602223 - Flags: approval-mozilla-esr10? → approval-mozilla-esr10+
https://hg.mozilla.org/mozilla-central/rev/e29cdf5839e3
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Reopening until we get the aurora+beta mozconfigs approved and landed with the mozharness patch.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(For future inbound landings where the bug needs to stay open post merge to mozilla-central, you can use [leave open] in the whiteboard, to save having to reopen :-))
Attachment #602222 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #602227 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 602222 [details] [diff] [review]
mozilla-beta mobile mozconfigs

http://hg.mozilla.org/releases/mozilla-beta/rev/824244c92d20

Sweet, 11.0b6's release_sanity should be good.
Attachment #602222 - Flags: checked-in+
Comment on attachment 602229 [details] [diff] [review]
point mozharness single locale mozconfigs at in-tree mozconfigs

http://hg.mozilla.org/build/mozharness/rev/2989bd62015a
Attachment #602229 - Flags: checked-in+
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Crap, the aurora->beta merge wiped the release mozconfigs.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I think we just need to update the whitelists, actually. I found 3 changes total (pasted from build notes):
* All desktop platforms
** --enable-signmar in nightly but not in release
*** We don't need to build signmar for releases, needs to be added to whitelist '''FIXME'''
** --enable-js-diagnostics in nightly but not in release
*** ASSUMING that we don't want to build betas with this '''FIXME'''
* Linux & Linux64
** --enable-warnings-as-errors in nightly but not in release
*** ASSUMING that we don't want to build betas with this '''FIXME'''


I'm certain we don't need signmar, and I assume we don't need the others but we should verify that with someone who knows for sure.
Oh, I see. We're missing some mobile release configs altogether.
the release mozconfigs need to be added to mozilla-central and mozilla-aurora as well so they get uplifted the next time around.
I'm leaving the beta branding in here since we don't start using the release mozconfigs until Beta builds anyway - so this way we don't really have to worry about branding or updates every time we uplift, only from beta-> release
Attachment #605896 - Flags: review?(aki)
same as previous attachment, I'm leaving the beta branding in here since we don't start using the release mozconfigs until Beta builds anyway - so this way we don't really have to worry about branding or updates every time we uplift, only from beta-> release
Attachment #605897 - Flags: review?(aki)
Comment on attachment 605897 [details] [diff] [review]
mozilla aurora release mozconfigs (for beta)

These guys are missing l10n-release.
I think I need to take a look here.
[Approval Request Comment]
Regression caused by (bug #): 
aurora->beta merge.

User impact if declined: 
No single locale android beta builds when locales are signed off for Fennec.

Testing completed (on m-c, etc.): 
None.

Risk to taking this patch (and alternatives if risky):
Low.  If we start doing l10n on mozilla-beta, not taking this will break things.

String changes made by this patch:
None

post-merge.

This:
* changes the update channel to ${MOZ_UPDATE_CHANNEL} for less merge-time editing
* fixes l10n-nightly's branding
* adds mobile/android l10n-release

We'll have to update the merge docs.
Attachment #605940 - Flags: review?(lsblakk)
Attachment #605940 - Flags: approval-mozilla-beta?
I'm not sure if ${MOZ_UPDATE_CHANNEL} is set for single locale repacks.
It probably isn't, but that should be easy to set for mozharness.
Comment on attachment 605940 [details] [diff] [review]
mozilla-beta mobile mozconfigs

[Triage comment]
looks good, please go ahead and land so respin on 12.0b1 can pick these up.
Attachment #605940 - Flags: review?(lsblakk)
Attachment #605940 - Flags: review+
Attachment #605940 - Flags: approval-mozilla-beta?
Attachment #605940 - Flags: approval-mozilla-beta+
This patch:

* fixes the android l10n-nightly l10n-base and branding.
* switches the update channel to ${MOZ_UPDATE_CHANNEL} for less editing at merge time
* adds the release mozconfigs like attachment 605897 [details] [diff] [review], but with ${MOZ_UPDATE_CHANNEL}
* adds l10n-release for mobile/android with beta branding.

We'll need to update the merge docs for this as well.

[Approval Request Comment]
Regression caused by (bug #): 
central -> aurora merge.

User impact if declined: 


Testing completed (on m-c, etc.): 
None.

Risk to taking this patch (and alternatives if risky):
Low.  

String changes made by this patch:
None
Attachment #605897 - Attachment is obsolete: true
Attachment #605897 - Flags: review?(aki)
Attachment #605953 - Flags: review?(lsblakk)
Attachment #605953 - Flags: approval-mozilla-aurora?
Oh, User impact if declined: breakage of android single locale repacks until l10n-base is fixed in l10n-nightly.
This patch:
* sets the l10n-nightly update channel to ${MOZ_UPDATE_CHANNEL}
* adds the release mozconfigs with beta branding as does attachment 605896 [details] [diff] [review], but with ${MOZ_UPDATE_CHANNEL}
* adds the l10n-release mobile/android mozconfig with beta branding

Are the merge docs still the same ones on github?
Attachment #605896 - Attachment is obsolete: true
Attachment #605896 - Flags: review?(aki)
Attachment #605981 - Flags: review?(lsblakk)
[15:26]	<aki|buildduty>	i think in http://mozilla.github.com/process-releases/draft/development_specifics/ i want to add a sed -i -e 's,branding/nightly,branding/aurora,' mobile/*/config/mozconfigs/android/*
[15:27]	<aki|buildduty>	also sed -i -e 's,with-l10n-base=.*,with-l10n-base=..,' mobile/android/config/mozconfigs/android/l10n-nightly
Updated https://wiki.mozilla.org/Release_Management/Merge_Documentation , which doesn't seem to have mozilla-beta -> mozilla-release info.  Should help keep the l10n-nightly's up to date though.
Comment on attachment 605953 [details] [diff] [review]
mozilla-aurora release mozconfigs

[Triage comment]
awesome.  glad we won't clobber on merge anymore.
Attachment #605953 - Flags: review?(lsblakk)
Attachment #605953 - Flags: review+
Attachment #605953 - Flags: approval-mozilla-aurora?
Attachment #605953 - Flags: approval-mozilla-aurora+
Attachment #605947 - Flags: review?(lsblakk) → review+
Attachment #605981 - Flags: review?(lsblakk) → review+
Comment on attachment 605947 [details] [diff] [review]
mozharness mobile_l10n MOZ_UPDATE_CHANNEL

http://hg.mozilla.org/build/mozharness/rev/b02ac449511e
Attachment #605947 - Flags: checked-in+
Comment on attachment 605981 [details] [diff] [review]
mozilla-central mobile mozconfigs

https://hg.mozilla.org/integration/mozilla-inbound/rev/011bce915a20

This bug should be resolvable when this migrates to m-c.
Attachment #605981 - Flags: checked-in+
https://hg.mozilla.org/mozilla-central/rev/011bce915a20
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.