Closed Bug 725300 Opened 8 years ago Closed 8 years ago

mozconfig comparison output from release sanity is hard to read

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bhearsum, Assigned: aki)

References

Details

(Whiteboard: [automation][releases])

Attachments

(1 file)

This is some sample output from release_sanity.py:
ERROR : not in release mozconfig's whitelist (releases/mozilla-release/macosx64/nightly) : ac_add_options --enable-official-branding
ERROR : not in nightly mozconfig's whitelist (releases/mozilla-release/macosx64/release) : ac_add_options --with-macbundlename-prefix=Firefox
ERROR : not in release mozconfig's whitelist (releases/mozilla-release/macosx64/nightly) : mk_add_options MOZ_MAKE_FLAGS="-j4"

What this means is that "ac_add_options --enable-official-branding" and "mk_add_options MOZ_MAKE_FLAGS="-j4"" were both found in the release mozconfig but not the nightly, and weren't whitelist; and also that "ac_add_options --with-macbundlename-prefix=Firefox" was found in the nightly one but not the release one and also wasn't whitelisted.

I think it would be clearer for it to make that more explicit. For example:
ERROR : found in path/to/release/mozconfig but not in path/to/nightly/mozconfig: ac_add_options --enable-official-branding
ERROR : found in path/to/nightly/mozconfig but not in path/to/release/mozconfig: ac_add_options --with-macbundlename-prefix=Firefox
ERROR : found in path/to/release/mozconfig but not in path/to/nightly/mozconfig: mk_add_options MOZ_MAKE_FLAGS="-j4"

I'm not sure it needs to talk about the whitelists at all, we may be OK assuming that the consumer knows about the whitelists.
Assignee: nobody → lsblakk
Is it possible if we could whitelist these ERROR lines if they are OK to happen? or is there a different bug for this? or say WARNING? ERRORs got me scared that something was broken.
Assignee: lsblakk → aki
Attached patch as requestedSplinter Review
Sample output:

2012-03-01 13:56:08,866 : INFO : Comparing firefox mozconfigs to nightly mozconfigs...2012-03-01 13:56:39,409 : ERROR : found in browser/config/mozconfigs/macosx-universal/release but not in browser/config/mozconfigs/macosx-universal/nightly: ac_add_options --enable-official-branding
2012-03-01 13:56:39,410 : ERROR : found in browser/config/mozconfigs/macosx-universal/nightly but not in browser/config/mozconfigs/macosx-universal/release: ac_add_options --with-macbundlename-prefix=Firefox2012-03-01 13:57:09,876 : ERROR : found in browser/config/mozconfigs/win32/release but not in browser/config/mozconfigs/win32/nightly: mk_add_options MOZ_PGO=12012-03-01 13:57:09,876 : ERROR : found in browser/config/mozconfigs/win32/release but not in browser/config/mozconfigs/win32/nightly: ac_add_options --enable-official-branding2012-03-01 13:57:41,348 : ERROR : found in browser/config/mozconfigs/linux64/release but not in browser/config/mozconfigs/linux64/nightly: ac_add_options --enable-official-branding 2012-03-01 13:57:41,348 : ERROR : found in browser/config/mozconfigs/linux64/release but not in browser/config/mozconfigs/linux64/nightly: mk_add_options MOZ_PGO=12012-03-01 13:57:41,348 : ERROR : found in browser/config/mozconfigs/linux64/release but not in browser/config/mozconfigs/linux64/nightly: mk_add_options PROFILE_GEN_SCRIPT='$(PYTHON) @MOZ_OBJDIR@/_profile/pgo/profileserver.py 10'2012-03-01 13:58:10,953 : ERROR : found in browser/config/mozconfigs/linux32/release but not in browser/config/mozconfigs/linux32/nightly: ac_add_options --enable-official-branding2012-03-01 13:58:10,953 : ERROR : found in browser/config/mozconfigs/linux32/release but not in browser/config/mozconfigs/linux32/nightly: mk_add_options MOZ_PGO=12012-03-01 13:58:10,953 : ERROR : found in browser/config/mozconfigs/linux32/release but not in browser/config/mozconfigs/linux32/nightly: mk_add_options PROFILE_GEN_SCRIPT='$(PYTHON) @MOZ_OBJDIR@/_profile/pgo/profileserver.py 10'
Attachment #602097 - Flags: review?(bhearsum)
er, it had line breaks until copy/paste borked it.
Also, this completely obsoletes bug 725302.  Duping that one.
Duplicate of this bug: 725302
2012-03-01 13:56:08,866 : INFO : Comparing firefox mozconfigs to nightly mozconfigs...
2012-03-01 13:56:39,409 : ERROR : found in browser/config/mozconfigs/macosx-universal/release but not in browser/config/mozconfigs/macosx-universal/nightly: ac_add_options --enable-official-branding
2012-03-01 13:56:39,410 : ERROR : found in browser/config/mozconfigs/macosx-universal/nightly but not in browser/config/mozconfigs/macosx-universal/release: ac_add_options --with-macbundlename-prefix=Firefox
2012-03-01 13:57:09,876 : ERROR : found in browser/config/mozconfigs/win32/release but not in browser/config/mozconfigs/win32/nightly: mk_add_options MOZ_PGO=1
2012-03-01 13:57:09,876 : ERROR : found in browser/config/mozconfigs/win32/release but not in browser/config/mozconfigs/win32/nightly: ac_add_options --enable-official-branding
Attachment #602097 - Flags: review?(bhearsum) → review+
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.