Closed Bug 725302 Opened 8 years ago Closed 8 years ago

release_sanity.py's path to mozconfigs are wrong

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 725300

People

(Reporter: bhearsum, Assigned: aki)

References

Details

(Whiteboard: [automation][releases])

Attachments

(1 obsolete file)

It talks about mozconfigs such as:
2012-02-08 05:31:05,487 : ERROR : not in release mozconfig's whitelist (releases/mozilla-release/win32/nightly) : mk_add_options MOZ_PGO=1

But those don't exist. In lines like this, it builds up that path itself: http://hg.mozilla.org/build/tools/file/default/buildbot-helpers/release_sanity.py#l141

This isn't necessary now that we have an explicit list of mozconfigs + paths in the release config. We should be using that rather than trying to guess it.
Assignee: nobody → lsblakk
Assignee: lsblakk → aki
Attached patch fix (obsolete) — Splinter Review
Sample output:

2012-03-01 13:44:14,219 : INFO : Comparing firefox mozconfigs to nightly mozconfigs...
2012-03-01 13:44:54,662 : ERROR : not in release mozconfig's whitelist (browser/config/mozconfigs/macosx-universal/nightly) : ac_add_options --enable-official-branding
2012-03-01 13:44:54,662 : ERROR : not in nightly mozconfig's whitelist (browser/config/mozconfigs/macosx-universal/release) : ac_add_options --with-macbundlename-prefix=Firefox
2012-03-01 13:45:25,110 : ERROR : not in release mozconfig's whitelist (browser/config/mozconfigs/win32/nightly) : mk_add_options MOZ_PGO=1
2012-03-01 13:45:25,111 : ERROR : not in release mozconfig's whitelist (browser/config/mozconfigs/win32/nightly) : ac_add_options --enable-official-branding
2012-03-01 13:45:55,574 : ERROR : not in release mozconfig's whitelist (browser/config/mozconfigs/linux64/nightly) : ac_add_options --enable-official-branding
2012-03-01 13:45:55,575 : ERROR : not in release mozconfig's whitelist (browser/config/mozconfigs/linux64/nightly) : mk_add_options MOZ_PGO=1
2012-03-01 13:45:55,575 : ERROR : not in release mozconfig's whitelist (browser/config/mozconfigs/linux64/nightly) : mk_add_options PROFILE_GEN_SCRIPT='$(PYTHON) @MOZ_OBJDIR@/_profile/pgo/profileserver.py 10'
Attachment #602089 - Flags: review?(bhearsum)
Comment on attachment 602089 [details] [diff] [review]
fix

This is completely obsoleted by the patch in bug 725300.
Obsoleting patch, duping bug.
Attachment #602089 - Attachment is obsolete: true
Attachment #602089 - Flags: review?(bhearsum)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 725300
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.