Closed Bug 725771 Opened 8 years ago Closed 7 years ago

xpath use in console returns null elements

Categories

(DevTools :: Console, defect)

10 Branch
x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 23

People

(Reporter: d.jaffry+firefox, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

Expected and got a node list when using an xpath search using the native web console



Actual results:

The console returns the node list as a series of 'null' that are clickable. 

http://dl.dropbox.com/u/24856/Screenshots/7.png


Expected results:

The resulting node list should have the types listed instead of null. A more generic xpath search like //*[@class="foo"] should return something like [div, div, a] instead of [null, null, null], as it is currently doing
Component: Untriaged → Developer Tools: Console
QA Contact: untriaged → developer.tools.console
Status: UNCONFIRMED → NEW
Ever confirmed: true
We now show [object Array] - since bug 808370 landed.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.