Last Comment Bug 725869 - Set the plugin hang timeout back to 45s
: Set the plugin hang timeout back to 45s
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: 11 Branch
: All All
: -- normal (vote)
: mozilla13
Assigned To: Benjamin Smedberg [:bsmedberg]
:
:
Mentors:
Depends on:
Blocks: 722394
  Show dependency treegraph
 
Reported: 2012-02-09 16:16 PST by Sheila Mooney
Modified: 2013-12-27 14:28 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
+
fixed
+
fixed


Attachments

Description Sheila Mooney 2012-02-09 16:16:40 PST
We made this change back in Nov to enable us to test the browser hang detector - Bug 705365. We ended up leaving in this change which obviously has resulted in a higher number of plugin crashes. Product thinks we should change it back until we better understand what the right number is. Bug 705365, comment #6 implies that we should have taken it out for Beta. We would like this removed for Firefox 11 so adding the tracking flag.
Comment 1 Alex Keybl [:akeybl] 2012-02-09 16:57:02 PST
% pwd
/Users/akeybl/Mozilla/mozilla-beta
$ hg backout 6f079f13c06a

https://hg.mozilla.org/releases/mozilla-beta/rev/3f12a90bf9d798a830e8fa833be569795ec1135c
Comment 2 Sheila Mooney 2012-02-13 10:19:40 PST
Alex, can we get this changed in Aurora and Nightly as well?
Comment 3 Robert Kaiser 2012-02-21 10:35:53 PST
It looks like numbers on beta are coming down to normal levels - Alex, could you please check this into aurora and central as well?
Comment 4 Alex Keybl [:akeybl] 2012-02-22 12:16:00 PST
I've done this for Aurora, but Sheila mentioned she'd get in touch with bsmedberg about backing it out on m-c to make sure we have consensus.

https://hg.mozilla.org/releases/mozilla-aurora/rev/f7dee7d1368a
Comment 5 Robert Kaiser 2012-03-02 09:42:37 PST
(In reply to Alex Keybl [:akeybl] from comment #4)
> I've done this for Aurora, but Sheila mentioned she'd get in touch with
> bsmedberg about backing it out on m-c to make sure we have consensus.

From #breakpad (times in CET):
Feb 29 16:38:26 <KaiRo> bsmedberg: What's your opinion on https://bugzilla.mozilla.org/show_bug.cgi?id=725869#c4 - should we do this revert for trunk as well? (I think we should)
Feb 29 16:38:30 <firebot>       Bug 725869 nor, --, mozilla13, nobody, REOP, Set the plugin hang timeout back to 45s
Feb 29 16:39:56 <bsmedberg>     KaiRo: it's a product decision, but it seems Asa has made it
Feb 29 16:39:58 <bsmedberg>     so yeah

I guess that means we should do this revert to 45s on trunk as well. Alex?
Comment 6 Alex Keybl [:akeybl] 2012-03-06 10:41:08 PST
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #5)
> I guess that means we should do this revert to 45s on trunk as well. Alex?

Agreed - sending over to Benjamin for the final backout of bug 722394 on m-c.
Comment 7 Ted Mielczarek [:ted.mielczarek] 2012-03-08 07:48:55 PST
http://hg.mozilla.org/integration/mozilla-inbound/rev/1777403749bc
Comment 8 Marco Bonardo [::mak] 2012-03-09 05:12:38 PST
https://hg.mozilla.org/mozilla-central/rev/1777403749bc

Note You need to log in before you can comment on or make changes to this bug.