Last Comment Bug 725885 - Worker interval timers can be deleted prematurely.
: Worker interval timers can be deleted prematurely.
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: Kyle Huey [:khuey] (khuey@mozilla.com)
:
Mentors:
Depends on:
Blocks: 612311 629597 697932
  Show dependency treegraph
 
Reported: 2012-02-09 16:51 PST by Kyle Huey [:khuey] (khuey@mozilla.com)
Modified: 2012-03-29 15:30 PDT (History)
2 users (show)
khuey: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Patch (1.54 KB, patch)
2012-02-09 16:51 PST, Kyle Huey [:khuey] (khuey@mozilla.com)
bent.mozilla: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta-
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (khuey@mozilla.com) 2012-02-09 16:51:18 PST
Created attachment 595910 [details] [diff] [review]
Patch
Comment 1 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-02-09 21:28:14 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/82779bfa0c2c
Comment 2 Ed Morley [:emorley] 2012-02-10 04:57:46 PST
https://hg.mozilla.org/mozilla-central/rev/82779bfa0c2c
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-02-11 16:40:32 PST
Comment on attachment 595910 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): N/A
User impact if declined: setInterval timers in workers will disappear on slower machines.
Testing completed (on m-c, etc.): On m-c
Risk to taking this patch (and alternatives if risky): Low risk.
String changes made by this patch: N/A

This fixes a bug in a web feature that causes it to randomly break depending on the speed of the machine.  The patch is simple enough that we could uplift it (as a bonus it fixes some randomorange bugs).
Comment 4 Alex Keybl [:akeybl] 2012-02-14 17:39:59 PST
Comment on attachment 595910 [details] [diff] [review]
Patch

[Triage Comment]
Our earliest instance of this bug was from 2010 in comment 0 of 612311. Given the low-risk nature of the patch, we'll take it for Aurora 12. But we don't have any significant need for this on Beta, especially when we're only 3 weeks from finishing up the release.
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-02-15 17:48:21 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/d3c833832242

Note You need to log in before you can comment on or make changes to this bug.